Tux Guitar

Help

  Forums : Help
Subject Fluid R3 soundbank problem!



Author Message
Misha
Post: Sep 22nd 2009 at 7:10 AM

After fixing the no-sound problem in tuxguitar, I eventually also got the FluidR3 soundbank working by editing the config file (thanks to this forum as well.) Now I've encountered another problem where none of the effects work. At first I thought it was just my Gp files, where the dead notes played like they were regular notes, but when I tried just making some dead notes, they wouldn't play as dead, in fact, none of the effects work, but I'm getting the good FluidR3 sounds for the regular notes. I would be okay switching to another soundbank if I had to, but this seems like a really odd problem.

I have Ubuntu 9.04, there was also some confusion as to which folder to place the .sp2 files in (theres 4 java folders,) but I eventually created an "audio" folder in the usr/lib/jvm/java-6-openjdk/jre/lib folder, and it seems to have caught the right sounds. Hopefully I can fix this problem soon. Thanks!


Back to Top
 
Julian
Post: Sep 22nd 2009 at 12:16 PM

Hi,

well i don't have FluidR3 installed currently now to test.
but note that some instruments inside soundfonts could be configured with some sustain.
it means, don't release the note inmediatly.
To simulate dead note effect, what tuxguitar does is to play a note in a very short duration.. but if the soundfont don't release the note you never will heard the effect.

I'm not sure if it could be the problem you are having..
but you could try, change the instrument on the tuxguitar track to others.. and test if it happens allways, of it it only happens with some instruments.

Also, what MIDI port are you using ???
FluidR3 is just a soundfont.. you can load it with many software synths like gervill, timidity, fluidsynth.. etc...


Back to Top