Tux Guitar

Help

  Forums : Help
Subject Ubuntu 9.04



Author Message
Denizente
Post: Oct 11th 2009 at 6:02 PM

Hi,

I installed tuxguitar & got following message:

tuxguitar-1.1-linux-x86-jet.run" cannot be opened
No application suitable for automatic installation is available for handling this kind of file.

Any suggestions? Am I downloading the wrong one? I am almost a 100% convert to Linux & would be gutted if I had to go to Windows or use Wine for my guitar tabs....


Back to Top
 
Julian
Post: Oct 11th 2009 at 7:38 PM

If you have ubuntu, it would be better if you download the "ubuntu" package of tuxguitar.

However, to launch a .run file, you have to apply "executable" permissions, and then run it.

So under a terminal do:

cd /path_to_the_folder_where_you_downloaded_it
chmod 775 tuxguitar-1.1-linux-x86-jet.run
./tuxguitar-1.1-linux-x86-jet.run

and it will extract a new folder with the application ready to run.


Back to Top
 
Tim
Post: Oct 12th 2009 at 2:02 PM

Yep it worked, thanks so much for quick response


Back to Top
 
El brujo
Post: Oct 12th 2009 at 7:24 PM

I've installed tuxguitar, the program runs but I can't hear the gp3 sounds. I use Ubuntu 9.04. I've downloaded it from Ubuntu repositories .What can I do? Thanks


Back to Top
 
rocky
Post: Oct 17th 2009 at 3:29 PM

Install timidity from the Ubunutu repos to get the best sound.
Reboot and then use in tuxguitar settings a timidity port(1 or 2 of them work)

But know you can't listen to tuxguitar AND youtube videos at the same time. It's a boring problem in ubuntu and other distros since pulseaudio exists. There are bugreports but the problem isn't solved.

Or you download the ubuntu package from this site and you use the Gervill sound. You won't have as good sounds as with timidity, but you can listen at the same time to youtube videos


Back to Top
 
Julian
Post: Oct 20th 2009 at 2:02 PM

rocky, "You won't have as good sounds as with timidity"

With gervill you also can configure custom soundfonts,
If you are using gervill in tuxguitar, you can to to Tools -> Plugins, and configure the Java Sound Api plugin..
then you'll find options to load a custom soundfont.

the default gervill soundfont, is an "emergency" soundfont
The goal is to make it works allways, even if you didn't configure it, but if you configure a nice one you can get very nice sounds.


Back to Top
 
rocky
Post: Oct 24th 2009 at 11:27 AM

Thank you, I didn't know that!


Back to Top