Tux Guitar

Help

  Forums : Help
Subject Need help with fluidsynth



Author Message
daxh
Post: Nov 13th 2009 at 11:45 PM

Hello. I have installed tuxguitar and this is really wonderful program. But I have several problems with sound, because it works only with Java Sound Synthesizer. And this is a very bad, because when track plays I hear a small delay between sound and "track view"(or visualization).And this is really annoying. So I tried to change it and have installed fluidsynth, but don't know how to add this plugin.

I use Slackware 13.0, tuxguitar-1.2-linux-x86.tar.gz package, fluidsynth-1.1.0.tar.gz,so I have built fluidsynth from sources in /opt/fluidsynth-1.1.0 and did next things:
1) modified /etc/profile:
....
PATH=/opt/fluidsynth-1.1.0/bin:$PATH
export PATH
....
2) modified ld.so.conf
....
/opt/fluidsynth-1.1.0/lib
....
What should I do next for adding fluidsynth in tuxguitar?


Back to Top
 
Julian
Post: Nov 14th 2009 at 3:30 PM

If you downloaded tuxguitar-1.2-linux-x86.tar.gz,
tuxguitar-fluidsynth plugin must be there.

but it's disabled as default ( to don't force users to install fluidsynth as a dependency if they are not going to use it ).

So you have to enable it:

* Go to the folder:
tuxguitar-1.2-linux-x86/share/plugins/tuxguitar-fluidsynth/META-INF/services

* Open the file:
org.herac.tuxguitar.gui.system.plugins.TGPlugin

* Uncomment the first line of the file ( remove "#" character )

Then when you start tuxguitar next time, fluidsynth plugin must be loaded.


To configure it in tuxguitar, go to menu "Tools -> Plugins"
select "Fluidsynth output plugin" and click "Configure" button.
Then select a soundfont.. ( and see if you want to configure audio settings )

Then it will create a new tuxguitar MIDI Port,
so you have to select it in "Tools -> Settings" at sound section.
the new MIDI Port must be somethign like "TG Fluidsynth[soundfont_name]"

---------------------
Another option, is to run it with alsa plugin.
you can just run fluidsynth in a command line:
fluidsynth -a alsa [path_to_a_sound_font]

and then if you have tuxguitar-alsa plugin, there must be a new alsa port for fluidsynth.


Back to Top
 
daxh
Post: Nov 15th 2009 at 7:59 AM

Great thanks to you Julian, now it all works and I am glad so much !!!

As soundfont file I've used 8MBGMSFX.SF2, I've found information about it at one of the topics here but don't remember link to this file.

If anybody will need this file I am sure you could find it with Google.

Thanks again )))


Back to Top