Tux Guitar

Help

  Forums : Help
Subject When tuxguitar is on, all other audio disabled...



Author Message
Guitar_maniac
Post: Feb 24th 2010 at 10:36 PM

... and vice versa :O

I was started transcribing songs again but noticed that i cant get any sound anywhere if tuxguitar is on. Not from browser (youtube etc), not from my mysic player (im using banshee, the song just won't start) and videos don't work either.

Pretty hard transciribing song when i have to shutdown tuxguitar wuite often, put it back on and load the file etc etv.


Back to Top
 
Ulukai
Post: Feb 26th 2010 at 8:35 AM

This is an often occuring problem, a lot us users have suffered from it already. I don't know the cause exactly (probably has something to do with the midi system) but I can tell you at least 2 solutions :-)

1) Post some information about your Linux OS and how you installed Tuxguitar (what packages). Ubuntu 9.10 ships with Pulseaudio by default and it should be working if you just download Tuxguitar from the repo and select a Java soundbank.

2) Install Timidity, have it startup at boot and configure a soundbank in timidity.conf. Then select the Timidity 0 port in your Tuxguitar settings.


Back to Top
 
Guitar-Maniac
Post: Feb 26th 2010 at 9:22 PM

I'm using ubuntu 9,04, i installed the packages through tuxguitar website. I cant quite recall what package that was from the download section of the sites.. but the version is 1.2 if that helps at all.

I have installed Timidity and in order to get tuxguitar working i have to chance the ports quite often (when i start TG, sometimes it just works and sometimes have to chance the port), the ports that work are 0 an 1. others don't seem to do anything.


Back to Top
 
Ulukai
Post: Mar 3rd 2010 at 3:48 PM

You should try to use the version included in the repo of your distro. I know they are older, but will give you better compatibility.

But to try to help you, did you check that timidity starts when booting and before starting tuxguitar? Timidity works as a daemon and should be in /var/run/daemons/. So open up a terminal, enter 'ls /var/run/daemons/' and see what you get. If it's there, Tuxguitar should be working with timidity port 0 unless this is in use by another program already. Which other programs do you run when you have to select port 1?


Back to Top
 
Julian
Post: Mar 6th 2010 at 4:30 PM

Try using fluidsynth with pulseaudio as output driver..

I just finish write a similar answer here:
http://www.tuxguitar.com.ar/forum/5/1609/massive-midi-problems-with-kubuntu-9-10/

Try install the fluidsynth and fluid-soundfont-gm packages,
and exec the last command i wrote:
~$ fluidsynth -a pulseaudio -m alsa_seq -z 1024 /usr/share/sounds/sf2/FluidR3_GM.sf2

Then as you selected timidity before, go to application settings and select the fluidsynth port ( i think as default it's name is something like "Synth Input Port" )

By other hand, try to uninstall timidity, because it could continue conflict with pulseaudio.


Back to Top
 
Anonymous
Post: Apr 5th 2012 at 5:44 AM

The Louis Vuitton Outlet 2012 is ready ,the

fall&Winter items have arrived ,you can write the Louis

Vuitton Handbags On Sale
in the google website Search,then enjoy the shipping funny with low price but

beatiful Louis Vuitton items like Louis Vuitton Shoes.


Back to Top