Tux Guitar

Help

  Forums : Help
Subject no sound with sidux



Author Message
gnumm
Post: Apr 28th 2008 at 3:44 PM

hi,

i have sidux and want to use tuxguitar. so i downloaded it from the repos (1rc2). i also downloaded timidity from the repos. now i went in tuxguitar to
"tools">"settings">"sounds"
and wanted to choose a midi port. but there is nothing to choose. just an empty line. does anyone now what i could do?
actually there is no sound in tuxguitar

thanks


Back to Top
 
Julian
Post: Apr 28th 2008 at 4:23 PM

Hi,

First WARNING: if you will "modify" your GP* files.. i don't suggest you 1.0-rc2 (or RC1) there is a several bug on that version, what can make unusable your files. this bug was fixed on 1.0-RC3 version.

About the sound.
> i downloaded it from the repos
I don't know how was sidux repository packages builded.
but at first, make sure the plugins (specially sound plugins) are included on "tuxguitar" package, or if there are other packages like as: tuxguitar-alsa, tuxguitar-jsa, etc.

To see if you have sound plugins, go to "Tools -> Plugins"
and take a look if you have the "Alsa output plugin" ( to play sounds with timidity ) or the "Java Sound Api" plugin ( to play sounds with the java sound api )


Back to Top
 
gnumm
Post: Apr 28th 2008 at 4:49 PM

maybe i should say that i use the 64 bit sidux

no, i do not have these plugins
i downloaded the 64bit binary files of the rc3
there i have these plugins, but midi port line is also empty. in the repos aren't packages like tuxguitar-alsa.
i use kde, so maybe i should install other packages? kde works with xine


Back to Top
 
Julian
Post: Apr 28th 2008 at 4:57 PM

Try open a terminal and type: aconnect -o
Do you see any midi port ?

If not.. maybe you should check if you have the
snd-seq kernel module loaded: lsmod | grep snd

if it's not loaded, so load it:
modprobe snd-seq

( and restart timidity )
/etc/init.d/timidity restart


Back to Top
 
Anonymous
Post: Apr 28th 2008 at 5:13 PM

sorry, doesn't work
maybe i will try it with wine


Back to Top
 
Julian
Post: Apr 28th 2008 at 5:21 PM

What doesn't work ?
did aconnect -o show you any result ?

I'm not sure what you will try with wine..
but make sure if you don't have MIDI configured on your system. wine will not be able to play MIDI sounds.


Back to Top
 
gnumm
Post: Apr 28th 2008 at 5:22 PM

it's worse with wine :D
i don't know...


Back to Top
 
Anonymous
Post: Apr 28th 2008 at 5:23 PM

aconnect -o shows

client 14: 'Midi Through' [type=kernel]
0 'Midi Through Port-0'


Back to Top
 
Anonymous
Post: Apr 28th 2008 at 5:27 PM

Java sound api cannot be loaded
this message comes at the start

now, i can choose Midi Trough Port-0 [14-0]
but no sound


Back to Top
 
Anonymous
Post: Apr 28th 2008 at 5:34 PM

and after a reboot, aconnect -o shows nothing and the midi port line is empty


Back to Top
 
Julian
Post: Apr 28th 2008 at 5:35 PM

14:0 alsa port never sounds as default.
you need run timidity daemon.
/etc/init.d/timidity start

of if your timidity package don't have that script:
timidity -iA -Os

then you should see timidity on the "aconnect -o" result list.


Back to Top
 
Julian
Post: Apr 28th 2008 at 5:39 PM

It seems we post at same time... :)

> after a reboot, aconnect -o shows nothing

Maybe because before reboot, you loaded the snd-seq module.
modprobe snd-seq

to start that kernel module when your OS boot.. you need add "snd-seq" to /etc/modules

without that module, midi system don't works. so timidity can't start if you tried start it before the module is loaded.


Back to Top
 
Anonymous
Post: Apr 28th 2008 at 6:27 PM

yes, but now i'm later :D

i added snd-seq to modules

/etc/init.d/timidity start

shows

Timidity is not yet configured.
Enable Alsa Sequencer first by editing /etc/default/timidity.

any idea? :)

and thank you very much for the great support!


Back to Top
 
gnumm
Post: Apr 28th 2008 at 6:29 PM

GNU nano 2.0.7 Datei: /etc/default/timidity

# Defaults for TiMidity++ scripts
# sourced by /etc/init.d/timidity
# installed at /etc/default/timidity by the maintainer scripts
# $Id: timidity.default,v 1.3 2004/08/07 14:33:26 hmh Exp $

this is written in /etc/default/timidity

# This is a POSIX shell fragment
#

# Enable MIDI sequencer (ALSA), default is disabled
#TIM_ALSASEQ=true

# Setting overrides (of /etc/timidity.conf) for the ALSA sequencer daemon
TIM_ALSASEQPARAMS="-Os"


Back to Top
 
Julian
Post: Apr 28th 2008 at 6:42 PM

Just "uncomment" TIM_ALSASEQ=true
Then try start timidity again.
/etc/init.d/timidity start


Back to Top
 
gnumm
Post: Apr 28th 2008 at 7:05 PM

dear julian,

thank you very much!
tuxguitar works now perfect! (Java sound api cannot be loaded <- this message comes, but sound works fine now)

:-)

keep up the great work,

greetings from france (actually it's 9 p.m. in france)


Back to Top
 
Julian
Post: Apr 28th 2008 at 7:09 PM

> Java sound api cannot be loaded
It's a different problem from tuxguitar-jsa plugin ( you are getting sound by tuxguitar-alsa plugin now )
To see what exactly is happening, you should run tuxguitar under a terminal, and copy here the error log.


Back to Top
 
Anonymous
Post: Apr 28th 2008 at 7:14 PM

gnumm@sidux:~$ /home/gnumm/Apps/tuxguitar-1.0-rc3-linux-x86_64/tuxguitar
org.herac.tuxguitar.gui.system.plugins.TGPluginException: Java sound api cannot be loaded
at org.herac.tuxguitar.gui.system.plugins.base.TGMidiPortProviderPlugin.addPluin(Unknown Source)
at org.herac.tuxguitar.gui.system.plugins.base.TGMidiPortProviderPlugin.setEnabled(Unknown Source)
at org.herac.tuxguitar.gui.system.plugins.base.TGPluginList.setEnabled(Unknown Source)
at org.herac.tuxguitar.gui.system.plugins.TGPluginManager.openPlugins(Unknown Source)
at org.herac.tuxguitar.gui.TuxGuitar.displayGUI(Unknown Source)
at org.herac.tuxguitar.gui.TGMain.main(Unknown Source)
Caused by: org.herac.tuxguitar.player.base.MidiPlayerException: Java sound api cannot be loaded
at org.herac.tuxguitar.player.impl.jsa.midiport.MidiPortProviderImpl.listPorts(Unknown Source)
at org.herac.tuxguitar.player.base.MidiPlayer.addPortProvider(Unknown Source)
at org.herac.tuxguitar.gui.system.plugins.base.TGMidiPortProviderPlugin.addPluin(Unknown Source)
...5 more
Caused by: java.lang.UnsatisfiedLinkError: init_
at gnu.javax.sound.midi.alsa.AlsaMidiDeviceProvider.init_(libgcj.so.90)
at gnu.javax.sound.midi.alsa.AlsaMidiDeviceProvider.(libgcj.so.90)
at java.lang.Class.initializeClass(libgcj.so.90)
at java.lang.Class.newInstance(libgcj.so.90)
at gnu.classpath.ServiceProviderLoadingAction.run(libgcj.so.90)
at java.security.AccessController.doPrivileged(libgcj.so.90)
at gnu.classpath.ServiceFactory$ServiceIterator.loadNextServiceProvider(libgcj.so.90)
at gnu.classpath.ServiceFactory$ServiceIterator.(libgcj.so.90)
at gnu.classpath.ServiceFactory.lookupProviders(libgcj.so.90)
at javax.sound.midi.MidiSystem.getMidiDeviceInfo(libgcj.so.90)
at org.herac.tuxguitar.player.impl.jsa.midiport.MidiPortProviderImpl.listPorts(Unknown Source)
...7 more


this is the message


Back to Top
 
Julian
Post: Apr 28th 2008 at 7:25 PM

Ok, it's caused because you are running tuxguitar with GCJ.
see all "(libgcj.so.90)" at the end of last lines..
tuxguitar 1.0-* is now GCJ compat.. but some plugins ( like this tuxguitar-jsa ) can't work under it, because GCJ don't implements Java Sound Api at all.

By the way, if you are using tuxguitar-alsa.. you don't need java sound api plugin.. so you can just disable the plugin ( Tools -> Plugins )..
or, remove it by removing the file tuxguitar-[version]/share/plugins/tuxguitar-jsa.jar


Back to Top
 
Anonymous
Post: Apr 28th 2008 at 7:44 PM

ok, thanks, i just disabled the plugin :)


Back to Top
 
gnumm
Post: May 1st 2008 at 1:18 PM

> First WARNING: if you will "modify" your GP* files.. i don't suggest you 1.0-rc2 (or RC1) there is a several bug on that version, what can make unusable your files. this bug was fixed on 1.0-RC3 version.


just to let you know: i reported this bug to a debian maintainer as a bug report and asked if the rc3 could be uploaded.


Back to Top
 
gnumm
Post: May 1st 2008 at 2:05 PM

just to let you know ;)

the maintainer answered he already prepared the rc3 because it's a known bug
http://mentors.debian.net/debian/pool/contrib/t/tuxguitar/

"now waiting it to be uploaded"


Back to Top
 
gnumm
Post: May 2nd 2008 at 7:39 AM

update: the rc3 is now awailable from the debian unstable repositories


Back to Top
 
Christian Louboutin Wedding Shoes
Post: Apr 17th 2012 at 8:43 AM

Even the packaging around the Christian Louboutin Barbie Shoes Christian Louboutin Ankle Boots is exciting. Each pair of shoes comes in a tiny little box and includes a shoe bag for Cheap Louboutin Sneakers each Christian Louboutin Wedding Shoes pair. No self-respecting owner would want to hide these out of sight, so these nine pairs of Cheap Louboutins fabulous shoes come with a 13-inches tall x 10-inches wide x 3-inches long display box. Best of all, this entire collection can be purchased for less than $60! I wish I could find nine pairs of stunning Louboutin shoes for that price, for my big old human Cheap Louboutin Pumps feet! At that price, this collection is an ideal gift for the Barbie enthusiast's special occasion


Discount Louboutins



Back to Top
 
jordan shoes
Post: Apr 19th 2012 at 8:12 AM

jordan shoes


Back to Top
 
Anonymous
Post: Apr 20th 2012 at 1:07 AM

We proudly offers Plus Size Dresses for our larger girls. prom dresses 2012 Full figures can look gorgeous in dresses by the top designers in the industry.short prom dresses 2012When big really can be beautiful, we are sure you will find the perfect Plus Size Dresses for prom or any other social occasion with our variety of designers from which to choose. plus size prom dresses Dress to impress your family, prom dresses under 100 friends, and colleagues with a Plus Size Dress from EDES for your very special event! Little black dresses are a popular go-to style for all generations. Black is a classic color in fashion that looks great on all body types. Little Black dresses are especially popular for Prom, Evening attire, plus size evening dresses Engagements and New Year's Eve dresses. Little Black Dresses are always in style and can be used for numerous occasions, you can never have too many little black dresses.


Back to Top