Tux Guitar

Problems

Subject For the suggestion box



Author Message
Just say know
Post: Feb 19th 2009 at 6:48 PM

After three crashes in two days (windows xp), with loss of nearly all my work, it occurred to me to suggest the programmers add a timed automatic "save draft" option.

I'd also appreciate not having to jack with the soundbank. (I downloaded the Java "deluxe" package and put in the audio folder as instructed but never could get it to work.)

I know, I know ... it's me and my flaky computer, not your program. Still ...


Back to Top
 
NagMacFeegle
Post: Feb 19th 2009 at 8:08 PM

you have to install the tuxguitar-jsa plugin and select the "Java Sound Synthesizer".
Works for me, and uses soundbank-deluxe, when installed properly.


Back to Top
 
Just say KNOW
Post: Feb 20th 2009 at 6:35 PM

Thanks for the response. The Java plugin is enabled (default setting) and Java Sound Synthesizer is selected. The deluxe sound package is located in Java/jre6/lib/audio folder.

Still no joy. Track properties shows just the five guitar sounds. No other choices.


Back to Top
 
Julian
Post: Mar 1st 2009 at 4:26 PM

We can make a plugin that automatically saves a temporal song (don't like to write on the original one if user don't decide it) every X minutes. i like the idea..

What is exactly your problem with the sound ??
can't you listen anything ??? or you just can't listen the new soundbank sounds ?


Back to Top
 
just say Know
Post: Mar 2nd 2009 at 2:45 PM

Thank you for the response, and for considering implementation of my idea. Frankly, I am loathe to use Tux until the "save draft" plug-in is ready.

I can hear sound and have the five default guitar sounds to select from in the Track Properties box. Those work fine.

But, as stated in my first post, I can't figure out how to make the Java "deluxe" soundbank appear in the Track Properties box. As stated above, the file "soundbank-deluxe.gm" is located in the correct folder (Java/jre6/lib/audio). Tux can't seem to find that....


Back to Top
 
Julian
Post: Mar 3rd 2009 at 10:54 AM

Ok, now i understand the point. it's not how it works.

Currently now, there is no support for multiple banks, you can only load 1 bank on global settings.
so you don't need to go to track -> properties to select it. there you just need to selecet an instrument.

To select a different sound port on tuxguitar, you need to go to "Tools -> Settings", at sound tab. then select one on "MIDI Port"

The soundbank "deluxe" is a "Java Sound Synthesizer" thing.
to make it run, you need to have this port selected.
if you have a different midi port selected, so the java soundbank will not be loaded.

But note that it will change the sounds, not the instrument names. so on track properties you will see allways same instrument names. just click play to listen the changes.


Back to Top