Tux Guitar

Problems

Subject java.lang.UnsatisfiedLinkError



Author Message
jan
Post: Feb 28th 2009 at 12:12 PM

Hey!

I really admire your work on TuxGuitar and had id work on some systems but my new opensuse11.2 is making some problems...
here my errorlog

Exception in thread "main" java.lang.UnsatisfiedLinkError: Cannot load 32-bit SWT libraries on 64-bit JVM
at org.eclipse.swt.internal.Library.loadLibrary(Unknown Source)
at org.eclipse.swt.internal.Library.loadLibrary(Unknown Source)
at org.eclipse.swt.internal.C.(Unknown Source)
at org.eclipse.swt.internal.Converter.wcsToMbcs(Unknown Source)
at org.eclipse.swt.internal.Converter.wcsToMbcs(Unknown Source)
at org.eclipse.swt.widgets.Display.(Unknown Source)
at org.herac.tuxguitar.gui.TuxGuitar.displayGUI(Unknown Source)
at org.herac.tuxguitar.gui.TGMain.main(Unknown Source)

I installed all swt-libraries i could find in Yast and also Java, but coudn't find any 32-bit versions.

thanks for your help
jan


Back to Top
 
Julian
Post: Mar 1st 2009 at 4:46 PM

if you are running a 64 bit JVM, so you need a 64 bit version of SWT (you have a 32 bit version of it).
try get them, or just download the x86_64 version of tuxguitar that already have included SWT libraries.

http://downloads.sourceforge.net/tuxguitar/tuxguitar-1.0-linux-x86_64.tar.gz

Just uncompress the downloaded file, and make 2 click to "tuxguitar" inside tuxguitar-1.0-linux-x86_64 folder


Back to Top
 
jan
Post: Mar 1st 2009 at 7:26 PM

Hey!

Thanks a lot! Now it works.


Back to Top