Tux Guitar

Problems

Subject Unable to make tabs display in more than 2 colums



Author Message
Michael Bushey
Post: Apr 6th 2009 at 9:52 AM

Linear layout displays the tab on one line, page layout displays the tab on two lines. I would like to use the up and down slider to go through my tab, like how a text editor works. It used to work this way. Here's a screenshot in case I'm not explaining it properly:

http://twin.sendthemtomir.com/sendthemtomir.com/tuxguitar.png


Back to Top
 
Michael Bushey
Post: Apr 6th 2009 at 10:16 AM

It looks like what it's doing is taking the width of my dual monitor display (1680 x 2 = 3360) and using that no matter what I size the tuxguitar window to when in page layout.


Back to Top
 
Julian
Post: Apr 6th 2009 at 1:12 PM

yes, this is a known issue..
its because the two screen configuration mode.
i'm not exactly sure how to explain it.. but it's something like you have a configuration over the xorg conf. so for xorg you really have 1 big screen instead of 2.
when

so my question is, did you configured your dual screen from xorg.conf or did you from any kind of setup of your video driver ?

By the way, you can "force" the width of the monitor.
try open tuxguitar config files (note that .tuxguitar is a hidden folder) with any text editor
/home/YourUser/.tuxguitar/config.properties

and add this line:
layout.page.force-width=1680

make sure that you are editing the file with tuxguitar closed. otherwise, tuxguitar will override your changes when close.


Back to Top
 
Michael Bushey
Post: Apr 24th 2009 at 4:30 PM

I configured X with nvidia-settings. The interesting thing is right around the time I had this issue the behavior of maximizing windows changed, it went from maximize to the monitor the windows was on to maximizing to fill up both windows. I changed motherboards and shuffled some stuff around so that's probably what caused it, and I think tuxguitar was fine before that.

The layout.page.force-width hack is working, thanks.


Back to Top