Tux Guitar

Problems

Subject Error (FreeBSD 7.1)



Author Message
bassman
Post: Jun 18th 2009 at 10:57 AM

When I start Tuxguitar on FreeBSD 7.1, I get following message:

$ tuxguitar
1.png: not found
2.png: not found
4.png: not found
8.png: not found
16.png: not found
32.png: not found
64.png: not found
tempo.png: not found
grace.png: not found
layout_page.png: not found
layout_linear.png: not found
layout_multitrack.png: not found
layout_score.png: not found
layout_compact.png: not found
new.png: not found
open.png: not found
save.png: not found
save-as.png: not found
print.png: not found
print-preview.png: not found
edit_undo.png: not found
edit_redo.png: not found
edit_voice_1.png: not found
edit_voice_2.png: not found
edit_mode_selection.png: not found
edit_mode_edition.png: not found
edit_mode_edition_no_natural.png: not found
icon.png: not found
splash.png: not found
about_description.png: not found
about_license.png: not found
about_authors.png: not found
option_view.png: not found
option_style.png: not found
option_sound.png: not found
option_skin.png: not found
option_language.png: not found
option_toolbars.png: not found
timesignature.png: not found
tempoicon.png: not found
openrepeat.png: not found
closerepeat.png: not found
repeat_alternative.png: not found
song_properties.png: not found
track_add.png: not found
track_remove.png: not found
dotted.png: not found
doubledotted.png: not found
tupleto.png: not found
fretboard.png: not found
firstfret.png: not found
fret.png: not found
chord.png: not found
tiednote.png: not found
transport.png: not found
transport_first_1.png: not found
transport_first_2.png: not found
transport_last_1.png: not found
transport_last_2.png: not found
transport_previous_1.png: not found
transport_previous_2.png: not found
transport_next_1.png: not found
transport_next_2.png: not found
transport_stop_1.png: not found
transport_stop_2.png: not found
transport_play_1.png: not found
transport_play_2.png: not found
transport_pause.png: not found
transport_icon_first_1.png: not found
transport_icon_first_2.png: not found
transport_icon_last_1.png: not found
transport_icon_last_2.png: not found
transport_icon_previous_1.png: not found
transport_icon_previous_2.png: not found
transport_icon_next_1.png: not found
transport_icon_next_2.png: not found
transport_icon_stop_1.png: not found
transport_icon_stop_2.png: not found
transport_icon_play_1.png: not found
transport_icon_play_2.png: not found
transport_icon_pause.png: not found
transport_metronome.png: not found
transport_mode.png: not found
marker_list.png: not found
marker_add.png: not found
marker_remove.png: not found
marker_first.png: not found
marker_last.png: not found
marker_previous.png: not found
marker_next.png: not found
mixer.png: not found
dynamic_ppp.png: not found
dynamic_pp.png: not found
dynamic_p.png: not found
dynamic_mp.png: not found
dynamic_mf.png: not found
dynamic_f.png: not found
dynamic_ff.png: not found
dynamic_fff.png: not found
effect_dead.png: not found
effect_ghost.png: not found
effect_accentuated.png: not found
effect_heavy_accentuated.png: not found
effect_harmonic.png: not found
effect_grace.png: not found
effect_bend.png: not found
effect_tremolo_bar.png: not found
effect_slide.png: not found
effect_hammer.png: not found
effect_vibrato.png: not found
effect_trill.png: not found
effect_tremolo_picking.png: not found
effect_palm_mute.png: not found
effect_staccato.png: not found
effect_tapping.png: not found
effect_slapping.png: not found
effect_popping.png: not found
effect_fade_in.png: not found
browser_new.png: not found
browser_file.png: not found
browser_folder.png: not found
browser_root.png: not found
browser_back.png: not found
browser_refresh.png: not found
settings.png: not found
Exception in thread "main" org.eclipse.swt.SWTException: Unable to load graphics library [Cairo is required] (java.lang.UnsatisfiedLinkError: no swt-cairo-gtk-3448 or swt-cairo-gtk in swt.library.path, java.library.path or the jar file)
at org.eclipse.swt.SWT.error(Unknown Source)
at org.eclipse.swt.graphics.Device.checkCairo(Unknown Source)
at org.eclipse.swt.graphics.Path.(Unknown Source)
at org.herac.tuxguitar.gui.editors.TGPainter.initPath(Unknown Source)
at org.herac.tuxguitar.gui.editors.tab.TGResources.getImage(Unknown Source)
at org.herac.tuxguitar.gui.editors.tab.TGResources.getScoreNoteImage(Unknown Source)
at org.herac.tuxguitar.gui.editors.tab.TGResources.initImages(Unknown Source)
at org.herac.tuxguitar.gui.editors.tab.TGResources.load(Unknown Source)
at org.herac.tuxguitar.gui.editors.tab.layout.ViewLayout.reloadStyles(Unknown Source)
at org.herac.tuxguitar.gui.editors.tab.Tablature.reloadStyles(Unknown Source)
at org.herac.tuxguitar.gui.editors.tab.Tablature.setViewLayout(Unknown Source)
at org.herac.tuxguitar.gui.editors.tab.Tablature.loadViewLayout(Unknown Source)
at org.herac.tuxguitar.gui.editors.tab.Tablature.reloadViewLayout(Unknown Source)
at org.herac.tuxguitar.gui.editors.TablatureEditor.showTablature(Unknown Source)
at org.herac.tuxguitar.gui.TuxGuitar.createComposites(Unknown Source)
at org.herac.tuxguitar.gui.TuxGuitar.displayGUI(Unknown Source)
at org.herac.tuxguitar.gui.TGMain.main(Unknown Source)
Caused by: java.lang.UnsatisfiedLinkError: no swt-cairo-gtk-3448 or swt-cairo-gtk in swt.library.path, java.library.path or the jar file
at org.eclipse.swt.internal.Library.loadLibrary(Unknown Source)
at org.eclipse.swt.internal.Library.loadLibrary(Unknown Source)
at org.eclipse.swt.internal.cairo.Cairo.(Unknown Source)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Class.java:169)
... 16 more

Where could be the problem?


Back to Top
 
Julian
Post: Jun 29th 2009 at 3:45 PM

There is something wrong on your package.
show me please the content of this "tuxguitar" script.
some classpath entries, and java.libray.path seems missing.


Back to Top