Tux Guitar

Problems

Subject No Sound in Fedora 11 x86_64



Author Message
Keith
Post: Jul 4th 2009 at 9:02 AM

Hello everyone,

Recently upgraded from Fedora 10 x86_64 to Fedora 11 x86_64 and of course, now I don't get any sound from Tux. I reinstalled Tux using yum from the Fedora repositories and it failed to start. I was getting the following message:

$MOZILLA_FIVE_HOME not valid : check doc shipped w/ tuxguitar
/usr/bin/tuxguitar: line 154: /usr/java/jre1.6.0_10/jre/bin/java: No such file or directory

So I went into /usr/bin/tuxguitar and changed line 104 from
JAVA=${JAVA:=${JAVA_HOME}/jre/bin/java}
to
JAVA=${JAVA:=${JAVA_HOME}/bin/java}

because the path to java on my system is actually /usr/java/jre1.6.0_10/bin/java. Any ideas on why this occurred? Just trying to figure out if it is something weird with the path on my system or the install from the repository.

Editing the script, I now have version 1.1 running, but as soon as I launch the app, I get the message "Gervill Synthesizer is not available." Looking under Tools->Settings->Sound, nothing is listed under MIDI...the drop down box is greyed out. Ran the command lsmod | grep snd_seq and didn't receive any output. So something with F11 isn't recognizing my hardware correctly...maybe the problem is with pulse audio?

Running Tux through terminal, I get the following error messages:
$MOZILLA_FIVE_HOME not valid : check doc shipped w/ tuxguitar

ALSA lib seq_hw.c:457:(snd_seq_hw_open) open /dev/snd/seq failed: No such file or directory
/dev/sequencer: No such file or directory

(TuxGuitar:3113): Gdk-CRITICAL **: gdk_x11_atom_to_xatom_for_display: assertion `atom != GDK_NONE' failed

Any ideas on solutions to try to get the sound working again?


Back to Top
 
Julian
Post: Jul 4th 2009 at 4:48 PM

>> because the path to java on my system is actually /usr/java/jre1.6.0_10/bin/java. Any ideas on why this occurred?

The answer is easy.
You may have installed
JRE ( Java Runtime Edition )
or
JDK ( Java Development Kit ).

when you install JDK, it have inside the jre folder.
just something like:

JDK_PATH/jre/bin/java

but if you have installed the JRE.
JRE_PATH is the "jre" folder..

take a look to your path:
/usr/java/jre1.6.0_10/bin/java

the real jre folder is "jre1.6.0_10"

allmost times the best option is to use:
$JAVA_HOME/bin/java
because JDK, have a bin folder with links to the jre bin folder.

now, these scripts were not made by us, you should report this problem to the package mantainer of fedora.


About the sound,
because this error "/dev/snd/seq failed: No such file or directory"
i beleive that you don't have the snd_seq kernel module loaded.

make the try
lsmod | grep snd_seq

( or snd-seq, i don't remember if it's - or _ )

if you don't see it loaded,
try load it as root
modprobe snd_seq
or
modprobe snd-seq


Back to Top
 
radt
Post: Aug 17th 2009 at 5:19 PM

1-update openjdk to its latest and then
try to select openjdk by entering the following command
# alternatives --config java

There are 3 programs which provide 'java'.

Selection Command
-----------------------------------------------
* 1 /usr/lib/jvm/jre-1.6.0-openjdk/bin/java
2 /usr/lib/jvm/jre-1.5.0-gcj/bin/java
+ 3 /usr/java/default/bin/java

Enter to keep the current selection[+], or type selection number:
############################
in this case it would be 1 and try running tuxguitar again. It fixed the problem to me.


Back to Top
 
Ben Engbers
Post: Sep 1st 2009 at 3:52 PM

After updating to Fedora 11, TuxGuitar starts but give the warning that "Gervill synthesizer is not available".

Other programs produce sound (not always of good quality, but it works) and output for lsmod | grep snd_seq is:
snd_seq_dummy 2448 0
snd_seq_oss 27184 1
snd_seq_midi_event 5564 1 snd_seq_oss
snd_seq 45148 6 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device 5988 3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_timer 17888 2 snd_seq,snd_pcm
snd 49072 20 snd_hda_codec_si3054,snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_seq_dummy,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer

Any idea how I can get Gervill to prudice sound?


Back to Top
 
Julian
Post: Sep 5th 2009 at 1:49 PM

Ben Engbers,

This is because your tuxguitar package should have "tuxguitar-gervill" installed ( that allows you to export to audio )
but you don't seems to have gervill at your CLASSPATH.

Gervill, is as default available on openjdk (as replace of the closed java sound synthesizer )
but if you are running sun's jdk, you don't have it as default.
this is why we didn't distributed this plugin as defatul in official releases.

now you have some options:
1_ disable the gervill plugin (or uninstall it) to don't see this error anymore.

2_ use openjdk instead of other java version..

3_ install gervill into your java version. (just adding gervill.jar in jre/lib/ext/ folder )
https://gervill.dev.java.net/


Back to Top