Tux Guitar

Problems

Subject TuxGuitar delete soundfonts on Qsynth (Fluidsynth)



Author Message
Francesco
Post: Jul 18th 2009 at 9:10 AM

Hallo ,
I am using Ubuntu 9.04 and I am trying to use TuxGuitar for my Guitar training but I have this problem :
when I start TuxGuitar the sound fonts in Fludsynth ( used with Qsynth GUI interface) for the used channels in TXG are deleted .

The programs running are :
Jack Control
Fluidsynth ( configured via Qsynth)
TUX Guitar

Is TuxGuitar sending the *.sf2 font to Fluidsynth ??

Where can I set these fonts ??

Thanks Ciao .
Francesco


Back to Top
 
Julian
Post: Jul 19th 2009 at 3:22 PM

No it is a normal thing, tuxguitar don't delete soundfonts, it just send midi messages to alsa ( and fluidsynth get these messages from alsa )
one of these standard midi messages is the "PROGRAM CHANGE" message.
this message loads a program in a channel.

it sends something like:
PROGRAM_CHANGE CHANNEL_NUMBER INSTRUMENT_NUMBER

this is the way you have in MIDI to load instruments ( without it, all may sounds with default instrument 0: Piano )

now on qsynth, you can load instruments by channel too.. but when fluidsynth receibe the events, all is reseted.

the problem is that these kind of features to load instruments by channel on the synth, are more planned to record MIDI ( not for notation editors ) where you could connect a keyboard, and you set the channel on the keyboard (not instrument) and then qsynth just use this channel.

but for notation editors, or midi players.. it's very different..
you could try same thing with a midi player..

for example with aplaymidi:
aplaymidi -p cient:port YourFile.mid

and you'll see that playing the file, also will reset your channels configuration from qsynth.

so about your question: "
Is TuxGuitar sending the *.sf2 font to Fluidsynth ??"

The answer is no, tuxguitar isn't sending sf2 files ( tuxguitar don't know about qsynth or .sf2 existense.. only about ALSA and standard MIDI protocol )
tuxguitar just say to alsa something like " the channel 5, is a distortion guitar "
then the port connected to alsa (in this case fluidsynth) receibe this message and do the job.


Back to Top
 
Francesco
Post: Jul 19th 2009 at 9:02 PM

Julian ,
thank for the replay ... I believe I have understand the process , but I do not have really understand why I'am not able to have any sound out from TuxGuitar .. using FluidSynth ( with or without Qsynth)
You are rigth also using the command :
aplaymidi -p client:port YourFile.mid
I have the same problem the channels soundfont is deleted and no sound are comming out.
I have try to use both plug-us :
TuxGuitar-jsa and TuxGuitar-Fluidsynth
Do you have an example of configuration for Fluidsynth to show me ??
Ciao e grazie


Back to Top
 
Julian
Post: Jul 19th 2009 at 11:24 PM

now i'm confused.. I'm not so clear if fluidsynth isn't working, or if it's just a soundfont problem.

make sure that you are using a GM soundfont ( 127 general midi instruments )
because some soundfonts, only contains 1 instrument.. and if the requested instrument isn't available, so there is no sound to heard...

try download this one ( a little soundfont ) to test:
http://alsa.opensrc.org/8MBGMSFX.SF2

execute on a terminal
fluidsynth /path_to_the_file.sf2

and without close the terminal, select the port in tuxguitar..
if it still not sounds, so you maybe have a problem with your OS configuration.

but, warning with this..
tuxguitar-fluidsynht, is another thing..
i mean.. when you run fluidsynth by a terminal.. or by qsynth.. what you are doing is creating an ALSA midi port.
so on tuxguitar you connect to it with "tuxguitar-alsa" plugin..

tuxguitar-fluidsynth plugin, works with fluidsynth ( without use alsa )
to try it, you must go to "Tools -> Plugins" in tuxguitar menu.. and click configure on the fluidsynth plugin..
then you select the soundfonts you want.
then once you configured the soundfonts, you could select a fluidsynth port in Tools -> Settings : Sound..

If you are having problems with your OS midi configuration ( not only tuxguitar ).. do you maybe have pulseaudio installed ???
if the answer is yes, try download the latest fluidsynth version 1.0.9 that includes pulseaudio driver support..
then start fluidsynth with pulseaudio driver ( if you do this, make sure the audio periods size of fluidsynth configuration is setter to 1024 or higher )


Back to Top
 
Francesco
Post: Jul 21st 2009 at 11:35 AM

Julian,
thanks for your support, that was a soundfont problems , I was using a font with only 8 instruments :-) !!.
I have loaded the file http://alsa.opensrc.org/8MBGMSFX.SF2
as per your suggestion and now the fluidsynth is working fine with TUXGUITAR in alsa nmode.
As soon I will have time I will test also the tuxguitar-fluidsynth plugin and I will let you know if any problems .
Ciao e grazie ... Francesco


Back to Top