Tux Guitar

Problems

Subject How to install ALSA plugin?????? Please help!!!



Author Message
vlad
Post: Aug 16th 2009 at 5:53 AM

Hello I recently lost sound on my tux guitar so my guess is to install the also plug in.So I click properties on tux guitar I click find target I go to share I go to plug ins and the website says to copy and paste it on there.So I click plug ins and I make a new folder and call it what this website tells me to call it yet it doesnt show in the program i would click tools and plugins but it isnt there am i doing something wrong?Please help me I really want tux guitar to sound.


Back to Top
 
mihai
Post: Aug 17th 2009 at 12:34 AM

Install TiMidity (a midi synthesiser).
Then in TuxGuitar Options choose it as the MIDI port.
Good luck.


Back to Top
 
Julian
Post: Aug 17th 2009 at 8:15 PM

vlad, did you built tuxguitar from sources ?? or did you got if from another place ??
tuxguitar-alsa is prebuilt as default in tuxguitar releases


Back to Top
 
Anonymous
Post: Aug 19th 2009 at 11:10 PM

Well I have a windows XP and I don't know perhaps I installed it wrong but I installed it here like I went to downloads and clicked only one of the download links.Am I supposed to download them all? The thing is I don't have sound so I choose Java and it's a really nasty sounds.I used to have great sound until one day I couldn't hear anything I don't know what happened but I want the old sound back.


Back to Top
 
Julian
Post: Aug 20th 2009 at 9:18 PM

No, wait..

ALSA means: "Advanced Linux Sound Architecture"
See: http://www.alsa-project.org/

It's a Linux kernel sound system.. so it depends on linux based operating systems.

You are running Windos XP operating system ( that is different ).

ALSA don't works under Windows, so tuxguitar-alsa plugin will never works under it.

Now....
The "Java Sound Synthesizer" is very poor. we are agree on that..
what about your Windows native MIDI ???
Windows as default provide MIDI ports.. don't they works ???
try to see on your control volume settings, if they are not muted.. or something like...

Another option, is to use TuxGuitar-fludsynth plugin..
if you have latest version, you should have it installed..
see on "Tools -> Plugins" if you have fluidsynth plugin..
if yes, you can click on "Configure" button.. and you'll find options to load a soundfont file ( .sf2 ).
there are some .sf2 files that you can download..
just to try.. see this ( small ) one:
http://alsa.opensrc.org/8MBGMSFX.SF2

you download it, select it on the tuxguitar-fluidsynth configuration..
and then. if you go to sound settings again..
on MIDI Port, you should see the option
TG FluidSynt [8MBGMSFX.SF2]
Select it.. and test the sounds..


Back to Top