Tux Guitar

Problems

Subject The more tracks, the less visible tabs?!



Author Message
LukeX
Post: Sep 20th 2009 at 6:09 PM

Hey, fellow TuxGuitar users!

Hopefully I'll be able to express what I want...
The more instruments a tab uses, the more tracks are displayed in the track list,---> so, logically it gets bigger!
So the bigger the track list gets, the less tabs/score are visible!
So how can I get rid of this track-list, which I don't need an which covers all the tabs I need to see?

Please, would be cool if someone knew how to deal with this?!

greets
Luke


Back to Top
 
Julian
Post: Sep 22nd 2009 at 11:55 AM

We have planned something like for future releases..

anyway, did you know that you could resize this bottom table ??


Back to Top
 
LukeX
Post: Sep 22nd 2009 at 9:45 PM

Hey, glad somebody knows what I mean! :D

Well, I use TG 1.0 rc4 and besides the main window, I'm not able to resize anything else! I tried that before!
If it is possible I just haven't found out how! ;)

thx, greets!
Luke


Back to Top
 
WurdBendur
Post: Sep 24th 2009 at 9:07 PM

That's the same version I have (on Mac OS), and it works for me ... most of the time. I just went to Help > About to check the version, and then it stopped working.

But when it does work, you can just put he mouse in the space above the track list, and the cursor will turn into the little arrows thing to tell you that you can resize it.


Back to Top
 
Julian
Post: Sep 24th 2009 at 10:24 PM

There is an SWT known bug under windows ( maybe under mac too ) with this sash control.
When the main shell changes the cursor (every dialogs you open in tuxguitar, displays a wait cursor until open)..
then the sash composite cursor don't back to original state.
so you can't see the "Resize" cursor.
but, the feature still works, even if it's not visible.. but ofcourse you need to find the place where to start dragging..

For next version i tried to make a little fix for this problem, forcing set the sash cursor every time the mouse is over it.

The position of this sash to drag, is
under the horizontal scrollbar of the tablature ( just 1 or 2 pixels next to it )

If you will use this feature, i suggest you go to Settings.
and uncheck "Enable Automatic table resizing"
Otherwise, the table will autoadjust every time you open a song, or add/remove tracks.


Back to Top
 
LukeX
Post: Sep 25th 2009 at 6:44 PM

Yeah,...seems to be caused by this bug! The other cursor doesn't appear, but I can now resize the track-list! :D....
cool, exactly what I wanted!

Thank you very, very much and keep up the good work, I really like to use TuxGuitar!

greets
Luke


Back to Top
 
Julian
Post: Sep 25th 2009 at 8:55 PM

In theory, the cursor problem will be solved on next release.


Back to Top