Tux Guitar

Problems

Subject When I press play the program closes!



Author Message
PEPE90210
Post: Feb 16th 2007 at 1:50 PM

Hi when i load a tab in tuxguitar i press play and the program just closes!

Can you help please? Thanks


Back to Top
 
Julian
Post: Feb 16th 2007 at 2:23 PM

Hi,
what file release of tuxguitar do you have installed?


Back to Top
 
PEPE
Post: Feb 16th 2007 at 5:17 PM

I have version 2.1


Back to Top
 
Julian
Post: Feb 16th 2007 at 5:33 PM

Hi,
>I have version 2.1
the last release of tuxguitar is 0.9 :p

but i don't ask you about version...
i ask you about the file release(*.exe, *.tar.gz,*.deb....)
i need see the error log to know the problem...
you should exec tuxguitar under a system teminal, so i need know what release do you have, before tell you how you can see that log.


Back to Top
 
PEPE
Post: Feb 16th 2007 at 8:09 PM

Allright sorry about that! I'm on ubuntu Linux and I installed it with Synaptic (apt depots packages).
When I launch it in a terminal this is what is says :

$ tuxguitar
ALSA lib seq_hw.c:457:(snd_seq_hw_open) open /dev/snd/seq failed: Aucun fichier ou répertoire de ce type
javax.sound.midi.MidiUnavailableException: Audio Device Unavailable
at com.sun.media.sound.MixerSynth.implOpen(MixerSynth.java:154)
at com.sun.media.sound.AbstractMidiDevice.doOpen(AbstractMidiDevice.java:144)
at com.sun.media.sound.AbstractMidiDevice.open(AbstractMidiDevice.java:108)
at org.herac.tuxguitar.player.impl.MidiPlayerImpl.setSynthesizer(Unknown Source)
at org.herac.tuxguitar.player.impl.MidiPlayerImpl.getSynthesizer(Unknown Source)
at org.herac.tuxguitar.player.impl.MidiPlayerImpl.init(Unknown Source)
at org.herac.tuxguitar.player.impl.MidiPlayerImpl.(Unknown Source)
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
at java.lang.reflect.Constructor.newInstance(Constructor.java:494)
at java.lang.Class.newInstance0(Class.java:350)
at java.lang.Class.newInstance(Class.java:303)
at org.herac.tuxguitar.gui.util.ClassLoaderUtil.newInstance(Unknown Source)
at org.herac.tuxguitar.gui.util.ClassLoaderUtil.newInstance(Unknown Source)
at org.herac.tuxguitar.gui.TuxGuitar.initPlayer(Unknown Source)
at org.herac.tuxguitar_alsa.plugin.TGPluginImpl.loadSynthesizer(Unknown Source)
at org.herac.tuxguitar_alsa.plugin.TGPluginImpl.init(Unknown Source)
at org.herac.tuxguitar.gui.system.plugins.PluginManager.initPLugins(Unknown Source)
at org.herac.tuxguitar.gui.TuxGuitar.initPluginManager(Unknown Source)
at org.herac.tuxguitar.gui.TuxGuitar.displayGUI(Unknown Source)
at org.herac.tuxguitar.gui.TuxGuitar.main(Unknown Source)


Thanks


Back to Top
 
Julian
Post: Feb 17th 2007 at 8:49 AM

Hi,

try load "snd_seq" kernel module:
$sudo modprobe snd_seq

if it works you can add "snd_seq" line at /etc/modules to load this module when kernel boot.


Back to Top
 
PEPe
Post: Feb 17th 2007 at 9:10 AM

Thanks alot it works now!


Back to Top
 
PEPE
Post: Feb 17th 2007 at 9:16 AM

It workd when I press play but I don't have anny sound. I have the soundbank activated and i installed alsa-oss.

Thanks


Back to Top
 
Julian
Post: Feb 17th 2007 at 10:03 AM

is there any new error log ?


Back to Top
 
PEPE
Post: Feb 17th 2007 at 10:43 AM

No, when I launch tuxguitar in a terminal no errors are written but there still is no sound


Back to Top
 
Julian
Post: Feb 17th 2007 at 11:12 AM

mm i'm not sure what can it be...

maybe you have installed the "tuxguitar-alsa" plugin ???

if you have.. check at "plugins" section to select a valid midi device (try with timidity)

if you don't have installed the plugin.. i'm not sure what hapend.. so.. i suggest you try the plugin.

##if you don't know how install timidity on ubuntu:

1_ sudo apt-get install timidity
2_ edit "/etc/default/timidity" file, and uncomment "TIM_ALSASEQ=true" line (as root)
3_ you can run timidity now:
# start command
sudo /etc/init.d/timidity start
# stop command
sudo /etc/init.d/timidity stop

as default timidity will make ports "128:0,128:1,128:2,128:3"
try connect 1 of them with alsa plugin.

Bye.


Back to Top
 
PEPPE
Post: Feb 18th 2007 at 8:08 AM

It still doesn't work!


Back to Top
 
PEPE
Post: Feb 18th 2007 at 10:38 AM

When i type "aoss tuxguitar" in a terminal it gives me an error log :

$aoss tuxguitar
Exception in thread "Thread-4" java.lang.IllegalStateException: sequencer not open
at com.sun.media.sound.RealTimeSequencer.stop(RealTimeSequencer.java:341)
at org.herac.tuxguitar.player.impl.MidiPlayerImpl.stop(Unknown Source)
at org.herac.tuxguitar.player.impl.MidiPlayerImpl$1.run(Unknown Source)
at java.lang.Thread.run(Thread.java:595)


Back to Top
 
PEPE
Post: Feb 18th 2007 at 10:40 AM

Sorry for all these posts!

~$ tuxguitar
javax.sound.midi.MidiUnavailableException: Audio Device Unavailable
at com.sun.media.sound.MixerSynth.implOpen(MixerSynth.java:154)
at com.sun.media.sound.AbstractMidiDevice.doOpen(AbstractMidiDevice.java:144)
at com.sun.media.sound.AbstractMidiDevice.open(AbstractMidiDevice.java:108)
at org.herac.tuxguitar.player.impl.MidiPlayerImpl.setSynthesizer(Unknown Source)
at org.herac.tuxguitar.player.impl.MidiPlayerImpl.getSynthesizer(Unknown Source)
at org.herac.tuxguitar.player.impl.MidiPlayerImpl.init(Unknown Source)
at org.herac.tuxguitar.player.impl.MidiPlayerImpl.(Unknown Source)
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
at java.lang.reflect.Constructor.newInstance(Constructor.java:494)
at java.lang.Class.newInstance0(Class.java:350)
at java.lang.Class.newInstance(Class.java:303)
at org.herac.tuxguitar.gui.util.ClassLoaderUtil.newInstance(Unknown Source)
at org.herac.tuxguitar.gui.util.ClassLoaderUtil.newInstance(Unknown Source)
at org.herac.tuxguitar.gui.TuxGuitar.initPlayer(Unknown Source)
at org.herac.tuxguitar_alsa.plugin.TGPluginImpl.loadSynthesizer(Unknown Source)
at org.herac.tuxguitar_alsa.plugin.TGPluginImpl.init(Unknown Source)
at org.herac.tuxguitar.gui.system.plugins.PluginManager.initPLugins(Unknown Source)
at org.herac.tuxguitar.gui.TuxGuitar.initPluginManager(Unknown Source)
at org.herac.tuxguitar.gui.TuxGuitar.displayGUI(Unknown Source)
at org.herac.tuxguitar.gui.TuxGuitar.main(Unknown Source)


Back to Top
 
PEPE
Post: Feb 19th 2007 at 2:35 PM

HELP PLEASE!


Back to Top
 
Julian
Post: Feb 19th 2007 at 2:43 PM

Do another midi app works in your system ?


Back to Top
 
PEPE
Post: Feb 19th 2007 at 3:02 PM

I dont know I reinstalled ubuntu a few days ago so my system isn't configured perfectly. Tuxeguitar used to work fine before, because I configured my system right. Now I don't know what to do!


Back to Top
 
SckyzO
Post: Mar 2nd 2007 at 1:31 PM

Yes, i had got the same problem ....

so, when u open tuxguitar, you must disable the plugin alsa

OPEN TUXGUITAR >> PLUGINS >> TUXGUITAR-PLUGIN-ALSA

and strip "Enable plugin"

(sorry for my english, but i am a little frenchy :))


Back to Top
 
Kelly
Post: Mar 11th 2007 at 12:59 PM

Yes, i had got the same problem ....

so, when u open tuxguitar, you must disable the plugin alsa

OPEN TUXGUITAR >> PLUGINS >> TUXGUITAR-PLUGIN-ALSA

and strip "Enable plugin"

(sorry for my english, but i am a little frenchy :))


Back to Top
 
WTF
Post: May 30th 2008 at 5:53 AM

I have the same annoying problem. and it doesn't help that some frenchy people are suggesting things to do that is impossible.

could U please tell me where in tuxguitar there is a PLUGINS section?? Maybe I'm just blind with rage 'cause I think this is AGAIN some goddam UBUNTU issue... I'll check this by installing Gentoo Linux and if couple of my problems disappear, I'll never touch ubuntu again!!!!


Back to Top
 
Johnny
Post: May 30th 2008 at 10:00 AM

It's in Tools -> Plugins.
Do you have TuxGuitar RCx?


Back to Top
 
Julian
Post: May 30th 2008 at 11:29 AM

WTF: TuxGuitar will run equals on ubuntu, gentoo, debian, suse.. or any other distribution.
just make sure you have the latest tuxguitar version installed.
http://tuxguitar.herac.com.ar/download.html

Go to "Tools -> Settings" on Sound section, and let me know what do you have on "MIDI Port".. and what do you have available.
if you don't have it installed.. try install timidity:
sudo apt-get install timidity freepats

open a terminal and exec:
timidity -iA -Os

then select a timidity port on tuxguitar.


Back to Top
 
katsu
Post: Jun 26th 2008 at 9:07 PM

Hello I've opend timidity -iA -Os and change port on tuxguitar, and everything worked. but when i closed timidity the sound disappear again. Do you use some script or something?


Back to Top
 
Julian
Post: Jun 26th 2008 at 9:23 PM

when you run "timidity -iA -Os" you are adding timidity ports to alsa.
but if you close timidity, the alsa ports will be removed..

you can add "&" to the end of the line to daemonize timidity:
timidity -iA -Os &

and you'll able to close the terminal.
but to stop timidity you'll need kill the process:
killall -9 timidity

On debian based distributions, there are timidity scripts to run it when PC boot.
but i don't know what distribution do you have.


Back to Top