Tux Guitar

Problems

Subject can't find gervill



Author Message
Nick
Post: Nov 28th 2009 at 3:06 PM

Version 1.1 from ubuntu repositories (9.10) worked fine with gervill, now that I have 1.2 I can't find gervill anymore, though the plugin is active


Back to Top
 
Julian
Post: Nov 28th 2009 at 4:16 PM

Gervill is included as default in openJdk.. but are you running tuxguitar with openjdk ??

try exec "tuxguitar -i" and paste here the display info.

> though the plugin is active
If it's for play sounds ( MIDI Port ) the plugin is the "Java Sound Api plugin".
Note that the Gervill plugin, uses gervill to export to audio file ( File -> Export -> Export Audio )
so if you look it for MIDI Port, make sure java sound api plugin is enabled.

If you see "Java sound synthesizer" available to select, this means you are running sun's JDK, or Jet native version.
in both cases you have to manually install gervill to the JRE to have it available.


Back to Top
 
Nick
Post: Nov 28th 2009 at 7:35 PM

nick@nick-desktop:~$ tuxguitar -i
System Info:
-> OS-Name: Linux
-> OS-Arch: amd64
-> OS-Version: 2.6.31-15-generic
-> JVM-Name: Java HotSpot(TM) 64-Bit Server VM
-> JVM-Version: 14.1-b02
-> JVM-Vendor: Sun Microsystems Inc.
-> Java-Version: 1.6.0_15
-> Java-Vendor: Sun Microsystems Inc.
-> Java-Home: /usr/lib/jvm/java-6-sun-1.6.0.15/jre
-> Java-Class-Path: ::/usr/share/java/tuxguitar/tuxguitar.jar:/usr/share/java/tuxguitar/swt.jar:/usr/share/java/itext.jar:/usr/share/tuxguitar/
-> Java-Library-Path: :/usr/lib/jni/:/lib:/usr/lib:/usr/lib/jni:/usr/local/lib:/usr/lib/firefox

I have openjdk installed, and both gervill Java Sound Api plugins and in the tuxguitar preferences I have Java sound synthesizer which won't play if another audio software is running. when I had the 1.1 it showed gervill, so I don't think I have to install it


Back to Top
 
Julian
Post: Nov 29th 2009 at 1:43 PM

It's running with sun's java..
if you are not using it for other applications you can try uninstall it ( sun-java6-* packages )

Or you can modify with any text editor the file /usr/bin/tuxguitar.

Remove this section:
###########################################
if [ -z $JAVA ]; then
JAVA=${JAVA_HOME}/bin/java
[ ! -f ${JAVA} ] && JAVA=/usr/lib/jvm/java-6-sun/jre/bin/java
[ ! -f ${JAVA} ] && JAVA=/usr/lib/jvm/java-1.5.0-sun/jre/bin/java
[ ! -f ${JAVA} ] && JAVA=/usr/lib/jvm/java-7-icedtea/jre/bin/java
[ ! -f ${JAVA} ] && JAVA=/usr/bin/java
[ ! -f ${JAVA} ] && JAVA=java
fi
###########################################

and replace it to:
JAVA=java


Back to Top
 
Nick
Post: Dec 5th 2009 at 12:43 PM

Thanks, i edited /usr/bin/tuxguitar and now I can use gervill. Anyway, at first I tried switching java version with sudo update-java-alternatives -s java-6-openjdk but that didn't show gervill, would this be a bug? Just to let you know, thanks again


Back to Top
 
Julian
Post: Dec 13th 2009 at 3:59 PM

I think that update-alternatives command will no work because you are not using a full path.

you could try this:
sudo update-alternatives --config java

Then you'll see the list of available "java", and choice your default one.


Back to Top