Tux Guitar

Problems

Subject massive MIDI problems with Kubuntu 9.10



Author Message
DexterF
Post: Feb 28th 2010 at 6:47 PM

timidity: timing problems. playback stutters as if the cpu clock had a heart diesease (2x2.9GHz AM2 Athlon)
plus: 1.2 forgets the settings on each reboot. always have to do the setup again

fluidsynth: threw out 1.2 for deps, reinstalled 1.1 from kubuntu, doesn't make a sound at all.

Help?


Back to Top
 
Anonymous
Post: Feb 28th 2010 at 7:10 PM

Addendum: timing got a lot better now, settings are
"Real Time Sequencer" (I have now idea what this actually uses, fluid or timidity) and
"Java Sound Synthesizer"

MIDI has always riddled me: the Sequencer tells when to play which note and the Synth is what finally generates the sound?
How do timidity and fluid differ?
How can I have tuxguitar 1.2 in Kub 9.10 and fluidsynth?


Back to Top
 
Julian
Post: Mar 6th 2010 at 4:15 PM

>> the Sequencer tells when to play which note and the Synth is what finally generates the sound?

Yes.. i allways use this example:
Sequencer: is like an human playing a guitar.
Synthesizer: is like a guitar

BTW, allmost synthesizers include sequencers too :)..
you can use timidity as standalone aplication to play MIDI files.. this is because it includes a sequencer too.


I think today, fluidsynth is the best choice, because it's still on development.. while timidity don't have releases since a lot of time ago, it don't have support for some new low level libraries, such as PulseAudio

to make fluidsynth works, you need to install it and a soundfont.
you can try this:

~$ sudo apt-get install fluidsynth fluid-soundfont-gm

Then just launch it (then select it in tuxguitar settings):
~$ fluidsynth /usr/share/sounds/sf2/FluidR3_GM.sf2

if it don't play sounds, you can change the default audio driver to "pulseaudio" with -a option

With pulseaudio, i use this settings:
~$ fluidsynth -a pulseaudio -m alsa_seq -z 1024 /usr/share/sounds/sf2/FluidR3_GM.sf2

(here we say with -a to use pulseaudio as audio output, alsa_seq as MIDI driver, to load it with tuxguitar-alsa, and a buffer size of 1024 because default size is to small for pulseaudio )


if you want to use fluidsynth, from tuxguitar-fluidsynth plugin..
if you have a 32 bit PC, follow this topic:
http://www.tuxguitar.com.ar/forum/4/1596/getting-fluidsynth-and-jack-plugins-to-load/

but if you have a 64bit PC, you have to manually build it ( or wait for 1.2 available at your distributions repositories)


Back to Top