Tux Guitar

Problems

Subject no start under Ubuntu 10.04



Author Message
deaver
Post: Apr 29th 2010 at 5:55 PM

hey folks i upgraded from 9.10 to 10.04 today. tuxguitar wont start. throws back


tuxguitar
Exception in thread "main" java.lang.NoClassDefFoundError: org/eclipse/swt/widgets/Control
at org.herac.tuxguitar.gui.TGMain.main(Unknown Source)
Caused by: java.lang.ClassNotFoundException: org.eclipse.swt.widgets.Control
at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:334)
... 1 more



tried a re-instasllation, but nothing worked

any1 suggestions ?


Back to Top
 
lobo
Post: Apr 29th 2010 at 6:50 PM

try reinstalling java
tell us if worked ;)


Back to Top
 
joe banana
Post: Apr 30th 2010 at 3:01 PM

modify: /usr/bin/tuxguitar

put in the swt_guess():

t="/usr/share/java/swt-gtk-3.5.1.jar"

instead of the old 3.4 version


Back to Top
 
amadeusmetal
Post: May 4th 2010 at 2:55 AM

did it solve the problem? im having the same.


Back to Top
 
amadeus metal
Post: May 4th 2010 at 3:30 AM

try to install the 1.2 version, avaliable in the download session. it worked for me.


Back to Top
 
hp1990
Post: May 4th 2010 at 8:21 AM

I tried the solution proposed by joe banana and it works now


Back to Top
 
Sord
Post: May 5th 2010 at 4:06 PM

Had the same problem, but joe bananas solution worked. Thanks a lot!


Back to Top
 
joe banana
Post: May 6th 2010 at 4:18 PM

Actually, there would be an easier way.

Just reinstall swt-gtk-3.5-java with synaptic or apt-get (or..). This would add the missing link swt.jar in the /usr/share/java folder. The unmodified start script should work now.


Back to Top
 
smooth i killed
Post: May 22nd 2010 at 9:12 PM

joe banana's post to reinstall swt-gtk-3.5-java with synaptic worked for me, thanks!


Back to Top
 
mariano
Post: May 24th 2010 at 12:25 PM

thanks to joe banana!


Back to Top
 
lazy_007
Post: May 25th 2010 at 6:52 PM

joe banana's post to reinstall swt-gtk-3.5-java with synaptic worked for me to, thanks!


Back to Top
 
Jai
Post: Jun 27th 2010 at 12:42 PM

shouldn't have a new rpm with the dependency on the package swt-gtk-3.5-java to avoid the problem ?


Back to Top
 
acca74
Post: Aug 30th 2010 at 12:00 PM

Had the same problem.
I found in another forum that re-installing libswt-gtk-3.5-java would fix the problem. I did it via synaptic and it worked.
I didn't try the solution suggested here though this one seems easier.


Back to Top
 
pongofra
Post: May 20th 2011 at 7:22 AM

Reinstall swt-gtk-3.5-java with synaptic. It worked for me, thanks to joe banana.


Back to Top