Tux Guitar

Problems

Subject X error



Author Message
Xinox
Post: Jul 9th 2010 at 4:37 PM

I run under ubuntu 10.04 lts, and i can't run tuxguitar, the version of distribution or the latest 1.2 :

marc@marc-desktop:~$ tuxguitar

progname=; RGBA=on
The program 'TuxGuitar' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
(Details: serial 1470 error_code 8 request_code 152 minor_code 4)
(Note to programmers: normally, X errors are reported asynchronously;
that is, you will receive the error a while after causing it.
To debug your program, run it with the --sync command line
option to change this behavior. You can then get a meaningful
backtrace from your debugger if you break on the gdk_x_error() function.


Back to Top
 
Julian
Post: Jul 11th 2010 at 4:51 PM

What GTK version do you have installed ?


Back to Top
 
nyskelo
Post: Jan 29th 2011 at 11:37 AM

Have the same error on Arch Linux, X.Org 1.9.2, gtk 2.22.1
Does anyone know what's the cause and how to fix??


Back to Top
 
franko
Post: Jan 29th 2011 at 5:45 PM

The cause is the RGBA gtk module. It is possible to blacklist apps from the module in /etc/profile.d/gtkrgba.sh, but adding "tuxguitar" and "TuxGuitar" doesn't help it... Seems like there is another identificator for TuxGuitar, but I can't figure out what it is... Any help?


Back to Top
 
nyskelo
Post: Feb 4th 2011 at 8:03 PM

hey, guys,

RGBA gtk module is really the problem. Found a workaround, just lanch tuxguitar in a console with:

env XLIB_SKIP_ARGB_VISUALS=1 tuxguitar

and that's it.)

Another way is to disable RGBA support for tuxguitar in some distro specific configuration files.


Back to Top
 
franko
Post: Feb 11th 2011 at 3:37 PM

Thank you, the command really works.

In Ubuntu, there is a rgba blacklist in /etc/profile.d/gtkrgba.sh, but adding "tuxguitar" to the list doesn't work. Seems like it uses another identifier... Can't figure out what it is. :-/

Thank you for the above command, though! :-)


Back to Top