Tux Guitar

Problems

Subject midi issues



Author Message
Tomi
Post: Jul 31st 2010 at 8:15 PM

hey guys,
im desperatly trying to make tuxguitar work on my laptop with ubuntu 10.04 but there is just no sound!

i got the alsa plugin installed and everything, but it works with no alsa port,
i can play midifiles in rhythmbox or video-player but when i try to play one via console with aplaymidi i dont hear anything.
there are no other errors, tuxguitar itself seems to be working just fine!

i think i already tried everything on this page:
http://tuxguitar.herac.com.ar/tgwiki/doku.php?id=doc:no_sound

thanks for any help, im going nuts here!
Tomi


Back to Top
 
Tomi
Post: Jul 31st 2010 at 8:21 PM

well and with the java sound synthesizer "the midi system isn available"...
but id rather not have to stress myself around with java...


Back to Top
 
Julian
Post: Aug 2nd 2010 at 1:53 PM

You have the alsa plugin installed, but you need to install alsa ports.

tuxguitar-alsa plugin, will list you the midi output ports connected to alsa..
try install and configure timidity or fluidsynth as alsa ports, so you'll be able to select them in tuxguitar's settings.


Back to Top
 
Tomi
Post: Aug 2nd 2010 at 6:58 PM

oh well sorry, i didnt make myself clear enough.
i installed timidity and the alsa ports are shown in tuxguitar. timidity ports 128:0 - 128:3.
it could be interesting that that each port is shown twice:
once as
timidity port 0 [128:0] and once as
timidity port 0 #1

any ideas?


Back to Top
 
Julian
Post: Aug 2nd 2010 at 7:23 PM

It's because you should have also "tuxguitar-oss" plugin installed.

"portname [client:port]" is provided by alsa plugin. ( e.g timidity port 0 [128:0] )

"portname #index" is provided by OSS plugin ( timidity port 0 #1 )

It's not recommended to have both plugins enabled.. just use the alsa one. and uninstall tuxguitar-oss.


Back to Top
 
Tomi
Post: Aug 3rd 2010 at 12:21 PM

oh yey,
great, thanks!


Back to Top