Tux Guitar

Problems

Subject Bug Report



Author Message
tmac
Post: Aug 6th 2010 at 7:21 PM

Should I report bugs here?

I'll give it a try:

Often, while moving the cursor (little square) around on the staff, the cursor disappears. When I click using the mouse it reappears where I clicked (as expected).

This makes it quite hard to work without the mouse and therefore makes working with TuxGuitar much less efficient.

I'm experiencing another display problem that I have reported to the Debian report system, but I'll mention it here since it might be related and since I don't know if the upstream authors have seen it:

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=590980


OS: Linux
Distribution: Debian Sid
TuxGuitar version: 1.2-5
Computer: Asus X5DID laptop
Graphics card: NVidia GeForce GT 320M (using NVidia driver)


Back to Top
 
tmac
Post: Aug 7th 2010 at 9:45 AM

I just noticed that when the little square disappears, so does parts of all the barlines in the document.


Back to Top
 
Jim Leven
Post: Aug 7th 2010 at 2:02 PM

Problem with running Tuxguitar after upgrading to the new SuSE 1.3

$MOZILLA_FIVE_HOME not valid : check doc shipped w/ tuxguitar
#
# A fatal error has been detected by the Java Runtime Environment:
#
# SIGSEGV (0xb) at pc=0x00000004, pid=13366, tid=3067145072
#
# JRE version: 6.0_17-b17
# Java VM: OpenJDK Client VM (14.0-b16 mixed mode linux-x86 )
# Derivative: IcedTea6 1.7.3
# Distribution: Custom build (Mon Jul 5 23:35:28 UTC 2010)
# Problematic frame:
# C 0x00000004
#
# An error report file with more information is saved as:
# /home/jleven/hs_err_pid13366.log
#
# If you would like to submit a bug report, please include
# instructions how to reproduce the bug and visit:
# http://icedtea.classpath.org/bugzilla
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#
/usr/bin/tuxguitar: line 125: 13366 Aborted ${JAVA} ${JAVA_FLAGS} ${PACKAGE_MAIN} $arg "$@"


Back to Top
 
Julian
Post: Aug 7th 2010 at 4:26 PM

@tmac: are you running tuxguitar with atest SWT 3.6 version ?
please make sure you are not having same problem as:
http://tuxguitar.herac.com.ar/forum/5/1331/no-lines-for-notes-and-tabs/
https://bugs.launchpad.net/ubuntu/+source/tuxguitar/+bug/455615

@Jim Leven:
> An error report file with more information is saved as:
> /home/jleven/hs_err_pid13366.log
Can you show me the content of that file?.. but create a new post foreach bug please.


Back to Top
 
Anonymous
Post: Aug 9th 2010 at 10:55 AM

>@tmac: are you running tuxguitar with atest SWT 3.6 version ?
>please make sure you are not having same problem as:
>http://tuxguitar.herac.com.ar/forum/5/1331/no-lines-for-notes-and-tabs/
>https://bugs.launchpad.net/ubuntu/+source/tuxguitar/+bug/455615

No, in Debian Sid SWT is v3.5.1. I will see about getting a newer version and then report back. Thanks for the help and those links! I'll report back with my findingsafter that.


Back to Top
 
tmac
Post: Aug 9th 2010 at 11:14 AM

The problem is gone with SWT3.6. Thanks! I have submitted a wishlist report to Debian for SWT3.6.

For now I just keep the SWT3.6 JAR-file in my home directory and set CLASSPATH when I run tuxguitar, as you described on the Launchpad.net site.

Thanks again!


Back to Top