Tux Guitar

Problems

Subject Tuxguitar crashes due to an error in native code



Author Message
Ben Engbers
Post: Jan 21st 2011 at 1:17 PM

I have installed tuxguitar-1.2-3.fc14 on a lenovo thinkpad r500.

When I start it from a console I get the following output:
#
# A fatal error has been detected by the Java Runtime Environment:
#
# SIGSEGV (0xb) at pc=0xb6a000f1, pid=3095, tid=3066014576
#
# JRE version: 6.0_23-b05
# Java VM: Java HotSpot(TM) Server VM (19.0-b09 mixed mode linux-x86 )
# Problematic frame:
# C 0xb6a000f1
#
# If you would like to submit a bug report, please visit:
# http://java.sun.com/webapps/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#

The content from the problematic frame is:
Stack: [0xb6baa000,0xb6bfb000], sp=0xb6bf9c8c, free space=319k
Native frames: (J=compiled Java code, j=interpreted, Vv=VM code, C=native code)
C 0xb6a000f1
C [libtuxguitar-alsa-jni.so+0x11a1] Java_org_herac_tuxguitar_player_impl_midiport_alsa_MidiSystem_findPorts+0xe1
j org.herac.tuxguitar.player.impl.midiport.alsa.MidiSystem.findPorts(J)V+0
j org.herac.tuxguitar.player.impl.midiport.alsa.MidiSystem.findPorts()Ljava/util/List;+30
j org.herac.tuxguitar.player.impl.midiport.alsa.MidiOutputPortProviderImpl.listPorts()Ljava/util/List;+39
j org.herac.tuxguitar.player.base.MidiPlayer.addOutputPortProvider(Lorg/herac/tuxguitar/player/base/MidiOutputPortProvider;Z)V+13
j org.herac.tuxguitar.gui.system.plugins.base.TGMidiOutputPortProviderPlugin.addPlugin()V+23
j org.herac.tuxguitar.gui.system.plugins.base.TGMidiOutputPortProviderPlugin.setEnabled(Z)V+5
j org.herac.tuxguitar.gui.system.plugins.TGPluginManager.openPlugins()V+35
j org.herac.tuxguitar.gui.TuxGuitar.displayGUI([Ljava/lang/String;)V+101
j org.herac.tuxguitar.gui.TGMain.main([Ljava/lang/String;)V+4
v ~StubRoutines::call_stub
V [libjvm.so+0x3b9681]
V [libjvm.so+0x5a4b18]
V [libjvm.so+0x3b94af]
V [libjvm.so+0x3ebfd4]
V [libjvm.so+0x3dc0ec]
C [java+0x1b98] JavaMain+0x2c8
C [libpthread.so.0+0x5f19]

I have no indication that my soundsystem is not working well (in firefox I have normal sound)

Can anybody tell me how I should interpret the information for this frame (and help me to get tuxguitar working)?

Ben


Back to Top