Tux Guitar

Problems

Subject Install tuxguitar0.9.1



Author Message
Robin
Post: Apr 22nd 2007 at 5:18 AM

Hi, i'm looking to install tux guitar but when I try to run it
i've got that:

[Robin@localhost Desktop]$ /home/Robin/install_dir/TuxGuitar-0.9.1-linux-gtk-x86_64/tuxguitar
Exception in thread "main" java.lang.UnsatisfiedLinkError: libswt-pi-gtk-3232: lib/libswt-pi-gtk-3232.so: wrong ELF class: ELFCLASS64
at java.lang.Runtime._load(libgcj.so.7rh)
at java.lang.Runtime.loadLibrary(libgcj.so.7rh)
at java.lang.System.loadLibrary(libgcj.so.7rh)
at org.eclipse.swt.internal.Library.loadLibrary(Library.java:123)
at org.eclipse.swt.internal.gtk.OS.(OS.java:22)
at java.lang.Class.initializeClass(libgcj.so.7rh)
at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:63)
at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:54)
at org.eclipse.swt.widgets.Display.(Display.java:126)
at java.lang.Class.initializeClass(libgcj.so.7rh)
at org.herac.tuxguitar.gui.TuxGuitar.displayGUI(Unknown Source)
at org.herac.tuxguitar.gui.TuxGuitar.main(Unknown Source)


Back to Top
 
Julian
Post: Apr 22nd 2007 at 9:36 AM

Hi,

libgcj.so.7, is a GCJ library ..
tuxguitar needs Java 1.5 or later from Sun.

maybe you have java 1.5 installed in your system.. but you also have GCJ (and its at linux PATH)..
so if you have the 1.5 installed, you can do:

export JAVA=/where_is_java_/bin/java
/home/Robin/install_dir/TuxGuitar-0.9.1-linux-gtk-x86_64/tuxguitar


Back to Top
 
Anonymous
Post: Apr 22nd 2007 at 2:53 PM

Thx for your answer!
Java is in /etc/java
I used to tape
export JAVA=/etc/java/bin/java
/home/Robin/install_dir/TuxGuitar-0.9.1-linux-gtk-x86_64/tuxguitar
It answered me:/home/Robin/install_dir/TuxGuitar-0.9.1-linux-gtk-x86_64/tuxguitar: line 27: /etc/bin/java: Aucun fichier ou répertoire de ce type
in english:No file or repertory of this type
I also tape: export JAVA=/etc/bin/java
the same error
(I'm new on linux)D553DF


Back to Top
 
Julian
Post: Apr 22nd 2007 at 3:05 PM

Hi,
/etc/bin/java ?? are you sure ?
i don't think your Java binary files are at /etc (maybe a symbolic link)..

try this:
/etc/java/bin/java -version
if it return an error, is because file don't exists.
if the file exists, but is a symbolic link and its broken.. you will get the same error.

what linux distribution are you using ??? and how did you install java?


Back to Top
 
Anonymous
Post: Apr 22nd 2007 at 5:53 PM

Hi, I've got an error beaucase the file doesn't exist so....
I've got linux Fedora core 6.


Back to Top
 
Julian
Post: Apr 22nd 2007 at 6:01 PM

well, so you need find the correct java path..

do you have installed a java-1.5 or later from Sun ?


Back to Top
 
Anonymous
Post: Apr 22nd 2007 at 6:04 PM

I thinks I installed a better of 1.5 1.6 I think


Back to Top
 
Julian
Post: Apr 22nd 2007 at 11:34 PM

so.. where is it installed??

in any place of your filesystem.. should be a folder:
jre/

you need find that folder.. and look for version:
JAVA_HOME/jre/bin/java -version


Back to Top
 
Robin
Post: Apr 23rd 2007 at 4:33 PM

hi, Ok my version is 1.6.0_01

[Robin@localhost ~]$ /usr/java/jre1.6.0_01/bin/java -version
java version "1.6.0_01"
Java(TM) SE Runtime Environment (build 1.6.0_01-b06)
Java HotSpot(TM) Client VM (build 1.6.0_01-b06, mixed mode, sharing)


Back to Top
 
Julian
Post: Apr 23rd 2007 at 8:32 PM

so try this:

export JAVA=/usr/java/jre1.6.0_01/bin/java
/home/Robin/install_dir/TuxGuitar-0.9.1-linux-gtk-x86_64/tuxguitar

You should run tuxguitar in same terminal as you export JAVA var..
if it works, you can modify the tuxguitar launcher and change the JAVA var. to make it run with 2 click.


Back to Top
 
Robin
Post: Apr 24th 2007 at 1:33 PM

I did it:
[Robin@localhost ~]$ export JAVA=/usr/java/jre1.6.0_01/bin/java
[Robin@localhost ~]$ /home/Robin/install_dir/TuxGuitar-0.9.1-linux-gtk-x86_64/tuxguitar
Exception in thread "main" java.lang.UnsatisfiedLinkError: /home/Robin/install_dir/TuxGuitar-0.9.1-linux-gtk-x86_64/lib/libswt-pi-gtk-3232.so: /home/Robin/install_dir/TuxGuitar-0.9.1-linux-gtk-x86_64/lib/libswt-pi-gtk-3232.so: wrong ELF class: ELFCLASS64
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary0(Unknown Source)
at java.lang.ClassLoader.loadLibrary(Unknown Source)
at java.lang.Runtime.loadLibrary0(Unknown Source)
at java.lang.System.loadLibrary(Unknown Source)
at org.eclipse.swt.internal.Library.loadLibrary(Library.java:123)
at org.eclipse.swt.internal.gtk.OS.(OS.java:22)
at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:63)
at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:54)
at org.eclipse.swt.widgets.Display.(Display.java:126)
at org.herac.tuxguitar.gui.TuxGuitar.displayGUI(Unknown Source)
at org.herac.tuxguitar.gui.TuxGuitar.main(Unknown Source)

Is something wrong ?


Back to Top
 
Julian
Post: Apr 24th 2007 at 2:20 PM

the java problem is fixed. so this is other...

java.lang.UnsatisfiedLinkError.. it happends when Java can't load native libraries.. on this case:
/home/Robin/install_dir/TuxGuitar-0.9.1-linux-gtk-x86_64/lib/libswt-pi-gtk-3232.so:


you have the x86_64 tuxguitar version.. are you sure you have a 64bit PC ?
i think you downloaded an incorrect release.. try install the x86 release.


Back to Top
 
Robin
Post: Apr 24th 2007 at 4:18 PM

So I dowlowded the TuxGuitar-0.9.1-linux-gtk-x86 the result is:


[Robin@localhost Desktop]$ /home/Robin/install_dir/TuxGuitar-0.9.1-linux-gtk-x86/tuxguitar
Exception in thread "main" java.lang.UnsatisfiedLinkError: init_
at gnu.javax.sound.midi.alsa.AlsaMidiDeviceProvider.init_(libgcj.so.7rh)
at gnu.javax.sound.midi.alsa.AlsaMidiDeviceProvider.(libgcj.so.7rh)
at java.lang.Class.initializeClass(libgcj.so.7rh)
at java.lang.Class.newInstance(libgcj.so.7rh)
at gnu.classpath.ServiceProviderLoadingAction.run(libgcj.so.7rh)
at java.security.AccessController.doPrivileged(libgcj.so.7rh)
at gnu.classpath.ServiceFactory$ServiceIterator.loadNextServiceProvider(libgcj.so.7rh)
at gnu.classpath.ServiceFactory$ServiceIterator.(libgcj.so.7rh)
at gnu.classpath.ServiceFactory.lookupProviders(libgcj.so.7rh)
at gnu.classpath.ServiceFactory.lookupProviders(libgcj.so.7rh)
at javax.sound.midi.MidiSystem.getMidiDeviceInfo(libgcj.so.7rh)
at javax.sound.midi.MidiSystem.getSynthesizer(libgcj.so.7rh)
at org.herac.tuxguitar.player.impl.MidiPlayerImpl.getSynthesizer(Unknown Source)
at org.herac.tuxguitar.player.impl.MidiPlayerImpl.init(Unknown Source)
at org.herac.tuxguitar.player.impl.MidiPlayerImpl.(Unknown Source)
at java.lang.Class.newInstance(libgcj.so.7rh)
at org.herac.tuxguitar.gui.util.ClassLoaderUtil.newInstance(Unknown Source)
at org.herac.tuxguitar.gui.util.ClassLoaderUtil.newInstance(Unknown Source)
at org.herac.tuxguitar.gui.TuxGuitar.initPlayer(Unknown Source)
at org.herac.tuxguitar.gui.TuxGuitar.displayGUI(Unknown Source)
at org.herac.tuxguitar.gui.TuxGuitar.main(Unknown Source)


Back to Top
 
Julian
Post: Apr 24th 2007 at 4:42 PM

you should export JAVA again..

export JAVA=/usr/java/jre1.6.0_01/bin/java
/home/Robin/install_dir/TuxGuitar-0.9.1-linux-gtk-x86/tuxguitar


export vars are removed after session closed.. when you close a terminal, the session is finished.. so you must "export" the JAVA var, and exec tuxguitar in same terminal.

as example:
-----------------------------------------------------
1_open a new terminal:
TEST="Hello World"
echo $TEST

"echo" command should show you the value of TEST

2_ open another terminal, and do echo again:
echo $TEST
you will see nothing, because you are in a new bash session.
-----------------------------------------------------

if you don't want export JAVA every time.. you can modify the tuxguitar script, and set the correct JAVA.. so you'll can open it with 2 clicks.
another option is set java-1.5 as default in your system.. (now you have gcj as default)


Back to Top
 
Robin
Post: Apr 24th 2007 at 5:16 PM

Ok thats worck now ^^
Thanks for you help ^^
But hwo can I lanch it with a lancher plis


Back to Top
 
Anonymous
Post: Apr 24th 2007 at 7:38 PM

Hi,

well you can modify the script now..
first i suggest you make a backup of the original file:
/home/Robin/install_dir/TuxGuitar-0.9.1-linux-gtk-x86/tuxguitar

then you can open it with some text editor...
and replace
.........................................................
##JAVA
if [ "${JAVA}" == "" ]; then
if [ "${JAVA_HOME}" != "" ]; then
JAVA=${JAVA_HOME}/bin/java
else
JAVA=java
fi
fi
...........................................................

TO

...........................................................
##JAVA
JAVA=/usr/java/jre1.6.0_01/bin/java
...........................................................


after save the file, it should run with 2 clicks.


Back to Top
 
Robin
Post: Apr 25th 2007 at 8:00 AM

Ok that's worck thaks verry much for your help ^^
thank you ++
Robin


Back to Top
 
roman
Post: Aug 25th 2007 at 8:44 AM

hi there,
it seems I'm having quite the same problem,
here's what I did and what it says:

[TuxGuitar-0.9.1-linux-gtk-x86]$ export JAVA=/usr/lib/jvm/java-1.5.0-gcj-1.5.0.0/jre/bin/java
[TuxGuitar-0.9.1-linux-gtk-x86]$ ./tuxguitar
Exception in thread "main" java.lang.UnsatisfiedLinkError: init_
at gnu.javax.sound.midi.alsa.AlsaMidiDeviceProvider.init_(libgcj.so.8rh)
at gnu.javax.sound.midi.alsa.AlsaMidiDeviceProvider.(libgcj.so.8rh)
at java.lang.Class.initializeClass(libgcj.so.8rh)
at java.lang.Class.newInstance(libgcj.so.8rh)
at gnu.classpath.ServiceProviderLoadingAction.run(libgcj.so.8rh)
at java.security.AccessController.doPrivileged(libgcj.so.8rh)
at gnu.classpath.ServiceFactory$ServiceIterator.loadNextServiceProvider(libgcj.so.8rh)
at gnu.classpath.ServiceFactory$ServiceIterator.(libgcj.so.8rh)
at gnu.classpath.ServiceFactory.lookupProviders(libgcj.so.8rh)
at gnu.classpath.ServiceFactory.lookupProviders(libgcj.so.8rh)
at javax.sound.midi.MidiSystem.getMidiDeviceInfo(libgcj.so.8rh)
at javax.sound.midi.MidiSystem.getSynthesizer(libgcj.so.8rh)
at org.herac.tuxguitar.player.impl.MidiPlayerImpl.getSynthesizer(Unknown Source)
at org.herac.tuxguitar.player.impl.MidiPlayerImpl.init(Unknown Source)
at org.herac.tuxguitar.player.impl.MidiPlayerImpl.(Unknown Source)
at java.lang.Class.newInstance(libgcj.so.8rh)
at org.herac.tuxguitar.gui.util.ClassLoaderUtil.newInstance(Unknown Source)
at org.herac.tuxguitar.gui.util.ClassLoaderUtil.newInstance(Unknown Source)
at org.herac.tuxguitar.gui.TuxGuitar.initPlayer(Unknown Source)
at org.herac.tuxguitar.gui.TuxGuitar.displayGUI(Unknown Source)
at org.herac.tuxguitar.gui.TuxGuitar.main(Unknown Source)


argh.
any ideas?
regards,
roman


Back to Top
 
Julian
Post: Aug 25th 2007 at 11:10 AM

GCJ for jre-1.5 ?? i didn't know that.

However, tuxguitar-0.9.1 needs run under jre1.5 from "Sun" or any other what implements "Java Sound Api".

GCJ has included "tritonus" java sound api implementation.. but it seems don't work as default..


Back to Top
 
vevhlos
Post: Mar 14th 2008 at 11:22 AM

works for me too
thanks!


Back to Top