Tux Guitar

Problems

Subject TuxGuitar export to LilyPond 2.14.1 error



Author Message
Jay
Post: Jun 23rd 2011 at 6:00 AM

I recently upgraded to LilyPond 2.14.1. Now when TuxGuitar exports to LilyPond, I get an error:

"Wrong type argument in position 1 (expecting Pitch):"

I guess this is the offending code that TuxGuitar exports:

TrackATabStaff = new TabStaff with { stringTunings = #'( 9 4 0 7 ) } <<

How to correct?

Thanks in advance.

Jay


Back to Top
 
Jay
Post: Jun 23rd 2011 at 6:04 AM

Sorry, I found the solution. I needed to update the syntax of the LilyPond document.


Back to Top
 
b4dc0d3r
Post: Aug 3rd 2011 at 11:12 PM

I have updated the lilypond plugin for 2.14.0, a few more quirks to address and I should have a release.

In the meantime, using convert-ly from the lilypond distribution makes the updates for you automatically. I used it to confirm the updates I made looked good. 2.13.46 is the version where stringTunings got updated.


Back to Top
 
Viktor
Post: Feb 6th 2012 at 9:43 PM

"...Sorry, I found the solution. I needed to update the syntax of the LilyPond document. ,..."

How did you do that?


Back to Top
 
Viktor
Post: Feb 7th 2012 at 11:21 PM

I found it. In a terminal, type: convert-ly name-of-file.ly

Or in Frescobaldi: Lilypond/Source Document/Update with Convert-ly


Back to Top