Tux Guitar

Problems

Subject no sound after inst'ing alsa-plugin



Author Message
Dexter Filmore
Post: Oct 5th 2007 at 10:29 AM

Kubuntu 7.04, SoundBlaster live 5.1, emu10k1 chip, TG 0.9.1.

Tuxguitar used to play sound tho with a slight lag. Installed alsa-plugin, no there's silence. Play button wroks but I can't hear a thing.
As soon as I disabled the plugin sound plays again.
Pointing TG at a custum GM sound font had no effect.


Back to Top
 
Julian
Post: Oct 5th 2007 at 11:02 AM

That's because, you don't have any software synthesizer installed. the first Alsa midi port "Midi Through Port-0 14:0" don't play sounds as default.

try install "timidity" and "freepats" from repositories

then edit the file:
/etc/default/timidity

and uncomment the lines:
TIM_ALSASEQ=..........
TIM_ALSASEQPARAMS=..........

then restart timidity as a daemon
/etc/init.d/timidity stop
/etc/init.d/timidity start

restart tuxguitar, go to the plugin config and select the timidity port "128:0"..

Bye


Back to Top
 
Dexter Filmore
Post: Oct 6th 2007 at 9:52 AM

yay, thanks!


Back to Top
 
Anonymous
Post: Oct 7th 2007 at 3:57 AM

thanks to julian for his good indications


Back to Top
 
reuking
Post: Oct 12th 2007 at 10:22 AM

thanks for the advice but i can't save timidity changes cause the file is protected, this is the first step and for the next i don't know what is the daemon, can you explain :"then restart timidity as a daemon
/etc/init.d/timidity stop
/etc/init.d/timidity start"

Merci beaucoup (in french)


Back to Top
 
Julian
Post: Oct 12th 2007 at 10:48 AM

Hi..
first.. are you under Ubuntu ?? ( because i'm not sure if the official release has the /etc/init.d/timidity file... )

Well..

>i can't save timidity changes cause the file is protected
you must edit it as "root" or with "sudo" :
sudo gedit /etc/default/timidity

>i don't know what is the daemon, can you explain...
Well.. i'm not sure how explain what a daemon is on english (not my native land).. see it as an application server running on background.

you can launch timidity only doing (on a terminal):

timidity -iA -Os

that is the same as "/etc/init.d/timidity start"

but the difference, is on the second method.. the timidity daemon will started when your PC boot (but need first "/etc/default/timidity" configured to do the same as "timidity -iA -Os" ).


Back to Top
 
reuking
Post: Oct 12th 2007 at 5:19 PM

Thanks Jullian
That's quite clear to make my tuxguitar work very well with the alsa plugin.
Understand that i'm a brand new user of ubuntu and i don't used the terminal so easily.
thanks again
bye


Back to Top
 
Silver
Post: Nov 10th 2007 at 9:14 AM

Whow! Since I reinstalled my FreeBSD with OpenSuse, I've had some sound problems, and since moving to ALSA I wasn't able to play any sounds in TuxGuitar.

While using TuxGuitar-alsa, I got the error: javax.sound.midi.InvalidMidiDataException: cannot get soundbank from stream

But launching timidity as daemon and choosing the timidity port solved it..
Thanks :)


Back to Top
 
Silver
Post: Nov 10th 2007 at 9:27 AM

Hmm, well, actually I still get the Java error "cannot get soundbank from stream" and TuxGuitar says it fails to open the custom soundbankfile , but I can still play sounds though..


Back to Top
 
Julian
Post: Nov 10th 2007 at 12:39 PM

Hi silver. so time..

>"fails to open the custom soundbank file"
TuxGuitar show that error, when try to load a "custom" soundbank and it failed.. ( maybe not a soundbank file.. or file don't exists )

Go to "Settings -> Configure TuxGuitar : Sound "
you have selected the option "use custom soundbank"
does the selected file exists ???

>While using TuxGuitar-alsa
well i'm looking now, that is a bug.
the app don't should try load the soundbank if the alsa plugin is enabled. so try to set "Use default soundbank" to fix the problem.


Back to Top
 
Silver
Post: Nov 10th 2007 at 5:11 PM

Isn't the java error cause of failure loading soundbank? The java error is shown (in terminal) right before the error in TuxGuitar.

Oh, damn.. I specified TuxGuitar-alsa.jar as soundbank file. I just realized that I don't have to do that :) Um.. sorry, I've mixed things up a little.. silly me.

Default soundbank works as well.


Back to Top
 
Julian
Post: Nov 10th 2007 at 5:24 PM

>Isn't the java error cause of failure loading soundbank?
when java try to load a soundbank from an inputsream ( the selected file )
it throws:
javax.sound.midi.InvalidMidiDataException: cannot get soundbank from stream

then tuxguitar, catch that error, and throw the message:
"Failed to open custom soundbank file"


Back to Top