Tux Guitar

Problems

Subject Java sound api cannot be loaded



Author Message
Stoneface
Post: Nov 10th 2007 at 7:03 AM

Hi,

I had the CVS Version of TuxGuitar successfully running on my Debian unstable machine.
But then I had to reinstall Debian unstable with a basic system from netinstall and want tuxguitar again on the box, of course.
I build from CVS with ant, everything looks ok, but after starting tuxguitar it says:

Java sound api cannot be loaded

and no sound will be played... I get these errors from java:

stoneface@neotux:~/.tuxguitar/TuxGuitar/TuxGuitar-cvs-src$ aoss ./tuxguitar
/home/stoneface/.tuxguitar/TuxGuitar/TuxGuitar-cvs-src/./share/skins/blue_serious/layout_compact.png: not found
org.herac.tuxguitar.gui.system.plugins.TGPluginException: Java sound api cannot be loaded
at org.herac.tuxguitar.gui.system.plugins.base.TGMidiPortReaderPlugin.addPluin(Unknown Source)
at org.herac.tuxguitar.gui.system.plugins.base.TGMidiPortReaderPlugin.setEnabled(Unknown Source)
at org.herac.tuxguitar.gui.system.plugins.base.TGPluginList.setEnabled(Unknown Source)
at org.herac.tuxguitar.gui.system.plugins.TGPluginManager.openPlugins(Unknown Source)
at org.herac.tuxguitar.gui.TuxGuitar.displayGUI(Unknown Source)
at org.herac.tuxguitar.gui.TGMain.main(Unknown Source)
Caused by: org.herac.tuxguitar.player.base.MidiPlayerException: Java sound api cannot be loaded
at org.herac.tuxguitar.player.impl.jsa.midiport.MidiPortReaderImpl.listPorts(Unknown Source)
at org.herac.tuxguitar.player.base.MidiPlayer.addPortReader(Unknown Source)
at org.herac.tuxguitar.gui.system.plugins.base.TGMidiPortReaderPlugin.addPluin(Unknown Source)
...5 more
Caused by: java.lang.UnsatisfiedLinkError: init_
at gnu.javax.sound.midi.alsa.AlsaMidiDeviceProvider.init_(libgcj.so.81)
at gnu.javax.sound.midi.alsa.AlsaMidiDeviceProvider.(libgcj.so.81)
at java.lang.Class.initializeClass(libgcj.so.81)
at java.lang.Class.newInstance(libgcj.so.81)
at gnu.classpath.ServiceProviderLoadingAction.run(libgcj.so.81)
at java.security.AccessController.doPrivileged(libgcj.so.81)
at gnu.classpath.ServiceFactory$ServiceIterator.loadNextServiceProvider(libgcj.so.81)
at gnu.classpath.ServiceFactory$ServiceIterator.(libgcj.so.81)
at gnu.classpath.ServiceFactory.lookupProviders(libgcj.so.81)
at gnu.classpath.ServiceFactory.lookupProviders(libgcj.so.81)
at gnu.classpath.ServiceFactory.lookupProviders(libgcj.so.81)
at javax.sound.midi.MidiSystem.getMidiDeviceInfo(libgcj.so.81)
at org.herac.tuxguitar.player.impl.jsa.midiport.MidiPortReaderImpl.listPorts(Unknown Source)
...7 more
org.herac.tuxguitar.player.base.MidiPlayerException: Java sound api cannot be loaded
at org.herac.tuxguitar.player.impl.jsa.midiport.MidiPortReaderImpl.listPorts(Unknown Source)
at org.herac.tuxguitar.player.base.MidiPlayer.listPorts(Unknown Source)
at org.herac.tuxguitar.gui.system.config.items.SoundOption$1.run(Unknown Source)
at java.lang.Thread.run(libgcj.so.81)
Caused by: java.lang.NoClassDefFoundError: gnu.javax.sound.midi.alsa.AlsaMidiDeviceProvider
at java.lang.Class.initializeClass(libgcj.so.81)
at java.lang.Class.newInstance(libgcj.so.81)
at gnu.classpath.ServiceProviderLoadingAction.run(libgcj.so.81)
at java.security.AccessController.doPrivileged(libgcj.so.81)
at gnu.classpath.ServiceFactory$ServiceIterator.loadNextServiceProvider(libgcj.so.81)
at gnu.classpath.ServiceFactory$ServiceIterator.(libgcj.so.81)
at gnu.classpath.ServiceFactory.lookupProviders(libgcj.so.81)
at gnu.classpath.ServiceFactory.lookupProviders(libgcj.so.81)
at gnu.classpath.ServiceFactory.lookupProviders(libgcj.so.81)
at javax.sound.midi.MidiSystem.getMidiDeviceInfo(libgcj.so.81)
at org.herac.tuxguitar.player.impl.jsa.midiport.MidiPortReaderImpl.listPorts(Unknown Source)
...3 more

I have installed these packages:

sun-java5-bin
sun-java5-demo
sun-java5-jdk
sun-java5-jre
sun-java5-plugin
libtritonus-bin (implementation of the Java Sound API)
libtritonus-java (implementation of the Java Sound API)

I've downloaded a soundbank and put it there:

/usr/lib/jvm/java-1.5.0-sun/jre/lib/audio/soundbank.gm

So I don't have any idea what's the problem... I can't find anything about the api problem in the forum or via google...
Maybe a package is missing ?

Greets

Stoneface


Back to Top
 
Stoneface
Post: Nov 10th 2007 at 10:05 AM

Hi again,

forgot to say:
when I install the official debian package, I don't get the error, but the cvs version is so much better, so it would be nice to have...

Best regards

Stoneface


Back to Top
 
Julian
Post: Nov 10th 2007 at 12:24 PM

Hi,
CVS version of tuxguitar, is now GCJ compat..
to did that, some things, were splitted as plugins..
but not all plugins are GCJ compat.
tuxguitar-jsa ( java sound api plugin ) is one case.

The problem, is you are running tuxguitar under GCJ ( see the (libgcj.so.81) acclarations.. or exec "java -version" to see more details ) and it works.. but java sound api plugin not.. ( tuxguitar-alsa is the only GCJ compat sound plugin available for the moment )

So well..
if you wan run tuxguitar under SUN java..
just set it as default on your system:
update-alternatives --config java

if you wan run tuxguitar under GCJ..
TuxGuitar/share/plugins/tuxguitar-jsa.jar must be removed.
TuxGuitar/share/plugins/tuxguitar-alsa.jar must exists
then select a software synthesizer ( timidity, fluidsynth..)


Back to Top
 
Stoneface
Post: Nov 10th 2007 at 3:04 PM

Thank you Julian !
the update-alternative trick work for me...
the other solution works as well, but I'm a banjo player and at the moment I couldn't find the banjo patch on freepats.org... But not so important, cause the other solution works right...

Best regards

Stoneface

PS: This is one of the most helpful forums, I've ever been, thanks again Julian, you do a great Job here !


Back to Top
 
Andy
Post: Mar 30th 2008 at 10:37 AM

Hi! I just Downloaded Tuxguitar 1.0 on my Ubuntu 7.10 and installed it. I opened an .gp5-file and played it but there was no sound. When I start Tuxguitar I get the error: "Java Sound Api cannot be loaded" I think that that somehow is the causing of the not playing the sound. How can I get my Tuxguitar playing the Tab and this Error going away??
Greets
Andy


Back to Top
 
Julian
Post: Mar 30th 2008 at 1:54 PM

Hi,
"Java Sound Api cannot be loaded" is throwed by tuxguitar-jsa plugin. try run tuxguitar on a terminal to see a full error log.
By other hand, you can install timidity:
sudo apt-get install timidity

and then go to Tools -> Settings : Sound, and select a Timidity Port on the MIDI Port option.


Back to Top
 
Martin
Post: Apr 17th 2008 at 10:59 PM

I'm getting the same problem. I've tried all the fixed here, none of which work. I'm using Ubuntu 7.10 (64-bit), on my new high-spec computer. I really want to use this program (I'm moving over from Windows where I had GP5). I can't get the sound to work.


Back to Top
 
Julian
Post: Apr 17th 2008 at 11:27 PM

Hi,
Go to "Tools -> Settings" please, and let me know what "MIDI Port" do you have selected ( and what ports do you have available to select )

And because your other post ("Cannot load Java sound api"):
http://www.tuxguitar.com.ar/rd.php/message_boards/forum_posts.do?fid=6&tid=520
Try run tuxguitar under a terminal, and paste here the error log please.


Back to Top
 
Martin
Post: Apr 18th 2008 at 4:22 PM

Okay, when I run TuxGuitar from the terminal, is actually gaveme this- "An error occurred while trying to set plugin status". The full log from the terminal is as follows-

"martin@martin-desktop:~$ tuxguitar
org.herac.tuxguitar.gui.system.plugins.TGPluginException: An error ocurred when trying to set plugin status
at org.herac.tuxguitar.gui.system.plugins.TGPluginManager.openPlugins(Unknown Source)
at org.herac.tuxguitar.gui.TuxGuitar.displayGUI(Unknown Source)
at org.herac.tuxguitar.gui.TGMain.main(Unknown Source)
Caused by: java.lang.UnsatisfiedLinkError: /usr/lib/jni/libtuxguitar-alsa-jni.so: /usr/lib/jni/libtuxguitar-alsa-jni.so: wrong ELF class: ELFCLASS32 (Possible cause: architecture word width mismatch)
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1751)
at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1676)
at java.lang.Runtime.loadLibrary0(Runtime.java:823)
at java.lang.System.loadLibrary(System.java:1030)
at org.herac.tuxguitar.player.impl.midiport.alsa.JNILibraryLoader.loadLibrary(JNILibraryLoader.java:18)
at org.herac.tuxguitar.player.impl.midiport.alsa.MidiSystem.(MidiSystem.java:11)
at org.herac.tuxguitar.player.impl.midiport.alsa.MidiPortProviderImpl.listPorts(MidiPortProviderImpl.java:17)
at org.herac.tuxguitar.player.base.MidiPlayer.addPortProvider(Unknown Source)
at org.herac.tuxguitar.gui.system.plugins.base.TGMidiPortProviderPlugin.addPluin(Unknown Source)
at org.herac.tuxguitar.gui.system.plugins.base.TGMidiPortProviderPlugin.setEnabled(Unknown Source)
... 3 more
javax.sound.midi.MidiUnavailableException: Audio Device Unavailable
at com.sun.media.sound.MixerSynth.implOpen(MixerSynth.java:165)
at com.sun.media.sound.AbstractMidiDevice.doOpen(AbstractMidiDevice.java:144)
at com.sun.media.sound.AbstractMidiDevice.open(AbstractMidiDevice.java:108)
at org.herac.tuxguitar.player.impl.jsa.midiport.MidiPortSynthesizer.getSynthesizer(Unknown Source)
at org.herac.tuxguitar.player.impl.jsa.midiport.MidiPortSynthesizer.open(Unknown Source)
at org.herac.tuxguitar.player.base.MidiPlayer.loadPort(Unknown Source)
at org.herac.tuxguitar.player.base.MidiPlayer.openPort(Unknown Source)
at org.herac.tuxguitar.player.base.MidiPlayer.addPortProvider(Unknown Source)
at org.herac.tuxguitar.gui.system.plugins.base.TGMidiPortProviderPlugin.addPluin(Unknown Source)
at org.herac.tuxguitar.gui.system.plugins.base.TGMidiPortProviderPlugin.setEnabled(Unknown Source)
at org.herac.tuxguitar.gui.system.plugins.base.TGPluginList.setEnabled(Unknown Source)
at org.herac.tuxguitar.gui.system.plugins.TGPluginManager.openPlugins(Unknown Source)
at org.herac.tuxguitar.gui.TuxGuitar.displayGUI(Unknown Source)
at org.herac.tuxguitar.gui.TGMain.main(Unknown Source)"

Under Tools > Settings > Sound, the MIDI Sequencers I have are 'Real Time Sequencer', and 'TuxGuitar Sequencer', and the MIDI Port only has 'Java Sound Synthesizer' in it.

Thanks in advance for your help. Your program seems really amazing, I just need to get it working lol.


Back to Top
 
Martin
Post: Apr 18th 2008 at 4:24 PM

P.S. When I try and play a file, it says 'MIDI system could not be loaded". I was previously getting the 'Java sound api cannot be loaded', and so I tried all the fixes in this thread, and am getting this new problem.


Back to Top
 
Julian
Post: Apr 18th 2008 at 4:54 PM

Well, you have 2 different problems here.

1) /usr/lib/jni/libtuxguitar-alsa-jni.so: wrong ELF class: ELFCLASS32 (Possible cause: architecture word width mismatch)
You told you have a 64bit arch.
but it seems you downloaded a 32 bit version of tuxguitar.
so, "tuxguitar-alsa" plugin will never work.
With it, you would able to load native MIDI Ports connected on your alsa system. ( there are no ports as default on allmost GNU/Linux distributions, but you can easily install "timidity" under ubuntu )

2) javax.sound.midi.MidiUnavailableException: Audio Device Unavailable
This second, is a known Java Sound Api problem.
I can't explain it better than how i did here:
http://www.tuxguitar.com.ar/tgwiki/doku.php?id=doc:error_midi_unavailable_linux

> When I try and play a file, it says 'MIDI system could not be loaded"
Sure, it's the same problem(2).. java sound api plugin couldn't be loaded at all.. so ofcourse it'll not be able to reproduce any sound.


Back to Top
 
Martin
Post: Apr 18th 2008 at 6:22 PM

It can't be the wrong architecture though, I installed 'GNU/Linux-x86_64 Binary Files' from your downloads section.


Back to Top
 
Julian
Post: Apr 18th 2008 at 6:42 PM

And how did you installed it ?
That is a simple .tar.gz package..
you should uncomprees it and run the tuxguitar script.
but i see on your error log:
1*
/usr/lib/jni/libtuxguitar-alsa-jni.so
Did you "manually" move this file to /usr/lib/jni ??

2*
martin@martin-desktop:~$ tuxguitar
Did you move "tuxguitar" script to /usr/bin ( or other PATH folder ) ?

If you just extracted the x86_64 files..
"tuxguitar" command will not work.
it should be:
/where_is_the_folder/tuxguitar
and the library should be:
/where_is_the_folder/lib/libtuxguitar-alsa-jni.so

But as the paths you have.. i think you have a .deb package installed.


Back to Top
 
Martin
Post: Apr 18th 2008 at 6:50 PM

To be honest it's probably entirely my fault. I'm new to Linux, and far too used to Windows. I extracted it to /home/martin.


Back to Top
 
Julian
Post: Apr 18th 2008 at 7:05 PM

> To be honest it's probably entirely my fault
I'm not looking for a fault :)

i'm just trying to understand what version do you have installed.
if you have this file:
/usr/lib/jni/libtuxguitar-alsa-jni.so

and you didn't manually move the file.. so you don't have the "GNU/Linux-x86_64 Binary Files" package. ( or maybe you have tuxguitar installed twoice on your system )

If you are complety sure you downloaded "GNU/Linux-x86_64 Binary Files". so try go on a terminal to the extraction place:
cd /where_you_extracted_the_folder
./tuxguitar

Note: "tuxguitar" and "./tuxguitar" is different.
tuxguitar: it means the file is on any PATH folder.
exec this to see what folders (separated with ":") are at your PATH:
echo $PATH

./tuxguitar: it means the file is at "./" (current folder)
/home/martin/tuxguitar: it means the file is at "/home/martin/"

Only to make sure..
please can you paste here the result of:
dpkg -l | grep tuxguitar


Back to Top
 
Martin
Post: Apr 18th 2008 at 11:11 PM

"martin@martin-desktop:~$ dpkg -l | grep tuxguitar
iU tuxguitar 1.0-rc3-ubuntu-x86 TuxGuitar is a multitrack guitar tablature e"

Hmmm, I definitely installed the x86-64 version. But not, according to that?


Back to Top
 
Julian
Post: Apr 19th 2008 at 12:01 PM

You have "tuxguitar 1.0-rc3-ubuntu-x86" installed.
i suggest you.. uninstall this .deb package:
sudo dpkg --purge tuxguitar

> I definitely installed the x86-64 version
Maybe you installed both versions ?

Just go where you downloaded/extracted x86_64 files.
and make 2 clicks to "tuxguitar" script.

By other hand, you can check this again:
http://www.tuxguitar.com.ar/forum_posts.html?fid=3&tid=555&view=NEW
there is a 64bit package now available.


Back to Top
 
Martin
Post: Apr 20th 2008 at 4:18 PM

Thanks. It seems I did have both versions installed. I purged the 32bit version from the terminal. However, I still have no sound on the 64bit version (all my Timidity MIDI ports seem to do nothing), and can't find TuxGuiar in the Ubuntu repositories (I cannot find any TuxGuitar files on the Synaptic Package Manager at all).


Back to Top
 
Julian
Post: Apr 20th 2008 at 9:57 PM

Yes, the snapshot release seems currently down.. ( check tomorrow )
if you don't have sounds with timidity, try this:
sudo modprobe snd_seq

and then, restart timidity:
/etc/init.d/timidity restart


Back to Top
 
Martin
Post: May 6th 2008 at 8:20 PM

I've updated to Ubuntu 8.04, and got my sound working. However, I decided to uninstall the TG I had (as it was in a messy place), and reinstall it from the repositories. I did this, and I cannot find it. It's not in Applications > Sound & Video at all.


Back to Top
 
Julian
Post: May 6th 2008 at 8:51 PM

Hi,

> I decided to uninstall the TG I had (as it was in a messy place)
If you are interested, i notice you that there is a 64bit .deb pakcage available to download now.

> reinstall it from the repositories. I did this, and I cannot find it. It's not in Applications > Sound & Video at all.
maybe because that repository package don't have a launcher menu file..
so you should run it on a terminal, or make your own launcher.


Back to Top
 
schmerse
Post: Sep 6th 2008 at 4:44 PM

Hi there,

I got the same problem. That's what I get:

schmerse@desktop1:~/tuxguitar-1.0$ ./tuxguitar
org.herac.tuxguitar.gui.system.plugins.TGPluginException: Java sound api cannot be loaded
at org.herac.tuxguitar.gui.system.plugins.base.TGMidiPortProviderPlugin.addPlugin(Unknown Source)
at org.herac.tuxguitar.gui.system.plugins.base.TGMidiPortProviderPlugin.setEnabled(Unknown Source)
at org.herac.tuxguitar.gui.system.plugins.base.TGPluginList.setEnabled(Unknown Source)
at org.herac.tuxguitar.gui.system.plugins.TGPluginManager.openPlugins(Unknown Source)
at org.herac.tuxguitar.gui.TuxGuitar.displayGUI(Unknown Source)
at org.herac.tuxguitar.gui.TGMain.main(Unknown Source)
Caused by: org.herac.tuxguitar.player.base.MidiPlayerException: Java sound api cannot be loaded
at org.herac.tuxguitar.player.impl.jsa.midiport.MidiPortProviderImpl.listPorts(Unknown Source)
at org.herac.tuxguitar.player.base.MidiPlayer.addPortProvider(Unknown Source)
at org.herac.tuxguitar.gui.system.plugins.base.TGMidiPortProviderPlugin.addPlugin(Unknown Source)
...5 more
Caused by: java.lang.UnsatisfiedLinkError: init_
at gnu.javax.sound.midi.alsa.AlsaMidiDeviceProvider.init_(libgcj.so.70)
at gnu.javax.sound.midi.alsa.AlsaMidiDeviceProvider.(libgcj.so.70)
at java.lang.Class.initializeClass(libgcj.so.70)
at java.lang.Class.newInstance(libgcj.so.70)
at gnu.classpath.ServiceProviderLoadingAction.run(libgcj.so.70)
at java.security.AccessController.doPrivileged(libgcj.so.70)
at gnu.classpath.ServiceFactory$ServiceIterator.loadNextServiceProvider(libgcj.so.70)
at gnu.classpath.ServiceFactory$ServiceIterator.(libgcj.so.70)
at gnu.classpath.ServiceFactory.lookupProviders(libgcj.so.70)
at gnu.classpath.ServiceFactory.lookupProviders(libgcj.so.70)
at javax.sound.midi.MidiSystem.getMidiDeviceInfo(libgcj.so.70)
at org.herac.tuxguitar.player.impl.jsa.midiport.MidiPortProviderImpl.listPorts(Unknown Source)
...7 more
org.herac.tuxguitar.player.base.MidiPlayerException: Java sound api cannot be loaded
at org.herac.tuxguitar.player.impl.jsa.midiport.MidiPortProviderImpl.listPorts(Unknown Source)
at org.herac.tuxguitar.player.base.MidiPlayer.listPorts(Unknown Source)
at org.herac.tuxguitar.gui.system.config.items.SoundOption$1.run(Unknown Source)
at java.lang.Thread.run(libgcj.so.70)
Caused by: java.lang.NoClassDefFoundError: gnu.javax.sound.midi.alsa.AlsaMidiDeviceProvider
at java.lang.Class.initializeClass(libgcj.so.70)
at java.lang.Class.newInstance(libgcj.so.70)
at gnu.classpath.ServiceProviderLoadingAction.run(libgcj.so.70)
at java.security.AccessController.doPrivileged(libgcj.so.70)
at gnu.classpath.ServiceFactory$ServiceIterator.loadNextServiceProvider(libgcj.so.70)
at gnu.classpath.ServiceFactory$ServiceIterator.(libgcj.so.70)
at gnu.classpath.ServiceFactory.lookupProviders(libgcj.so.70)
at gnu.classpath.ServiceFactory.lookupProviders(libgcj.so.70)
at javax.sound.midi.MidiSystem.getMidiDeviceInfo(libgcj.so.70)
at org.herac.tuxguitar.player.impl.jsa.midiport.MidiPortProviderImpl.listPorts(Unknown Source)
...3 more

I already installed that timidity, but still the same. I can't even choose a different midi port in settings.

Can anybody help me? I'm very keen on getting to run this software.

Thanx in advance,
schmerse


Back to Top
 
Julian
Post: Sep 6th 2008 at 5:01 PM

Java Sound Api don't start because you are running tuxguitar with GCJ (it don't implements java sound api at all)

If you don't want to see that error anymore, just go to Tools -> Plugins and disable Java Sound Api plugin.

> I already installed that timidity, but still the same. I can't even choose a different midi port in settings.
Is timidity running ??
try exec:
aconnect -o
Do you see any port like "Timidity Port 0.. bla bla" ??

If not, you need to start it:
timidity -iA -Os

Then go to Tools -> Settings on tuxguitar, and select it on MIDI Port at "sound" section.


Back to Top
 
schmerse
Post: Sep 6th 2008 at 6:50 PM

Thanx Julian,

timitidy wasn't running, I did what you suggested and now I can hear something, but it is running very bumpy. Any idea?

schmerse


Back to Top
 
Radissthor
Post: Sep 14th 2008 at 5:11 PM

Hi all,

I'm new at Ubuntu and my knowledge in computers is quite limited. I've downloaded TuxGuitar and I get the "Java sound api cannot be loaded" message. I've read the posts that have been written in this site, but, as I said, my limited knowledge of computers and I could not follow the instructions. For example, what does the following mean?

"So well..
if you wan run tuxguitar under SUN java..
just set it as default on your system:
update-alternatives --config jav"

Is there an option called update? All I could find was update manager, but there wasn't any "alternatives" option. I would appreciate some help.

Thanks,


Back to Top
 
Julian
Post: Sep 14th 2008 at 5:27 PM

Radissthor, some forum topics may be old.
each problem/solution depends on your tuxguitar version.
so, what tuxguitar version do you have ?
and how did you installed it ?

> update-alternatives --config java
This line is an Debian (and based distros, like ubuntu) thing.

TuxGuitar needs "java" to run.
update-alternatives, means there are some "java" implementations available, so you can choice what is the default.

If you are running tuxguitar 1.0, please run it under a terminal as:
tuxguitar -i

and paste here the returned log.


Back to Top
 
Radissthor
Post: Sep 14th 2008 at 5:36 PM

Sorry, I hadn't realized this was an old discussion.
I have the 1.0 version. What does it mean:

"run it under a terminal as:
tuxguitar -i" What's a terminal?


Back to Top
 
Radissthor
Post: Sep 14th 2008 at 5:51 PM

I'm really sorry for my lack of knowledge and for your patience. I managed to do what you asked. Here is what I got:

System Info:
-> OS-Name: Linux
-> OS-Arch: i386
-> OS-Version: 2.6.24-19-generic
-> JVM-Name: GNU libgcj
-> JVM-Version: 4.2.3 (Ubuntu 4.2.3-2ubuntu6)
-> JVM-Vendor: Free Software Foundation, Inc.
-> Java-Version: 1.5.0
-> Java-Vendor: Free Software Foundation, Inc.
-> Java-Home: /usr/lib/jvm/java-1.5.0-gcj-4.2-1.5.0.0/jre
-> Java-Class-Path: ::/usr/share/java/tuxguitar.jar:/usr/lib/java/swt.jar:/usr/share/java/itext.jar:/usr/share/tuxguitar/
-> Java-Library-Path: :/usr/lib/jni/:/usr/lib/jni/:/lib:/usr/lib:/usr/lib/jni:/usr/local/lib:/usr/lib/firefox
administrador@administrador-desktop:~$


Back to Top
 
Julian
Post: Sep 14th 2008 at 5:57 PM

Ups, i was writting how to open a terminal :p...

-> JVM-Name: GNU libgcj
ok, you have "GCJ" JVM (Java Virtual Machine).

GCJ don't implements Java Sound Api, so that is why it can't be loaded.

you can install "sun-java" package, exec (also on a terminal):
sudo apt-get install sun-java6-jre

Then, try to exec "tuxguitar -i" again, and check if "JVM-Name" was changed to Sun's version.

If yes you can try know if you have sounds.

Another suggestion, is to install "timidity"
sudo apt-get install timidity

Then, on tuxguitar go to "Tools -> Settings", and on "Sound" section select the first "Timidity" port on "MIDI Port" option.
it may have better sounds than with java.


Back to Top
 
Anonymous
Post: Sep 14th 2008 at 6:36 PM

It worked!! Thank you so very much!! I never thought I would be able to fix the thing! Thanks to people like you I hope I can learn the mysteries of Ubuntu, jajaja.

Cheers,


Back to Top
 
ptrdebont@gmail.com
Post: Aug 27th 2011 at 9:17 AM

Hello there,

Browsing the net, I came across a discussion from around 2007 (long time ago) and thus discovered a banjo player in your ranks. So am I; and this raises my hopes of someone able to tell me where to find a credible tenor banjo soundfont suitable for Ubuntu.

My apologies this hasn't anything to do with tuxguitar, but I'll clutch at every straw right now.


Back to Top