Tux Guitar

Problems

Subject Problema con Sonido



Author Message
Nahue's
Post: Jan 20th 2008 at 2:30 PM

Instalé TuxGuitar y entro al programa, el problema es que recibo un problema de Soundbank, así que decidí instalar el tuxguitar-alsa, pero ahora cuando inicio el tusguitar recibo este problema:

java.lang.UnsatisfiedLinkError: /home/Nahuel/tuxguitar-0.9.1-update1/lib/libMidiReceiverJNI.so: /home/Nahuel/tuxguitar-0.9.1-update1/lib/libMidiReceiverJNI.so: no se puede restaurar el `prot' del segmento después de la relocalización: Permiso denegado

tengo muchas gnaas de usar el programa, espero que se pueda solucionar :)
desde ya gracias


Back to Top
 
Nahue's
Post: Jan 20th 2008 at 2:36 PM

Mi OS es Fedora 8
la version de java es:
java version "1.7.0"
IcedTea Runtime Environment (build 1.7.0-b21)
IcedTea Client VM (build 1.7.0-b21, mixed mode)


Back to Top
 
Johnny
Post: Jan 20th 2008 at 10:02 PM

As I said in previous post, I'm not sure about IcedTea JNI capabilities. It should be OK, but maybe there's a problem with compatibility of the plugin. Try to install Sun Java Runtime Environment.

And maybe you should check if exists a file "/home/Nahuel/tuxguitar-0.9.1-update1/lib/libMidiReceiverJNI.so" and that you have a permission to read it.

I think we should wait for Julian, he has more experience.


Back to Top
 
Nahue's
Post: Jan 21st 2008 at 1:44 PM

Johnny you rock man, now i can run the plugin, appears that the problem was iced-tea, now at least work, but i can't get sound. I can open files, and play it, but can't get sound :S


Back to Top
 
Johnny
Post: Jan 21st 2008 at 6:09 PM

http://tuxguitar.com.ar/tgwiki/doku.php?id=doc:alsa_plugin_troubleshooting

That what help is for. :)


Back to Top
 
Nahue's
Post: Jan 22nd 2008 at 4:51 PM

Solved!
Thx johnny!!! :D


Back to Top