Tux Guitar

Problems

Subject Sin Sonido



Author Message
nitram
Post: Sep 25th 2006 at 3:44 PM

Mis mas sinceras Felicitaciones. Perfecto!!!

Solo que tengo un problema, no consigo hacer funcionar el sonido.

He seguido varios manuales, posibles soluciones en este for y por ultimo este:
http://daviblog.wordpress.com/2006/09/

Pero nada, no funciona.

Dejo la salida de tuxguitar:
TuxGuitar$ tuxguitar
javax.sound.midi.MidiUnavailableException: Audio Device Unavailable
at com.sun.media.sound.MixerSynth.implOpen(MixerSynth.java:154)
at com.sun.media.sound.AbstractMidiDevice.doOpen(AbstractMidiDevice.java:144)
at com.sun.media.sound.AbstractMidiDevice.open(AbstractMidiDevice.java:108)
at org.herac.tuxguitar.play.models.defaultplayer.SongPlayer.setSynthesizer(Unknown Source)
at org.herac.tuxguitar.play.models.defaultplayer.SongPlayer.getSynthesizer(Unknown Source)
at org.herac.tuxguitar.play.models.defaultplayer.SongPlayer.close(Unknown Source)
at org.herac.tuxguitar.play.models.defaultplayer.SongPlayer.init(Unknown Source)
at org.herac.tuxguitar.play.models.defaultplayer.SongPlayer.(Unknown Source)
at org.herac.tuxguitar.song.managers.SongManager.(Unknown Source)
at org.herac.tuxguitar.gui.TuxGuitar.displayGUI(Unknown Source)
at org.herac.tuxguitar.gui.TuxGuitar.main(Unknown Source)
javax.sound.midi.MidiUnavailableException: Audio Device Unavailable
at com.sun.media.sound.MixerSynth.implOpen(MixerSynth.java:154)
at com.sun.media.sound.AbstractMidiDevice.doOpen(AbstractMidiDevice.java:144)
at com.sun.media.sound.AbstractMidiDevice.open(AbstractMidiDevice.java:108)
at org.herac.tuxguitar.play.models.defaultplayer.SongPlayer.setSynthesizer(Unknown Source)
at org.herac.tuxguitar.play.models.defaultplayer.SongPlayer.getSynthesizer(Unknown Source)
at org.herac.tuxguitar.play.models.defaultplayer.SongPlayer.init(Unknown Source)
at org.herac.tuxguitar.play.models.defaultplayer.SongPlayer.(Unknown Source)
at org.herac.tuxguitar.song.managers.SongManager.(Unknown Source)
at org.herac.tuxguitar.gui.TuxGuitar.displayGUI(Unknown Source)
at org.herac.tuxguitar.gui.TuxGuitar.main(Unknown Source)

*****************************************
Muchas gracias y a ver si podeis ayudarme.
Un saludo


Back to Top
 
Julian
Post: Sep 25th 2006 at 5:50 PM

Hola,
Todavia no pude terminar de entender porque se da este problema con ciertas tarjetas de sonido..
el blog... http://daviblog.wordpress.com/2006/09/
tenia el mismo error y se contacto conmigo y conseguimos esa solucion,
pero no se decirte si esto te puede solucionar a vos.
tengo un par de preguntas:
1_ que OS estas usando ?
2_ lograste correr alguna aplicacion (rosegarden, kguitar..etc) que corra con timidity ?

una cosita mas, por ahora las veces que se dio este error, todos tenian una similitud.. era que no se obtenia salida Midi si otra aplicacion abierta usaba sonido...
intenta cerrar todo (incluso messengers que usan sonido) y luego dime si el error sigue apareciendo.

Saludos.


Back to Top
 
nitram
Post: Sep 25th 2006 at 7:05 PM

Solucionado!!!!

Uso Dapper. Hize correr Kguitar y funciono perfecto con timidity. Reemplaze el script del blog..de devibolg.. por la copia q tenía. Y en la cajetilla de alsa-plugins en Device ya me mostraba los de timidity.

Muchas gracias de nuevo, y enhorabuenapor tuxguitars.
Saludos.


Back to Top
 
Julian
Post: Sep 25th 2006 at 7:34 PM

Ok.. perfecto!!
fijate que en ububtu por defecto timidity no arranca solo..
si miras el archivo /etc/init.d/timidity, llama a un segundo archivo:
/etc/default/timidity
en este archivo hay que descomentar estas lineas para que prenda con linux:
TIM_ALSASEQ=true
TIM_ALSASEQPARAMS="-B2,8 -Os"

por otro lado, seguro lo sepas pero por si necesitas.. te comento que para prender timidity sin usar el /etc/init.d/timidity start.. podes ejecutar lo siguiente:
timidity -iA -Os
ese comando tambien prende el demonio.

Saludos.


Back to Top
 
nitram
Post: Sep 26th 2006 at 6:19 AM

Muchas gracias julian.

Pues no, no lo sabía, una cosa mas al saco....

Esta tarde probaré lo de default/timidity a ver que tal...
Un saludo.


Back to Top
 
kike
Post: Dec 18th 2007 at 10:03 PM

hola esta muy bueno este programa de tuxguitar pero yo tambien tengo otro problema
hace unos dias instale este programa y funcionaba muy bien pero luego dejo de sonar las notas y no he podido solucionar este problema (mi OS es ubuntu)


Back to Top
 
Julian
Post: Dec 19th 2007 at 8:11 AM

Hola,

intenta ejecutar tuxguitar desde una consola..
lanza algun error cuando intentas reproducir ??

esta por casualidad, "tuxguitar-alsa" instalado ?


Back to Top
 
Anonymous
Post: May 2nd 2009 at 6:13 AM

yo tenia el mismo problema y en otro foro enkontre ke hacia falta solo el "tuxguitar-jsa" y listo a divertirte...


Back to Top
 
Anonymous
Post: Jun 6th 2009 at 3:22 PM

Chicos, por mas que lo leo no lo entiendo, yo tengo la misma cosa, no se oye nada en TuxGuitar, soy un Newbie, estoy usando Ubuntu 9.04.
me podeis decir por favor como hacer funcionar el sonido, en lenguaje a prueba de tontos? os estare muy agrdecido


Back to Top
 
Julian
Post: Jun 6th 2009 at 5:05 PM

El problema es que mas alla de el asunto "sin sonido" aca se habla de un error especifico que indica "nitram".
Por eso seguramente al leer este hilo, no comprendas como solucionar tu problema.

A ver, veamos.
Usas ubuntu 9.04. ahora decime, como instalaste tuxguitar ? ( descargaste un paquete de esta pagina, o lo hiciste desde repositorios de ubuntu mediante synaptic o apt-get ? )
Esto es algo importante, porque los paquetes vienen configurados de diferente manera.

Si lo instalaste desde repositorios de ubuntu, asegurate de instalar "tuxguitar-alsa" ( si descargaste de esta pagina, ya esta incluido en el paquete ).
luego, abri synaptic e instala "timidity"

una vez instalado timidity ( y tuxguitar-alsa si es necesario ) reinicia tuxguitar, y llendo por el menu:
Tools -> Settings ( Herramientas -> Preferencias en castellano )
en la seccion Sound ( o Sonido )
fijate el MIDI Port ( Puerto Midi ), y selecciona la primer opcion de timidity que tengas.


Back to Top
 
Dan
Post: Jul 19th 2009 at 5:07 PM

Para que tengas audio en Tuxguitar con ubuntu 9.04 lo que debes haces es los siguiente:

1.- primero debes tener instalado tuxguitar

2.- verificar que tengas instalador tuxguitar-alsa en el gestor de paquetes Synaptic, si no aparece en verde instalalo

3.- abrir tuxguitar,
ir a herramnientas,
ir a preferencias
ir a pestaña sonido
y en secuenciador MIDI seleccionar "TuxGuitar Secuencer"
y en Puerto MIDI Gervil

y listo aplicas los cambios en tuxguitar y listo ya tienes audio, listo para reproducir tus tablaturas favoritas

espero le sirva a alguien


Back to Top
 
ignacio lica
Post: Aug 21st 2009 at 6:49 PM

perfecto me funciono


Back to Top
 
Ortiz
Post: Sep 4th 2009 at 3:32 AM

Disculpa Dan, a mí no me sale Gervil en el puerto MIDI, sino que me sale Midi trouhgt port-0 # 0 o también me sale
Midi trouhgt port-0 [14:0]

Como hago para que me salga el Gervil


Back to Top
 
Julian
Post: Sep 5th 2009 at 1:39 PM

Ortiz,

para que Gervill aparesca, tenes que tener instalado el plugin "tuxguitar-jsa" (java sound api), y tenes que usar openjdk (o tener gervill instalado en tu version de java )
si usas java de sun, seguro te aparesca "Java Sound Synthesizer" en lugar de gervill...

el puerto "Midi trouhgt port-0 #0" lo ves porq tenes instalado "tuxguitar-oss"
y el "Midi trouhgt port-0 [14:0]" (q en realidad es el mismo que el anterior ) lo lista tuxguitar-alsa.

te recomiendo que no uses alsa y oss a la ves.. desinstala uno (si me preguntas, yo dejaria solo el de alsa )
Con el de alsa (o oss) podes usar puertos nativos como timidity, fluidsynth, linuxsampler, etc...


Back to Top
 
Ortiz
Post: Sep 26th 2009 at 3:18 AM

YA me funcionó muchas gracias. Ya me aparece el Gervil y ya pude escogerlo. Felicitó a los que hicieron este programa está muy bueno, aunque una última pregunta, lo que pasa es que a veces cuando suena una canción, esta se traba, no reproduce bien, ustedes saben porque es eso?


Back to Top