Tux Guitar

Problems

Subject CVS version - cant save GP* files correctly



Author Message
Adrian Efes
Post: Feb 25th 2008 at 7:16 AM

In current CVS when you save tab in GuitarPro format (tried only v5 and v4) it comes out messed up. Reading these files created in GuitarPro is OK, but when I save them in TuxGuitar it's complete mess.

I know its CVS version, so I can't expect everything working just fine - I just want to let you know about this problem in case you haven't noticed yet.


Back to Top
 
Julian
Post: Feb 25th 2008 at 9:01 AM

Hi,
i was testing about, and found a problem when try to open gp5 files (maded by tuxguitar) on GP v5.00. ( this bug is fixed now )
but i don't found any problem with GP4 files.
can you give me more details about ?

Bye


Back to Top
 
Afro
Post: Feb 25th 2008 at 12:27 PM

I have fresh CVS build and I can't open some tg files and any gp4 or 5 files. There is also nothing in import/export submenu nor plugins windows.

It says:
afro@mrok:~/Desktop/taby$ tuxguitar
org.herac.tuxguitar.io.base.TGFileFormatException: Nie da się otworzyć: file:/home/afro/Desktop/taby/B.tg
at org.herac.tuxguitar.gui.actions.file.FileActionUtils.open(Unknown Source)
at org.herac.tuxguitar.gui.actions.file.OpenFileAction$2.run(Unknown Source)
at java.lang.Thread.run(Thread.java:619)
Caused by: org.herac.tuxguitar.io.base.TGFileFormatException: Unsupported file format
at org.herac.tuxguitar.io.base.TGSongLoader.load(Unknown Source)
... 3 more
org.herac.tuxguitar.io.base.TGFileFormatException: Nie da się otworzyć: file:/home/afro/Desktop/taby/blood_brothers_ver3.gp4
at org.herac.tuxguitar.gui.actions.file.FileActionUtils.open(Unknown Source)
at org.herac.tuxguitar.gui.actions.file.OpenFileAction$2.run(Unknown Source)
at java.lang.Thread.run(Thread.java:619)
Caused by: org.herac.tuxguitar.io.base.TGFileFormatException: Unsupported file format
at org.herac.tuxguitar.io.base.TGSongLoader.load(Unknown Source)
... 3 more


Back to Top
 
Julian
Post: Feb 25th 2008 at 12:42 PM

That is because you don't have the plugins.

When you do: ant -Ddist.version=blabla
the build.xml generate a clean source ( remove all unnecesary files, and precompiled packages ).

So you builded the main app "TuxGuitar", but now you need build ( or get prebuilded packages from CVS ) the plugins.
see at "share/plugins" folder of your builded package. and see the same folder of your tuxguitar CVS folder.

The first error you show me, will be fixed if you add "tuxguitar-compat.jar" to share/plugins.
( this plugin make file format compatibility beetween tuxguitar versions )

and for GP files, you need tuxguitar-gtp.jar

Bye


Back to Top
 
Afro
Post: Feb 25th 2008 at 1:17 PM

It works, thank you. As I compiled tg form cvs several months ago plugins just installed themselves, so I was a bit confused today.
btw. I found gp5.00 file, that can't be opened by tg.
http://members.lycos.co.uk/geomancer/BUA096.gp5


Back to Top
 
Julian
Post: Feb 25th 2008 at 3:15 PM

Ok, i'll see the file. Thanks


Back to Top
 
Adrian Efes
Post: Feb 26th 2008 at 5:54 AM

Ok I did some further testing. Problem occurred only when I open GP5 file created in GuitarPro 5.0 and then saved it in TuxGuitar. Julian maybe it was connected with problem you wrote above. I'll try newest CVS version ASAP and let you know.


Back to Top
 
Adrian Efes
Post: Feb 26th 2008 at 7:01 AM

So the problem is still the same even with the newest CVS version of gtp plugin...


Back to Top
 
Julian
Post: Feb 26th 2008 at 8:19 AM

mmm well.
can you send me the problematic file please ? to:
julian < AT > casadesus < DOT > com < DOT > ar


Back to Top