Tux Guitar

Problems

Subject alsa plugin install



Author Message
Nugget
Post: Feb 29th 2008 at 3:29 AM

Is there a binary download for the alsa plugins? I'm having difficulties attempting to compile it from source. I get errors such as the following when running the compile:
error: the import org.herac.tuxguitar.gui cannot be resolved.

Tuxguitar was installed from binary package. My system is Fedora 8 x86 (Eeedora on an Asus Eee PC, a cut down install of Fedora). I think all the other prerequisites have been met (Java SE RT 1.6 is installed)

Any help appreciated!


Back to Top
 
Julian
Post: Feb 29th 2008 at 5:45 AM

Hi,
I assume you are building tuxguitar-alsa for 1.0-rc1 ( released yesterday ).
that plugin is included as default on GNU/Linux releases.
Just go to "Tools -> Plugins" . if you see Alsa on the list, so it's installed.
To select an alsa port go to: "Tools -> Settings" : "Sound"
And select any alsa port on "Midi Port" combo.

but if you want build it, you must edit the file: build.properties. and set the property:
path.tuxguitar=/where_is/tuxguitar.jar


Back to Top
 
Nugget
Post: Mar 2nd 2008 at 3:18 AM

Correct - I can see the plugin installed in tools -> Plugins, yet configuration options for sound include:
Midi Sequencer: Tuxguitar Sequencer, Real time sequencer
Midi Port: Java Sound Synth, Midi through port-0

None of these options are working for me.

The "How to install Tuxguitar-alsa plugin" help mentions:

> Place plugin_tuxguitar-alsa.properties file in that folder.

> In that file is specified the location of plugin files. By
> default, you will need to place two files
> (libMidiReceiverJNI.so and TuxGuitar-alsa.jar) in
> $TUXGUITAR_DIRlib folder.


I guess part of my problem is that I don't have the .so or .jar files listed above - this is what I thought I had to compile. I also don't have the .properties file, and so there are no configurable proiperties for the plugin.

What do I need to do to obtain these files?


Back to Top
 
Johnny
Post: Mar 2nd 2008 at 8:39 AM

My bad, wiki is still for old version. I will correct it now.

Midi through port-0 is from ALSA, so you installed it properly. My guess is that you need to instal Timidity or similar.

http://tuxguitar.com.ar/tgwiki/doku.php?id=doc:alsa_plugin_troubleshooting


Back to Top
 
Julian
Post: Mar 2nd 2008 at 10:29 AM

Nugget: As Johnny say, "Midi through port" is the default alsa port. So you have alsa plugin already installed.
The problem, is that alsa port never play sounds as default.
you must install a software synthesizer.
i suggest you Timidity too.
then run timidity daemon: "timidity -iA -Os"
and select the timidity port from tuxguitar.


Back to Top
 
Nugget
Post: Mar 4th 2008 at 6:23 AM

Thanks guys - most helpful, getting very close now.

Sound quality is a bit nasty, but that's probably the hardware more than anything else.

:-)


Back to Top