Tux Guitar

Problems

Subject Alsa: no tuxguitar-alsa-jni in java.library.path



Author Message
Tilman
Post: Mar 20th 2008 at 9:07 PM

Hello,

i just downloaded the last pre-compiled tuxguitar jet excelsior package and installed it locally in my home-folder expecting great alsa sound :)

but the alsa plugin does not work for me, starting tuxguitar with the alsa plugin enabled results in the following error messages:

org.herac.tuxguitar.gui.system.plugins.TGPluginException: An error ocurred when trying to set plugin status
at java.lang.Void.(Unknown Source)
at java.lang.Void.(Unknown Source)
at java.lang.Void.(Unknown Source)
at java.lang.Void.(Unknown Source)
Caused by: java.lang.UnsatisfiedLinkError: no tuxguitar-alsa-jni in java.library.path
... 4 more

in the console and "An error ocurred when trying to set plugin status" in tuxguitar.

I've got snd-seq loaded and timidity is up and running, "aconnect -o" outputs:

lient 14: 'Midi Through' [type=kernel]
0 'Midi Through Port-0'
client 128: 'TiMidity' [type=user]
0 'TiMidity port 0 '
1 'TiMidity port 1 '
2 'TiMidity port 2 '
3 'TiMidity port 3 '

thank you for your help!


Back to Top
 
Julian
Post: Mar 20th 2008 at 9:39 PM

Hi,
the error say you the tuxguitar-alsa-jni library not found..
but that shouln't happends.
try moving share/plugins/tuxguitar-alsa/tuxguitar-alsa-jni.jnilib to the root folder ( same where is "tuxguitar" excecutable file )
but rename it as: libtuxguitar-alsa-jni.so


Back to Top
 
Tilman
Post: Mar 22nd 2008 at 4:00 PM

Hi,

i just tried what you've said but it did not work. I tried it by using a symbolic link (didnt work) and then moved tuxguitar-alsa-jni.jnilib to ./libtuxguitar-alsa-jni.so, which did not work, too.

then i tried the precompiled x86 binaries because i already have java installed but it failed because i use debian etch, which comes with glibc 2.3.6 and not glibc 2.4.

i will try to compile tuxguitar manually


Back to Top
 
Julian
Post: Mar 22nd 2008 at 4:21 PM

Ok, GLibC version should be the problem for Jet too.

Note the Jet package is a native version, and to "reduce" the executable size, the error messages was removed.
that's whay you saw "java.lang.Void.(Unknown Source)" lines

Does the java version "Caused by" error start with ? :
Caused by: java.lang.UnsatisfiedLinkError: no tuxguitar-alsa-jni in java.library.path


Back to Top
 
Josh
Post: Mar 27th 2008 at 4:47 PM

I also recieve this error when trying to Run via Eclipse.


Back to Top
 
Julian
Post: Mar 27th 2008 at 5:18 PM

What SWT are you using unde reclipse ??
does it contains the native libraries at the swt.jar file ?
if not.. are you setting the -Djava.library.path= property ?


Back to Top
 
Josh
Post: Mar 27th 2008 at 8:31 PM

probably not setting that -D properly (or at all).
SWT is the most recent (stable). And yes, it does contain the the .jniib file. It doesnt matter to me, I'm not using the plugin so I just excluded it from the build path.


Back to Top
 
Julian
Post: Mar 27th 2008 at 8:40 PM

Sorry, i understood other thing. ( about swt native libraries ) i don't know why :)
This topic is about tuxguitar-alsa....

> I'm not using the plugin so I just excluded it from the build path.
Ok but i'm curioslly... what OS do you have installed ?


Back to Top
 
Josh
Post: Mar 28th 2008 at 12:15 AM

Vista, that might have something to do with it.
I did not envounter this issue with Linux Red Hat.


Back to Top