Tux Guitar

Problems

Subject Compiled Sources and No Sound



Author Message
Jeff
Post: Mar 29th 2008 at 11:03 PM

Hi I compiled the sources of TuxGuitar and when I go to run the program I get no sound at all. I am doing this on Windows XP any help would be great.

I also would like to by default change it so Tux will open gp3, gp4 and gp5 files by default; which files do I have to edit to do this.

Thanks
Jeff


Back to Top
 
Julian
Post: Mar 30th 2008 at 1:47 PM

> I get no sound at all..
did you build any "sound" plguin ???
If yes, try see on "Tools -> Settings : Sound" and select a valid MIDI Port.

> I also would like to by default change it so Tux will open gp3...
I can't understand your question.. if the "tuxguitar-gtp" plugin is installed, so just go to "File -> Open" and select your GP file..


Back to Top
 
Jeff
Post: Mar 30th 2008 at 1:56 PM

I didn't build any sound plugins, which plugin do I need to build for Windows install and after I do the build where would I put the plugin?

The second question I did figure out thanks for replying Julian.

By the way I absolutely love Tuxguitar WOW!!! what a bueatiful program, thank you for working so hard on it Julian and the rest of your group!!


Back to Top
 
Julian
Post: Mar 30th 2008 at 2:07 PM

> which plugin do I need to build for Windows install
I suggest you build "TuxGuitar-jsa" ( Java Sound Api plugin )

> where would I put the plugin
You need copy the builded "tuxguitar-jsa.jar" to TUXGUITAR_INSTALLATION_FOLDER/share/plugins

Then(after restart tuxguitar) you should be able to load any java sound api MIDI Port at tuxguitar settings.


Back to Top