Tux Guitar

Problems

Subject Syncing problem



Author Message
firmit
Post: Apr 2nd 2008 at 12:30 PM

The red highlighted not that is suppossed to be played, is one step infront of the note that is actually played...

On Ubuntu 8.04 beta, TG 1.0rc3


Back to Top
 
Julian
Post: Apr 2nd 2008 at 12:40 PM

I can't understand.
can you tell me this with other words please ?


Back to Top
 
firmit
Post: Apr 2nd 2008 at 1:00 PM

I had an old gp5-file. Clapton - Theme from a movie that never happened. Made it myself in Guitar Pro. When I opened it in TuxGuitar, it started playing, but the visualization with the red-note that got marked on screen, is one step ahead of the actuall note that I hear.

There may be some kind of import problem, because it works fine when I make myown files in TuxGuitar, so.... self-diagnosting, I'm saying my old file is corrupted, or badly formatted. Q.E.D. - my fault :)


Back to Top
 
Julian
Post: Apr 2nd 2008 at 1:31 PM

Ok, i understand now.

> There may be some kind of import problem
If you "could" openned it.. so there is no problem with the file.
tuxguitar don't use the file to play it.. it just open the song, and release the file.

This is a known problem. Some users have a sound "delay" with java sound api synthesizer ( Java Sound Synthesizer )

What midi port do you have selected ?
See at "Tools -> Settings : Sound"

Do you have timidity installed ?? ( maybe it solve your problem )
you can install it:
sudo apt-get install timidity freepats

Then select: "Timidity Port 0 [128:0]" as MIDI Port on tuxguitar.


Back to Top
 
firmit
Post: Apr 2nd 2008 at 7:59 PM

This solved my problem!
First install, I got a crash report - a fail while installing. I had Opera running - if that has any known conlicts (it uses sound on occasions). Re-installing with apt-get, and Timidity startet.

Thanks


Back to Top