Tux Guitar

Problems

Subject No sound wth the latest version



Author Message
Bumbo
Post: Apr 3rd 2008 at 2:45 PM

I've just upgraded from 0.9.1 to 1.0-rc3 and I no longer have any sound. I have alsa-plugin installed and selected. Running tuxguitar through a console doesn't show any particular error message.

I have no idea what to do except downgrading to 0.9.1. Any hint that might help locate the problem ?


Back to Top
 
Julian
Post: Apr 3rd 2008 at 2:56 PM

What "alsa" MIDI Port do you have selected ?


Back to Top
 
Bumbo
Post: Apr 3rd 2008 at 4:08 PM

MIDI Sequencer = Tuxguitar Sequencer
MIDI Port = EMU10K1 MPU-401(UART) [16:0]

I have no idea what "MPU-401(UART) [16:0]" means ^^


Back to Top
 
Julian
Post: Apr 3rd 2008 at 4:20 PM

"EMU10K1 MPU-401(UART) [16:0]" is a port connected to alsa.
exec "aconnect -o" to see all alsa ports.

I don't know about how to enable that midi port. ( i don't have it on my list ).

i can suggest you install timidity.
then run it as a daemon ( Only if your OS don't do it as default ):
timidity -iA -Os

and select a timidity port on tuxguitar.

What OS do you have installed ?
what tuxguitar-1.0-rc3 release did you download ?

and, how did you get sounds on 0.9.1 ? ( did you use tuxguitar-alsa, or just the default java sound ? ).


Back to Top
 
Anonymous
Post: Apr 3rd 2008 at 4:31 PM

"exec "aconnect -o" to see all alsa ports."

$ aconnect -o
client 16: 'SB Live 5.1' [type=kernel]
0 'EMU10K1 MPU-401 (UART)'
client 17: 'Emu10k1 WaveTable' [type=kernel]
0 'Emu10k1 Port 0 '
1 'Emu10k1 Port 1 '
2 'Emu10k1 Port 2 '
3 'Emu10k1 Port 3 '


Back to Top
 
Anonymous
Post: Apr 3rd 2008 at 4:33 PM

"i can suggest you install timidity.
then run it as a daemon ( Only if your OS don't do it as default ):
timidity -iA -Os"

I have timidity++ latest version installed and with de daemon started but it doesn't show any new choice for the MIDI Port.


Back to Top
 
Bumbo
Post: Apr 3rd 2008 at 4:35 PM

"What OS do you have installed ?"
Gentoo GNU/Linux

"what tuxguitar-1.0-rc3 release did you download ?"
Builded from the source on your website

"and, how did you get sounds on 0.9.1 ? ( did you use tuxguitar-alsa, or just the default java sound ? )."
I have know idea how I did get sound but I had the alsa plugins installed.

PS: oops, I forgot to put my nickname in the previous messages


Back to Top
 
Julian
Post: Apr 3rd 2008 at 4:58 PM

> I have timidity++ latest version installed and with de daemon started but it doesn't show any new choice for the MIDI Port.

Are you sure you have it started ?
if yes, you should see it on "aconnect -o" result.

> Builded from the source on your website
Did you build the "tuxguitar-jsa" plugin ?
its a "Java Sound Api" plugin for tuxguitar. ( 0.9.1 came with that sound as default )

At last, i see you have more options than "'EMU10K1 MPU-401 (UART)'"
did you test if one of this ports work ?
0 'Emu10k1 Port 0 '
1 'Emu10k1 Port 1 '
2 'Emu10k1 Port 2 '
3 'Emu10k1 Port 3 '


Back to Top
 
Bumbo
Post: Apr 3rd 2008 at 9:28 PM

"Are you sure you have it started ?
if yes, you should see it on "aconnect -o" result."
I'm sure it's started but nothing appears in aconnect, it must not be properly configured.

"At last, i see you have more options than "'EMU10K1 MPU-401 (UART)'" did you test if one of this ports work ?"
I tested all of them, but nothing works.

"Did you build the "tuxguitar-jsa" plugin ?
its a "Java Sound Api" plugin for tuxguitar. ( 0.9.1 came with that sound as default )"
That was it ! Now with de jsa plugin I can select Java Sound Synthetiser for the MIDI port and have sound. I'm going to post ebuilds for this on the gentoo bugzilla ^^ (and for the other plugins while I'm at it).

PS: However maybe I should investigate about how to make it work with my sound card synthetiser or with timitidy++.

PS2: I didn't test for long this latest version of TuxGuitar, but that's enough to see, imho, that it rocks and that it is superior to guitarpro now ^^. Great job! Thx a lot !!


Back to Top
 
Julian
Post: Apr 3rd 2008 at 9:48 PM

> That was it ! Now with de jsa plugin I can select
> Java Sound Synthetiser for the MIDI port and have sound.
So it seems on 0.9.1 you had the plugin installed, but maybe it was "disabled"

> However maybe I should investigate about how to make it
> work with my sound card synthetiser or with timitidy++.
Java Synth haven't nice soundbanks.. so i agree on try other synth.
I don't have any idea how timidity is configured under "Gentoo".
But i think if "aconnect -o" don't display anything, maybe timidity is throwing an error when you try start it.

timidity should start with "timidity -iA -Os" ( it worked on all GNU/linux distributions i tested ).

Some distributions ( like debian ) came with a /etc/init.d/timidity script.
but on old debian like distributions you had to edit "/etc/default/timidity" and uncomment some things to make the init.d script work.

Another option is "fluidsynth". it works fine. but you need manually download a soundfont for it.
e.g: http://alsa.opensrc.org/8MBGMSFX.SF2
then you can run it as:
~$ fluidsynth 8MBGMSFX.SF2

But i think the best option is by searching for your "EMU10K1" ports.
That ports aren't displayed as default on allmost soundcards.. So i think you have a MIDI Card ?
i readed some time, MIDI cards needs load a soundfont.
with a command like "asfxload". but i'm not sure


Back to Top