Tux Guitar

Problems

Subject tuxguitar 0.9.1 not starting on Debian Lenny



Author Message
Matt
Post: Apr 30th 2008 at 10:29 PM

Hello, TuxGuitar will not start on my system. I am using the version that comes in Debian Lenny's respiratory (0.9.1-4). When I try to start the app from a terminal, I get this:

Exception in thread "main" java.lang.UnsupportedClassVersionError: Bad version number in .class file
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:620)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:124)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:260)
at java.net.URLClassLoader.access$100(URLClassLoader.java:56)
at java.net.URLClassLoader$1.run(URLClassLoader.java:195)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:268)
at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:319)

Any help will be greatly appreciated.


Back to Top
 
Julian
Post: May 1st 2008 at 12:45 AM

Hi, "UnsupportedClassVersionError" means you are running the application with an "older" java version than used to build it.
But as i "don't have idea" what java compiler version was used to build the .deb package, so i can't give you a "real" solution.. but i can sugget you try with sun-java6 ( i think it is the latest java on debian lenny repositories )


Back to Top
 
Matt
Post: May 1st 2008 at 7:57 PM

Thanks Julian, ill try that out.


Back to Top