Tux Guitar

Problems

Subject JET Version - Can't Access Settings



Author Message
floborg
Post: May 30th 2008 at 6:09 AM

I've installed the JET version of tuxguitar in Puppy Linux 4.00. I can run it and actualy play powertab and guitarpro files with sound, but I cannot change any settings. When I click on, say, Sound, nothing happens. It's stuck on General, and I can't even change those settings.


Back to Top
 
Julian
Post: May 30th 2008 at 11:31 AM

What about the normal java version ?? do you have the same problem ???
try run tuxguitar under a terminal, and see if it's throwing any error when you try to open settings.


Back to Top
 
floborg
Post: May 31st 2008 at 12:34 AM

No errors in the terminal. I noticed that, after clicking on Sound, if I click in the Window Title area for General, I get a dropdown list of audio sequencers. Maybe it's possible to go to the different settings tabs, but the display doesn't actually update.


Back to Top
 
Johnny
Post: May 31st 2008 at 12:55 AM

So your settings don't save? Do you have ~/.tuxguitar-rc? folder (and permission to write)?


Back to Top
 
floborg
Post: May 31st 2008 at 3:23 AM

I have that hidden folder, and I can write to it. The only config files are:

config.properties
history.properties
plugin.properties
toolbars.xml
plugins/tuxguitar-jsa.cfg

I managed to hide some toolbars by manually editing the toolbars.xml file. I can't fid any sound settings in those files.


Back to Top
 
Julian
Post: May 31st 2008 at 12:43 PM

the main settings are stored on "config.properties"

what you see at the sound step is setted with this keys:
midi.sequencer
midi.port

as example, if you have "tuxguitar alsa", and you want to connect to port 128:0 (see aconnect -o )

on config.properties you should set:
midi.port=tuxguitar-alsa_128-0

by the way:
> if I click in the Window Title area for General...
it should't happen.
you should see also MIDI Port combo.. do you see it ?

what GTK version do you have installed ?


Back to Top
 
floborg
Post: Jun 3rd 2008 at 1:02 AM

I don't see any sound settings. All I see are the settings on the General tab. After clicking on Sound, the General settings are still there, but I can click in the Window Title field and some sound options appear. There is no feedback as to what is selected.

I believe Puppy 4.0 uses GTK 2.12.1. I was able to get the main Java version of an earlier tuxguitar release to work properly with Puppy 3.01, which, if anything, used an earlier version of GTK (a mix of GTK 1 and 2???).


Back to Top
 
Julian
Post: Jun 3rd 2008 at 11:05 AM

GTK 2.* should be fine..

do you know how to build tuxguitar ?
if yes, can you try build svn version and test if it still happening ?


Back to Top
 
floborg
Post: Jun 4th 2008 at 4:04 AM

No. I do not. Wouldn't that be a shared version requiring Java rather than the static JET version. I don't think the problems I've seen with the JET version exist in the normal shared version.


Back to Top
 
Julian
Post: Jun 4th 2008 at 1:34 PM

I don't think it's an JET problem.
JET is a JVM. but who paint the screen is SWT/gtk.

I tried to fix this problem.. but ofcourse i can't test if i can't reproduce the bug.


Back to Top