Tux Guitar

Problems

Subject i can't open tuxguitar



Author Message
mathieu
Post: Jun 17th 2008 at 6:48 AM

hello,
I have an error message when I try to open tuxguitar :

Exception in thread "main" org.eclipse.swt.SWTException: Unable to load graphics library [Cairo is required] (java.lang.UnsatisfiedLinkError: no swt-cairo-gtk-3436 or swt-cairo-gtk in swt.library.path, java.library.path or the jar file)

I have jre1.6 and my /temp have the exec permission.

Must I break my computer or is there a solution ?

Thanks.


Back to Top
 
Julian
Post: Jun 17th 2008 at 11:08 AM

What tuxguitar release did you download ?? or did you build it yourself ?

libswt-cairo-gtk-[version].so is missing on your SWT library

But as default the compiled packages we provide include SWT libraries ( with the ubuntu package exception, so it take dependencies from repositories. )

Do you maybe have Debian ???
if yes, make sure you have installed this package:
libswt-cairo-gtk-3.3-jni


Back to Top
 
daddy
Post: Jun 18th 2008 at 1:19 AM

had same problem but downloaded tuxguitar 64 bit version started working check version you need


Back to Top
 
mathieu
Post: Jun 18th 2008 at 6:21 AM

I have a mandrake10.2. I tried to install the pakage for x86 and the bin but it doesn't work (I have always the same error).
I will try the tuxguitar 64bit version but I think I will have the same error.

I can use tuxguitar with windows and I must say it's a great program and I'm happy to find it. I hope I can use it with a linux platform.


Back to Top
 
Julian
Post: Jun 18th 2008 at 12:36 PM

daddy, you maybe had the same "org.eclipse.swt.SWTException",
but with different cause. if this problem would be the 64bit version, the error message should say something like "wrong ELF class"
But this error say: "Unable to load graphics library [Cairo is required] ....."

mathieu, do you have cairo installed ??
What's the result of:
ls /usr/lib/ | grep cairo


Back to Top
 
mathieu
Post: Jun 20th 2008 at 6:07 AM

yes, grep gives this result :
libcairo.so.@
libcairo.so.1.0.0


Back to Top
 
Julian
Post: Jun 20th 2008 at 10:46 AM

i think (not really sure) swt needs libcairo2 but it seems you have libcairo 1.


Back to Top