Tux Guitar

Problems

Subject Drums and audio balance



Author Message
Guy
Post: Jun 23rd 2008 at 3:39 AM

Hi everyone,

Congratulations to the devs about the 1.0 release :)

I have noted a strange behaviour of drum tracks, regarding to audio balance: drums are always present on the 2 channels of the stereo output.

Say, I make a partition with a bass track and a drum track. I put the balance cursor of the drum track all the way to the right, and the balance cursor of the bass track all the way to the left. If I listen to the right HP, I will hear only the drums. If I listen to the left HP, I will hear the bass and the drums at about half volume.

Another test: I mute the drums tracks: I hear bass on the left and nothing from the right HP. If I unmute the drums and mute the bass track, I hear drums on the right and drums at half volume on the left.

Is it a normal behaviour ? I understand that most of the times drums audio balance is at the center, but I try to make records of bass + drums on separate channels so I can record myself playing and make a mix.

I don't know if it is related but I notice that on the mixer there is a difference between drum tracks and regular tracks: it is impossible to choose the "channel(?)", it is always 9.

I have the same behaviour with timidity and qsynth.


Back to Top
 
Julian
Post: Jun 23rd 2008 at 10:41 AM

Hi,
this isn't normal, nobody reported any problem like that before (i'm testing and also don't happen to me ).
Try please test to export a midi file with some mixing things, and then exec it with an external midi player ( e.g timidity ) ... does it sound as it should ?

What Java are you using to run tuxguitar ?
exec: tuxguitar -i

What "MIDI Sequencer" do you have selected at: Tools -> Settings : Sound"

> it is impossible to choose the "channel(?)", it is always 9.
That is fine. MIDI channel 9, is percussion reserved.


Back to Top
 
Guy
Post: Jun 23rd 2008 at 8:50 PM

Hi,

I made 2 midi files: one with bass on left (balance 0) and drums on right (balance 127), and another with the contrary. You can get them there:
http://www.faltine.com/tuxguitar/BassL-DrumsR.mid
http://www.faltine.com/tuxguitar/DrumsL-BassR.mid
When reading the files with timidity, I hear Bass+Drums on the Drums side. The bass side is ok.

Output of tuxguitar -i :
System Info:
-> OS-Name: Linux
-> OS-Arch: i386
-> OS-Version: 2.6.24.7-1.rt3.2.fc8.ccrmart
-> JVM-Name: Java HotSpot(TM) Server VM
-> JVM-Version: 10.0-b22
-> JVM-Vendor: Sun Microsystems Inc.
-> Java-Version: 1.6.0_06
-> Java-Vendor: Sun Microsystems Inc.
-> Java-Home: /usr/java/jre1.6.0_06
-> Java-Class-Path: ::./tuxguitar.jar:lib/swt.jar:lib/itext.jar:share/
-> Java-Library-Path: :lib/:/lib:/usr/lib:/usr/lib/jni:/usr/local/lib:/usr/lib/mozilla

The sequencer selected is Midi Sequencer.
I don't know if it is important, but the sound card is a Teratec Phase 22. There is no midi (mpu-401) or something on the board, only a midi input plug. I use timidity or qsynth with jack.


Back to Top
 
Julian
Post: Jun 23rd 2008 at 9:51 PM

I think i understand the problem
i tried carefully listen the sounds with timidity (free pats) output.
and i could heard a very little sound of "snare" sounding on the right speaker (while i have all to left )

But i also could determine why it happen.
the this is on the default timidity "reverb".
It seems the reverb effect sound on all speakers instead of the current channel balance.

You can check it by running timidity wihtout reverb:
timidity -iA -Os -EFreverb=0

then ofcourse select the new timidity port on tuxguitar.

If you are asking yourself, so why the .mid file worked, it is because tuxguitar set that controllers to "0" when export to midi, but keep defaults when play).

With fluidsynth ( qsynth + jack ) i also heard something similar. but it's not solved by removing reverb.
but i could see same happend if i play the exported file:
aplaymid --port [fluidsynth port] test.mid


Back to Top
 
Guy
Post: Jun 24th 2008 at 10:02 AM

I am not sure if I understand correctly. Do you still have, like me, some drums on the wrong side when exporting to midi ?

I desactivate the reverb in timidity too. What is really strange is that bass is correctly cut from the other speaker. There is something strange with Drums.

When I play the mid files on timidity, I notice there is 3 channels (the ones I can see in tuxguitar's mixer). The drums only use one channel ? Perhaps it is the explanation ? Because drums are mono channel it is impossible to completely cut them from a side ?


Back to Top
 
Guy
Post: Jun 24th 2008 at 10:55 AM

I did some more tests, with headphones and all volumes to max.
Looks like I was mistaken and there is no difference with bass or drums.
Actually, when setting balance to max left or max right, there is always some sound going to the other side. It is just more noticeable with drums.


Back to Top
 
Julian
Post: Jun 24th 2008 at 11:09 AM

> Do you still have, like me, some drums on the wrong side when exporting to midi ?
Yes if i use a fluidsynth port.
Not under timidity.

> The drums only use one channel ?
Yes it does.
the second channel, is used to play effects.
There are some MIDI messages what are applied to the full channel while you need only apply it to one note, like "pitch_bend" messages
tuxguitar use "pitch_bend" to make Bend, Vibratos, Slide, etc.
If tuxguitar would use only 1 channel peer track.
when you have a "bend" note, that bend will be applied to all notes at the beat.
but if you have a different channel. you can play normal notes on ch0, and effects on ch1.

However, volume and balance are applied to channels.
if track have only 1 channel.. so it need be applied to 1.


Back to Top
 
andres
Post: Aug 11th 2008 at 4:24 AM

man i just got a question for you how i can make drums track like backingtracks? can you tell me how? my e-mail : ANDREZSLIPKNOT@HOTMAIL.COM ..plz help me =) and thanks bro.


Back to Top