Tux Guitar

Problems

Subject Tuxguitar can't open a file



Author Message
Eldar Insafutdinov
Post: Jun 29th 2008 at 12:30 PM

I have just installed tuxguitar and have an issue with it. I click open button - choose the file to open, click on this file but nothing changes - it doesn't open the file - the new empty tab that appeared after the startup remains. furthermore - I close the app, then start it once again but it cannot start second time:
eldar@linux-t4ge:~> tuxguitar
/usr/bin/tuxguitar: line 142: /usr/lib/jvm/jre/jre/bin/java: No such file or directory
Tuxguitar 1.0, openSUSE 11. Java 1_6RE Sun


Back to Top
 
Julian
Post: Jun 29th 2008 at 2:44 PM

What 1.0 package did you downloaded ?
does "/usr/lib/jvm/jre/jre/bin/java" exists on your system ?


Back to Top
 
Eldar Insafutdinov
Post: Jun 30th 2008 at 7:24 AM

Package is from Packman repository. /usr/lib/jvm/jre/jre/bin/java doesn't exist - I manually changed the path to the correct one($JAVA) but when launched tuxguitar again it showed
Exception in thread "main" java.lang.NoClassDefFoundError: org/herac/tuxguitar/gui/TGMain
Caused by: java.lang.ClassNotFoundException: org.herac.tuxguitar.gui.TGMain
at java.net.URLClassLoader$1.run(URLClassLoader.java:200)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:276)
at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:319)


Back to Top
 
Julian
Post: Jun 30th 2008 at 11:06 AM

The launcher script of that package has something wrong

> NoClassDefFoundError: org/herac/tuxguitar/gui/TGMain
This is because the file "tuxguitar.jar" is not correctly setted at java CLASSPATH.
I suggest you open the script "/usr/bin/tuxguitar" with any text editor, and check all paths are pointing to an existent location.
You also should report it to packman package mantainers.


Back to Top
 
Eldar Insafutdinov
Post: Jul 2nd 2008 at 6:55 PM

Ok, I'll gonna inform package maintainer of tuxguitar in packman. For now I downloaded binary package from this site, and it runs well. But I have another issue - no sound is played :( Maybe the problem is that in opensuse sound system is pulse audio?


Back to Top
 
Julian
Post: Jul 2nd 2008 at 10:51 PM

I knew about pulseadudio have some conflicts with MIDI for some users.
but i really don't know how to solve it (the only way i know is by killing pulse server, and use alsa as default).

Did you try with timidity ?


Back to Top
 
Anonymous
Post: Jul 6th 2008 at 7:38 PM

I installed timidity from the beginning. Maybe I had to switch some option in tuxguitar to timidity?


Back to Top
 
Julian
Post: Jul 6th 2008 at 8:19 PM

Ofcourse you need select any timidity port on tuxguitar
at "Tools -> Settings : Sound" chose it on MIDI Port

If it´s not on the list, make sure the timidity daemon is running:
timidity -iA -Os


Back to Top
 
Eldar Insafutdinov
Post: Jul 6th 2008 at 9:03 PM

I have just installed ubuntu 8.04, chose TiMidity port 0 [128:0], restarted app and it started working :) thanks


Back to Top