Tux Guitar

Problems

Subject No sound



Author Message
bepaald
Post: Jul 2nd 2008 at 10:20 PM

Hi! I'm running tuxguitar 1.0 and I'm having some sound issues. That is, I have no sound. I am running Fedora 8 with icedtea and tuxguitar from the compiled binary. I have not disabled any plugins.

I have a Sound Blaster Live and a soundfont loaded. aconnect -o returns:

[~/Programs/tuxguitar-1.0-linux-x86] $ aconnect -o
client 14: 'Midi Through' [type=kernel]
0 'Midi Through Port-0'
client 16: 'SB Live 5.1 Dell OEM [SB0220]' [type=kernel]
0 'EMU10K1 MPU-401 (UART)'
client 17: 'Emu10k1 WaveTable' [type=kernel]
0 'Emu10k1 Port 0 '
1 'Emu10k1 Port 1 '
2 'Emu10k1 Port 2 '
3 'Emu10k1 Port 3 '

Playing a midi file with pmidi

pmidi -p 17:0 file.mid

or with aplaymidi

aplaymidi --port 17 file.mid

works fine: it plays the midi with the soundfont I loaded (so I know volume is up too).

But in tuxguitar, tools->settings->sound has no options to choose from at all (I thought it was supposed to give the same options as aconnect -o).

So, any thoughts on this anyone? I really liked this program a lot, never had trouble with the previous version, but I missed all the rc's for 1.0.


Back to Top
 
Julian
Post: Jul 2nd 2008 at 10:56 PM

Hi,

> I have not disabled any plugins.
Ok not disabled, but are they installed ?
do you have "tuxguitar-alsa" and/or "tuxguitar-jsa" ?

See on "Tools -> Plugins"
"Alsa output plugin"
"Java Sound Api plugin"

> I thought it was supposed to give the same options as aconnect -o
It should with "alsa" plugin.


Back to Top
 
Javi
Post: Jul 8th 2008 at 2:06 PM

The same problem here.


Back to Top
 
beatman
Post: Jul 8th 2008 at 2:19 PM

IcedTea in Fedora 8 does not support the java sound api, at least that's what I remebered and found in the release notes: http://docs.fedoraproject.org/release-notes/f8/en_US/sn-Java.html.

Fedora 9's does or use the sun jre.

bye, beat


Back to Top