Tux Guitar

Problems

Subject Can't open files from folders with russian letters



Author Message
Qrdl
Post: Jul 24th 2008 at 9:17 AM

user@qrdl:~/???????> uname -a
Linux qrdl 2.6.25.11-0.1-default #1 SMP 2008-07-13 20:48:28 +0200 i686 athlon i386 GNU/Linux
user@qrdl:~/???????> locale
LANG=ru_RU.UTF-8
LC_CTYPE="ru_RU.UTF-8"
LC_NUMERIC="ru_RU.UTF-8"
LC_TIME="ru_RU.UTF-8"
LC_COLLATE="ru_RU.UTF-8"
LC_MONETARY="ru_RU.UTF-8"
LC_MESSAGES="ru_RU.UTF-8"
LC_PAPER="ru_RU.UTF-8"
LC_NAME="ru_RU.UTF-8"
LC_ADDRESS="ru_RU.UTF-8"
LC_TELEPHONE="ru_RU.UTF-8"
LC_MEASUREMENT="ru_RU.UTF-8"
LC_IDENTIFICATION="ru_RU.UTF-8"
LC_ALL=


Back to Top
 
Julian
Post: Jul 24th 2008 at 11:10 AM

Hi,
can you paste here one of that russians folder name please ?
I tried to reproduce the bug with this text "????????? ?????????" what i found on the web (don't ask me what this means :) )
But i could save/load files inside that folder.

What TuxGuitar version do you have ? and what package release ?


Back to Top
 
Julian
Post: Jul 24th 2008 at 11:13 AM

mmm, the text i pasted couldn't be saved on the DB.

I taked it from:
http://en.wikipedia.org/wiki/Russia

Is on the first line, where is a link pointing to a .ogg file.


Back to Top
 
Anonymous
Post: Jul 25th 2008 at 7:28 AM

openSUSE 11.0 Gnome 2.22.1
TuxGuitar 1.0 Packman

It's mean "Russian Federation". But it does't work on my PC too.


Back to Top
 
Julian
Post: Jul 25th 2008 at 10:41 AM

Try run tuxguitar under a terminal.
what is the error log when you try to open that files ?


Back to Top
 
Qrdl
Post: Jul 25th 2008 at 11:39 AM

No errors. It just silently ignoring File->Open command when try to open tab from folders with russian letters.

user@qrdl:~> TuxGuitar.sh

configure java-environment ...
configuring TuxGuitar ...
starting TuxGuitar application ...
java virtual machine used: /usr/lib/jvm/jre/bin/java
classpath used: /usr/share/java/TuxGuitar/lib/itext-1.4.5.jar:/usr/share/java/TuxGuitar/tuxguitar.jar:/usr/share/java/TuxGuitar/share/plugins/tuxguitar-ascii.jar:/usr/share/java/TuxGuitar/share/plugins/tuxguitar-alsa.jar:/usr/share/java/TuxGuitar/share/plugins/tuxguitar-gtp.jar:/usr/share/java/TuxGuitar/share/plugins/tuxguitar-musicxml.jar:/usr/share/java/TuxGuitar/share/plugins/tuxguitar-tef.jar:/usr/share/java/TuxGuitar/share/plugins/tuxguitar-fluidsynth.jar:/usr/share/java/TuxGuitar/share/plugins/tuxguitar-pdf.jar:/usr/share/java/TuxGuitar/share/plugins/tuxguitar-converter.jar:/usr/share/java/TuxGuitar/share/plugins/tuxguitar-jsa.jar:/usr/share/java/TuxGuitar/share/plugins/tuxguitar-compat.jar:/usr/share/java/TuxGuitar/share/plugins/tuxguitar-ptb.jar:/usr/share/java/TuxGuitar/share/plugins/tuxguitar-tray.jar:/usr/share/java/TuxGuitar/share/plugins/tuxguitar-midi.jar:/usr/share/java/TuxGuitar/share/plugins/tuxguitar-lilypond.jar:/usr/share/java/TuxGuitar/share/plugins/tuxguitar-oss.jar:/usr/share/java/swt/swt-gtk-3.3.1.1.jar:/usr/share/TuxGuitar
main class used: org.herac.tuxguitar.gui.TGMain
flags used: -Xms128m -Xmx128m
options used: -Djava.library.path=/usr/lib64/swt:/usr/lib64:/usr/lib/swt:/usr/lib
arguments used:
user@qrdl:~>


Back to Top
 
Julian
Post: Jul 25th 2008 at 12:09 PM

ok.. if there is no error, is because the "File Dialog" provided by SWT (with GTK on low level) didn't return any filename (as when you cancel operation).

I mean, the way to know if you cancelled operation on SWT file dialogs, is the return value.
if it's null, so you cancelled. else you choose a file.
If SWT would return a non null value, you should see any error such as "No Such file", "Unsupported File Format", or any other realtime error.

looking your log, i see you have SWT-3.3 (see the "/usr/share/java/swt/swt-gtk-3.3.1.1.jar" entry at classpath used )
My test of load/save on a russian folder was with "swt-3.4"

But now i'm testing with 3.3 and 3.2 too, and work without problems for me.

So it can be a GTK problem instead of SWT ?
what GTK version do you have installed ?

What about if you open the file as URL (File -> Open URL):
file://PATH_TO_THE_FILE

Does it work ?


Back to Top
 
Qrdl
Post: Jul 25th 2008 at 2:31 PM

I have gtk+-2.12.9

File -> Open URL "file:///home/user/???????/????/Chaif-Oi-o1.gp3" works fine.

Also I notice such behaviour with tabs with russian letters in file names.


Back to Top
 
Julian
Post: Jul 25th 2008 at 2:51 PM

GTK version is fine..
i'm not sure if can be a 64bit version of SWT/GTK bug.

> Also I notice such behaviour with tabs with russian letters in file names.
Yes i'm working on that.
it's because GP* file format don't work on unicode characters as default.
I was talking with a japanese user about this last month.
So you need to specify the file "encoding" to read texts, but we can't set one as default. because by adding a charset encoding to one country, it make a wrong encoding for other country.

The current solution (on SVN trunk version) is a new GTP plugin config dialog, where you can set the default encoding.
So, Japanese people will able to read Japan chars by setting "windows-31j" charset. but that will not read Latin chars :)

We also tested, that my GP and him GP (both 5.2) was different.
mine, can't display Japan chars, but yes Latin chars
while him GP can display Japan but not latin.

So i don't know what is the default Russian encoding used by GP, but after found it on the list it may work without problems.


Back to Top