Tux Guitar

Problems

Subject No sound-Ubuntu 8.04



Author Message
bobbyc
Post: Jul 27th 2008 at 1:41 AM

Everything looks great and I love all the features, but as stated, I have no sound. I searched these forums, installed timidity, but still no luck. When I start tuxguitar from terminal I get "No sound note", but otherwise no errors. From Tools--> Settings--> Sounds, the MIDI port is blank, and there are no options to select anything


Back to Top
 
Julian
Post: Jul 27th 2008 at 3:48 PM

Do you have installed any sound plugin ?

How did you get tuxguitar ?
Is there on "Tools -> Plugins" anything of this plugins ?:
* "Alsa output plugin" ( from tuxguitar-alsa )
* "Java Sount Api plugin" ( from tuxguitar-jsa )

These are 2 default plugins available for GNU/Linux distributions. make sure your package include that plugins


Back to Top
 
bobbyc
Post: Jul 27th 2008 at 4:25 PM

I used Ubuntu's Synaptic Package Manager to install tuxguitar. Those two plugins were not installed, but were available through Synaptic. I installed them and now it plays. Thank you so much


Back to Top
 
Nosidam
Post: Aug 21st 2008 at 4:43 PM

Hi Everybody

Just downloaded tuxguitar through ubuntu 8.04 synaptic Package Manager. I cannot get any sound out of my songs and I tried searching the repositories for the plugins listed above to no avail. Just wondering if anyone knew where I could find another source for those plugins, Or another solution for my MIDI sound issues.

Thanks All


Back to Top
 
Julian
Post: Aug 21st 2008 at 6:17 PM

Note that ubuntu hardy, have a very older version of tuxguitar on repositories.
So you can't found plugins because they didn't exist for that version.
I suggest you download latest version of tuxguitar.


Back to Top
 
kard
Post: Jul 25th 2009 at 7:16 PM

thanks...


Back to Top
 
MPA
Post: Aug 21st 2009 at 3:12 PM

Julian, thanks for your help. I installed tuxguitar-jsa and I changed MIDI Port in Tools --> Settings --> Sound --> MIDI Port to Gervill and I can hear musik. Thanks...


Back to Top
 
Danny
Post: Nov 13th 2009 at 6:45 PM

I only got his working after installing the Timidity package (via Synaptic). Select then MIDI port: Timidity port 0 [129:0]. Choise of sequencer seems irrelevant. I am using Ubuntu 9.10.


Back to Top
 
sabbath_sun
Post: Dec 17th 2009 at 3:29 PM

hey thnx a lot u guys...i've been looking for a soln to this prob for a long time...


Back to Top
 
Derathor
Post: Feb 28th 2011 at 4:28 PM

Worked for me too, thanks!


Back to Top
 
Nosnbär
Post: Mar 31st 2011 at 9:48 PM

Still working with 10.10 (for me)
Just installed tuxguitar-jsa for the Java Sount Api plugin bacaue the Alsa output plugin was already in the patch from the ubuntu-software-center.

Thanks alot!


Back to Top
 
Anonymous
Post: May 15th 2011 at 10:07 PM

For me I had to install timidity and then choose timidity port in settings


Back to Top
 
Anonymous
Post: Sep 11th 2011 at 9:21 PM

worked for me, download timidity and change port in settings on pinguy 11.04 thanks


Back to Top
 
Anonymous
Post: Feb 25th 2012 at 2:52 PM

Worked! Thanks, guys.


Back to Top
 
josh
Post: Mar 19th 2012 at 4:53 AM

hey guys I also cannot get my sound to work for tuxguitar I've tried everything I know including above and I cant seem to get it to work. tuxguitar doesnt even show that I have timidity installed when I know I do cause I'm looking at it right now.. but I am running linux mint 11, and I downloaded tuxguitar from the software manager (same with the plugins) any help would be greatly apreciated!


Back to Top
 
josh
Post: Mar 19th 2012 at 5:01 AM

never mind. I reinstalled tuxguitar and now its recognising timidity. yay!


Back to Top