Tux Guitar

Problems

Subject No sound



Author Message
frojnd
Post: Aug 1st 2008 at 4:29 PM

Hello there. I'm new to Tuxguitar. I've downloaded .ptb file from ultimate-guitar.com and I'm not able to listen any sounds, when mute. When opening alsamixer, everything is ok, nothing on mute. Also alsa is on since I can listen to music from amarok. Does anyone know why I can't play .ptb file? I use linux x86: 2.6.25.11-0.1-pae #1 SMP 2008-07-13 20:48:28 +0200 i686 i686 i386 GNU/Linux


Back to Top
 
frojnd
Post: Aug 1st 2008 at 8:30 PM

Looks like when starting timidity before tuxguitar there is a sound.


Back to Top
 
Julian
Post: Aug 2nd 2008 at 2:28 PM

Hi,
> I can listen to music from amarok
Note that Audio and MIDI are different things.
amarok is an Audio application, and tuxguitar a MIDI app.

> Does anyone know why I can't play .ptb file?
It happen only with PTB files ??
What about with a new file.. do you have sounds ?


Go to "Tools -> Settings", on "Sound" section.
what MIDI Port do you have selected ??
make sure you have a "timidity" port selected.


Back to Top
 
Bennie
Post: Aug 3rd 2008 at 9:17 PM

Hello,

I'm having the same problem. I'm trying to play gp3/gp5 files (haven't tried any others yet), but there's no sound.

In the sound settings I only have a "MIDI through Port-0 [14:0]" option. Nothing else.

I reinstalled timidity, and tuxguitar, but I still only have that option :(

I'm using OpenSuse x86 2.6.25.5-1.1-pae


Back to Top
 
Julian
Post: Aug 3rd 2008 at 11:30 PM

Hi,
Timidity is installed.. but is the daemon running ??

try run it as:
timidity -iA -Os

under Debian based distributions, there is an init script what run it on system startup.. it seems that script is not available under Suse.

once timidy daemon running, you should be able to select the timidity port 128:0 on tuxguitar.


Back to Top
 
Bennie
Post: Aug 4th 2008 at 10:38 AM

Cool, that fixed the problem. Thanks!


Back to Top
 
ken (ac4rd)
Post: Aug 30th 2008 at 1:29 PM

this fixed my "no sound" problem, too! THANKS! Fedora 8 newbie, just trying TuxGuitar for the first time.


Back to Top
 
A Lu
Post: Mar 21st 2010 at 2:44 AM

I've installed TuxGuitar 1.2 (tuxguitar-1.2-windows-x86-installer) Sometimes it sounds, sometimes not. But my system is OK with other software such as KMPlayer, Windows Media Player. Is it enough just to install that software, and what is the difference between windows-x86 installer and windows-x86 jet? Many thanks.


Back to Top
 
Julian
Post: Mar 27th 2010 at 3:38 PM

A Lu,
same question.. what MIDI Port do you have selected?
At downloads section you can see descriptions for each download..
basically the diff is that Jet version don't needs java installed in your system.


Back to Top
 
Thrawn
Post: May 7th 2011 at 9:42 AM

It works for me with the Timidity port; BUT when i choose the timidity port Banshee stops working :(


Back to Top
 
Hrishi
Post: May 8th 2011 at 8:34 AM

I had the same problem. I followed Julian's instructions over here and now MIDI files are playing on TuxGuitar.

Thanks all.

hrishi


Back to Top