Tux Guitar

Problems

Subject I got problem with setting timidity



Author Message
daweed
Post: Oct 2nd 2008 at 10:57 PM

[IMG]http://i274.photobucket.com/albums/jj274/DaweedLion/Screenshot-6.png[/IMG]

I installed Timidity, but Tuxguitar doesn't reckognise it? What should I do? I use Debian.Please help, guys...


Back to Top
 
daweed
Post: Oct 2nd 2008 at 10:58 PM

http://i274.photobucket.com/albums/jj274/DaweedLion/Screenshot-6.png


Back to Top
 
Julian
Post: Oct 2nd 2008 at 11:18 PM

Do you have "tuxguitar-alsa" plugin installed ?

Is timidity running ?
exec on a terminal: aconnect -o
To see MIDI ports connected to alsa.


Back to Top
 
daweed
Post: Oct 4th 2008 at 8:16 PM

Thank you for your reply.

Yes, I have tuxguitar-alsa installed and I have pmidi installed. I got ALL Tuxguitar plugins installed. I have this displayed when I enter that command into terminal :

aconnect -o
ALSA lib seq_hw.c:457:(snd_seq_hw_open) open /dev/snd/seq failed: No such file or directory
can't open sequencer

What should I do?


Back to Top
 
Julian
Post: Oct 5th 2008 at 1:48 PM

You don't have "snd_seq" kernel module loaded.
this module is needed to make MIDI works on ALSA.

Try load it (as root):
modprobe snd_seq

(on some distributions module is called snd-seq instead of snd_seq, see "-" vs "_", so if first don't work try second option)

Once it loaded you can try run timidity:
/etc/init.d/timidity start

Or if you don't have the repository version
run it as:
timidity -iA -Os

then try again : aconnect -o
if timidity is at list, it should be on tuxguitar settings too.


Back to Top
 
daweed
Post: Oct 5th 2008 at 6:44 PM

Thank you man!


Back to Top