Tux Guitar

Problems

Subject Stumbling playback



Author Message
realhangman
Post: Oct 10th 2008 at 12:23 PM

Hi,

I really like Tuxguitar and could already convince some of my bandmates to migrate from GP4 to Tuxguitar (they work on windows).

They have no problems with playback, but my playback on linux (debian testing) is very stumbling. Sometimes different instruments start with half a second difference, even if they should start at the very same sample.

I'm using tuxguitar with timidity or fluidsynth. Timidity seems to be even worse, but fluidsynth is also very bad in playing tuxguitar's output.
When I export my data to midi and import them into Rosegarden (with the same fluidsynth configuration), I hear a compelte perfect playback.

Is this a known issue? I'm sorry if that's a double post, but I found no search function, and honestly spoken, this forum isn't very good with the "help" and "problems" sections, they are confusing (which is for what?).
Maybe a bug tracker and an irc channel would be good?
Just a suggestion :)

Thanks for the program,
Regards
Realhangman


Back to Top
 
daddario
Post: Oct 10th 2008 at 4:36 PM

I have the same problem. I installed java and selected java output. With that it worked perfeclty. Well, atleast until i had to reboot. After that i cant get java working again. Maybe I'm just an idiot.


Back to Top
 
Julian
Post: Oct 10th 2008 at 10:40 PM

realhangman,
i have a little delay with timidity (but it's same for all tracks, so all run zynchronised ) this is a known issue,
and with fluidsynth i have no delay, but make my PC harder if i use hard quality sound fonts.
but i have same issues with them under Rosegarden, Noteedit, and other notation editors that i tested.

The only issue i can think now, is that tuxguitar-1.0 or lesser don't have chorus,reverb,etc support (yes on SVN version) so it play synthesizer defaults. but when a midi file is exported, these effects are setted to "0" (so no effects).
fluidsynth as default add some chorus and delay to allmost soundfonts i tested, and this cause more sounds quality, so more CPU usage.
So when you open a MIDI file exported in tuxguitar on rosegarden -> fluidsynth, you are running "clean" sounds, while on tuxguitar you are listening processed effects sounds on allmost cases.
I think this can be the difference that make your problem.
To test if it's true, you can set effects on rosegarden and then listen it.


Back to Top
 
realhangman
Post: Oct 11th 2008 at 12:15 AM

Julia & daddario,

thanks for the quick answers.
But no, it's not related to the effects, since I can use rosegarden with quite a lot effects with no glitches.
I also run this on a AMD Phenom 4x2.5GHz system, so system load is no issue.
I just tested it again - now (for what reason whatsoever) the instruments start synchronised, but the timing sometimes fastens and slows down during a single bar, making it sound stumbling.

I also had this issue back with Tuxguitar 0.9 and my old single core 2 GHz system. I'm using debian testing with a custom built kernel (currently 2.6.26.6), tweaked for good response for work with Ardour and Rosegarden.

Regards,
realhangman


Back to Top
 
realhangman
Post: Oct 11th 2008 at 12:16 AM

Julian of course, sorry!


Back to Top
 
Julian
Post: Oct 11th 2008 at 12:39 AM

yes, i'm a man :)

Go to Tools -> Settings: Sound.
what MIDI Sequencer do you have selected ?
Try choose other, and check if asyncrhonization continues.


Back to Top
 
Julian
Post: Oct 11th 2008 at 12:42 AM

Can you paste here the result of ?:
tuxguitar -i


Back to Top
 
realhangman
Post: Oct 11th 2008 at 11:14 AM

Hi,

I can only select "TuxGuitar Sequencer", there is no other choice.

Here is the output of tuxguitar -i:

-> OS-Name: Linux
-> OS-Arch: x86_64
-> OS-Version: 2.6.26.6
-> JVM-Name: GNU libgcj
-> JVM-Version: 4.3.2
-> JVM-Vendor: Free Software Foundation, Inc.
-> Java-Version: 1.5.0
-> Java-Vendor: Free Software Foundation, Inc.
-> Java-Home: /usr/lib/jvm/java-1.5.0-gcj-4.3-1.5.0.0/jre
-> Java-Class-Path: ::./tuxguitar.jar:lib/swt.jar:lib/itext.jar:share/
-> Java-Library-Path: :lib/:/lib:/usr/lib:/usr/lib/jni:/usr/local/lib:/usr/lib/f
irefox

realhangman


Back to Top
 
realhangman
Post: Oct 11th 2008 at 11:27 AM

Hi,

I guess I've solved it (for me, al least)!
Excuse me that I forgot to mention that I used the x86_64 binary files from this page, as debians tuxguitar package was broken for a very long time.

Now I tried debians package again, it seems to work perfectly! Interestingly, now the output of tuxguitar -i shows me:

-> OS-Name: Linux
-> OS-Arch: amd64
-> OS-Version: 2.6.26.6
-> JVM-Name: Java HotSpot(TM) 64-Bit Server VM
-> JVM-Version: 10.0-b23
-> JVM-Vendor: Sun Microsystems Inc.
-> Java-Version: 1.6.0_07
-> Java-Vendor: Sun Microsystems Inc.
-> Java-Home: /usr/lib/jvm/java-6-sun-1.6.0.07/jre
-> Java-Class-Path: :/usr/share/tuxguitar/:/usr/share/tuxguitar//tuxguitar.jar:/usr/share/java/itext.jar:
-> Java-Library-Path: /usr/lib/jni

I still can only select "TuxGuitar Sequencer" but, it uses pretty much never java libraries. The view of the program is also much better (I had so scroll horizontally a lot with the binary files).

Great! Now it's really only a few steps from perfection away :)

Thanks a lot Julian!


Back to Top
 
daddario
Post: Oct 11th 2008 at 3:51 PM

Well my problem stays: I dont have a option for a java output device like I used to have. With timidity the sound is terrible.


Back to Top
 
Julian
Post: Oct 11th 2008 at 11:34 PM

realhangman, difference beetween both results of "tuxguitar -i" is java that are you using.
on first you have GCJ. it don't implement all packages of java sound api, so this cause you can't get jsa plugin features.
and second is with sun java 6.
By the way if you installed debian package from repositories,
you need to install tuxguitar-jsa to get java sound api plugin.

daddario, same as before.. do you have "tuxguitar-jsa" plugin installed ?
see on "Tools -> Plugins"
it should be named "Java Sound Api plugin"


Back to Top
 
Anonymous
Post: Oct 17th 2008 at 4:50 PM

Yes, I have the Java Sound Api plugin. But there is no java output listed in the outputs.


Back to Top
 
Julian
Post: Oct 17th 2008 at 10:48 PM

Note that "Java Sound Synthesizer" isn't open sourced.
you'll get it available only if you use a Sun's java.
Are you maybe running tuxguitar with OpenJDK ?
Try exec "tuxguitar -i" as realhangman did and see what java version are you using.


Back to Top
 
Daddario
Post: Oct 25th 2008 at 4:09 PM

daddario> tuxguitar -i
System Info:
-> OS-Name: Linux
-> OS-Arch: i386
-> OS-Version: 2.6.18-6-486
-> JVM-Name: Java HotSpot(TM) Client VM
-> JVM-Version: 10.0-b23
-> JVM-Vendor: Sun Microsystems Inc.
-> Java-Version: 1.6.0_07
-> Java-Vendor: Sun Microsystems Inc.
-> Java-Home: /usr/lib/jvm/java-6-sun-1.6.0.07/jre
-> Java-Class-Path: :/usr/share/tuxguitar/:/usr/share/tuxguitar//tuxguitar.jar:/usr/share/java/itext.jar:
-> Java-Library-Path: /usr/lib/jni
daddario>


Back to Top
 
Julian
Post: Oct 25th 2008 at 8:32 PM

It's strange you should be available to use java sound synth.

On "MIDI Sequencer" do you have "Real Time Sequencer" option available ??
this option is also from Java Sound Api plugin.


Back to Top
 
pan
Post: Jul 15th 2009 at 6:51 PM

Thank you!

For me installing package tuxguitar-jsa
and then switching to "real time sequencer"
fixed stumbling / asynchronous sound on
ubuntu linux 9.04

- pan -


Back to Top