Tux Guitar

Suggestions

Subject No reproduce.



Author Message
nicoo
Post: Jan 4th 2008 at 6:12 PM

Hola. Soy usuario de Linux, chileno. Me he bajado el TuxGuitar para poder aprender un poco más de tocar guitarra pero me ha surgido un problema.. al cargar la pista solo aparece la partitura, al apretar Reproducir me dice "No se encontro un soundbank disponible."

¿Qué puedo hacer? Me pasa con todas las pistas que he probado..mi SO es Ubuntu 7.10

Saludos


Back to Top
 
Julian
Post: Jan 5th 2008 at 6:51 PM

Hola, ejecuta tuxguitar sobre una consola, y mostrame el error exacto que aparesca.


Back to Top
 
gonzalo
Post: May 19th 2008 at 2:55 PM

Hola a mi me pasó lo mismo. Hasta ayer andaba bien. El problema es que recién estoy comenzando y no sé cómo ejecutarlo desde consola. Gracias


Back to Top
 
Julian
Post: May 19th 2008 at 3:06 PM

Hola,

> no sé cómo ejecutarlo desde consola
Vayamos por partes.. que sistema operativo tenes ??
y que paquete de tuxguitar tenes instalado ?


Back to Top
 
luis jaime
Post: Jun 1st 2008 at 3:57 PM

Me doy cuenta que vosotros teneis el mismo error que yo. La forma de cargarlo desde la consola es simple: tuxguitar.

La salida que me da a mí es esta:
luisjaime@luisjaime-laptop:/$ tuxguitar
javax.sound.midi.MidiUnavailableException: Audio Device Unavailable
at com.sun.media.sound.MixerSynth.implOpen(MixerSynth.java:165)
at com.sun.media.sound.AbstractMidiDevice.doOpen(AbstractMidiDevice.java:144)
at com.sun.media.sound.AbstractMidiDevice.open(AbstractMidiDevice.java:108)
at org.herac.tuxguitar.player.impl.jsa.midiport.MidiPortSynthesizer.getSynthesizer(Unknown Source)
at org.herac.tuxguitar.player.impl.jsa.midiport.MidiPortSynthesizer.open(Unknown Source)
at org.herac.tuxguitar.player.base.MidiPlayer.loadPort(Unknown Source)
at org.herac.tuxguitar.player.base.MidiPlayer.openPort(Unknown Source)
at org.herac.tuxguitar.player.base.MidiPlayer.addPortProvider(Unknown Source)
at org.herac.tuxguitar.gui.system.plugins.base.TGMidiPortProviderPlugin.addPlugin(Unknown Source)
at org.herac.tuxguitar.gui.system.plugins.base.TGMidiPortProviderPlugin.setEnabled(Unknown Source)
at org.herac.tuxguitar.gui.system.plugins.base.TGPluginList.setEnabled(Unknown Source)
at org.herac.tuxguitar.gui.system.plugins.TGPluginManager.openPlugins(Unknown Source)
at org.herac.tuxguitar.gui.TuxGuitar.displayGUI(Unknown Source)
at org.herac.tuxguitar.gui.TGMain.main(Unknown Source)

como podeis ver no me suena nada y ve que hay varios unknown que debo cambiar pero que no sé como hacerlo.

Les agradezco la ayuda.


Back to Top
 
Sebastian89
Post: Jun 1st 2008 at 4:19 PM

hola, a mi me pasa lo mismo usando ubuntu hardy,instale el timidity, pero me dio un error a ldarle la instruccion start , he leido lso foros, pero al parecer como timidity no me fuinciono no ha podido encontrar las otras alidas de audio .

gracias .


Back to Top
 
Julian
Post: Jun 1st 2008 at 4:47 PM

Hola,

luis jaime: Este error esta en la documentacion (pero en ingles).

"Audio Device Unavailable" es un error que lanza el plugin tuxguitar-jsa (Java Sound Api) cuando no puede abrir dispositivos de audio.

Normalmente este problema se puede dar por 2 razones:

1* el modulo "snd_seq" del kernel no esta cargado. (necesario para la reproduccion MIDI)

para comprobarlo esta linea deberia mostrar los modulos cargados que comiencen con snd_seq (si no hay resultados, es porque no esta cargado) :
lsmod | grep snd_seq

si no esta cargado, se puede cargar ejecutando (como root):
modprobe snd_seq

2* Java Sound Api, funciona sobre OSS, el cual tiene problemas para ejecutar 2 o mas aplicaciones de audio al mismo tiempo en algunas tarjetas de sonido (notar que hasta un messenger reproduce sonidos)
para solucionar esto, se puede usar "alsa-oss" como wrapper entre alsa y oss.
para esto, instalar alsa-oss, y despues ejecutar: "aoss tuxguitar" ( aunque no siempre soluciona el problema ).

Sebastian89: con respecto a timidity, ya estamos hablando del plugin "tuxguitar-alsa", el cual lista los puertos midi conectados a alsa ( esos puertos se pueden ver ejecutando "aconnect -o" )

Si timidity tira un error cuando lo intentas prender, seguramente sea el mismo problema que explique arriba sobre el modulo "snd_seq", ya que sin ese modulo cargado, ni Alsa ni OSS ni Java Sound Api va a funcionar.

si no es ese el problema, seria mejor que nos digas cual es exactamente el error que muestra.


Back to Top
 
luis jaime
Post: Jun 2nd 2008 at 9:44 PM

buen día compañeros resulta que instalé el ubuntu studio, ahora me aparece el pulse audio e instaló un montón de cosas que no me solucionan el problema.

la salida a lsmod | grep snd_seq me da ahora lo siguiente:

snd_seq_dummy 3972 0
snd_seq_oss 34048 0
snd_seq_midi 8480 0
snd_rawmidi 24608 1 snd_seq_midi
snd_seq_midi_event 7552 2 snd_seq_oss,snd_seq_midi
snd_seq 51152 7 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer 23556 3 snd_rtctimer,snd_pcm,snd_seq
snd_seq_device 8588 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
snd 54692 22 snd_rtctimer,snd_hda_intel,snd_hwdep,snd_pcm_oss,snd_pcm,snd_mixer_oss,snd_seq_dummy,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device

Con toda esta información ayudadme por favor.


Back to Top
 
Julian
Post: Jun 2nd 2008 at 9:58 PM

probaste usar alsa-oss ?

sino lo mejor seria que instales timidity:
sudo apt-get install timidity freepats

despues anda al menu de tuxguitar "Tools -> Settings" y "Sound" donde esta el combo MIDI Port selecciona el puerto 128:0 de timidity.


Back to Top
 
luis jaime
Post: Jun 3rd 2008 at 12:39 AM

Gracias Julián


Back to Top
 
luis jaime
Post: Jun 3rd 2008 at 12:45 AM

Tengo instalados el timidity en "su versión más reciente" selecciono en herramientas tuxguitar sequencer y lo cambio por real sequencer y nop no suena.

Con la instalada del ubuntu studio veo que el desempeño del sonido mejoró sustancialmente.

Cuando le cambio a java sound sequencer me da un error de "MIDI system is unavailable" así que estoy como en el comienzo.

Julián te agradezco las ayudas que me haz dado hasta ahora.


Back to Top
 
luis jaime
Post: Jun 3rd 2008 at 12:48 AM

Adiciono: también activé el puerto 128:0 de timidity pero nop. Nop suena...

Gracias nuevamente


Back to Top
 
Julian
Post: Jun 3rd 2008 at 11:16 AM

Hola,
Para preproducir sonidos, tenes que seleccionar el "MIDI Port" ( este luego abre un sintetizador )

El Sequencer no reproduce sonidos. este solo llama al sintetizador para reproducirlos en un momento determinado.

Sequencer VS Synthesizer.
No me salen palabras para explicarlo muy claramente, pero te puedo dar un ejemplo que di hace poco en este foro:
* Synthesizer: es como si fuera un instrumento.. tocas una nota y suena.
* Sequencer: Es como una persona.. agarra un instrumento (Syntethiser) y toca una cancion

Poniendo en limpio todo:
Si seleccionas un "MIDI Port", con el simple echo de "agregar una nota" en tuxguitar, ya deberias escuchar el sonido de la nota por los parlantes.

Si escuchas las notas que agregas, pero al apretar play no pasa nada. entonces el problema es el Sequencer.

En este caso:
> Cuando le cambio a java sound sequencer me da un error de "MIDI system is unavailable"
Segun entiendo, por alguna razon Java Sound Api no te logra lebantar tampoco el "sequencer".
entonces selecciona "TuxGuitar Sequencer".

> activé el puerto 128:0 de timidity pero nop. Nop suena
veamos.. intenta probar timidity con otra aplicacion.
usa algun archivo .mid ( si no tenes, puedes exportar uno con tuxguitar ) y ejecuta:
aplaymidi --port 128:0 TuArchivo.mid

Sale sonido ?


Back to Top
 
luis jaime
Post: Jun 4th 2008 at 12:41 AM

Julián gracias por tu esfuerzo por ser lo más claro. Te lo agradezco en el alma.

Lo que quiero comentarles ahora es que inexplicablemente, porque creo haber probado todas las combinaciones, la combinación REal time sequencer y Java Sound Synthesizer ha hecho que suene mi tuxguitar.

El sonido no es que uff pero sirve para lo que quiero y es componer algunas cosillas y escuchar las piezas para tocarlas luego.

Si tengo alguna duda ulterior acudiré a vosotros.

Nuevamente gracias Julián por tu ayuda.

Me gustaría no perder contacto contigo. EScribema a este mail y allí de doy otro. negociosljsr@yahoo.com


Back to Top
 
luis jaime
Post: Jun 4th 2008 at 12:54 PM

Otra vez por aquí, tan inexplicablemente como me funcionó el tuxguitar ayer hoy está inaudible con el mismo mensaje de "midi unavailible".

Voy a hacer las pruebas que me sugeriste Julián. EStoy contandoles.


Back to Top
 
Julian
Post: Jun 4th 2008 at 1:28 PM

> la combinación REal time sequencer y Java Sound Synthesizer ha hecho que suene mi tuxguita

Es que se esta repitiendo el problema que explique sobre java sound api y OSS.
intenta probar usando "alsa-oss"
o sino usa puertos ALSA ( timidity )

"midi unavailible" es lanzado por tuxguitar-jsa.
puede ser por "Real Time Sequencer" o por "Java Sound Synthesizer"
1_ Olvidate del sequencer. selecciona "TuxGuitar Sequencer" y deja ese..
2_ concentrate en MIDI Port. que es ahi donde se produce el sonido.

Hiciste la prueba ?
aplaymidi --port 128:0 TuArchivo.mid


Back to Top
 
luis jaime
Post: Jun 11th 2008 at 4:43 PM

Volví, hice la prueba y suenan las dos notas primeras y me quedó ahí no sé como pararlo.


Back to Top
 
luis jaime
Post: Jun 11th 2008 at 4:50 PM

Uff por fín, tuve que matar los procesos del tux guitar y del java.

Veo que suena pero sólo las primeras notas y quedan sonando. Ahora volví a cargar el tuxguitar y está reproduciendo sin problemas.

Una especulación que tengo es que el pulse audio si se está conectado a la red busca un servidor en la misma para la reproducción.

Otra es que por alguna razón haya habido un proceso pendiente y con el hecho de haber matado estos procesos que se crearon al realizar aplaymidi se "hayan limpiado" y por tal razón esté funcionando.

si sigo teniendo problemas me comunico nuevamente.


Back to Top
 
luis jaime
Post: Jun 11th 2008 at 4:51 PM

nuevamente gracias julian


Back to Top
 
luis jaime
Post: Jun 11th 2008 at 9:29 PM

... cuando maté los procesos en realidad maté el servidor de pulse audio. Tal parece que entra en conflicto con pulse audio. El tuxguitar cuando está pulse audio en funcionamiento (utiliza alsa como base) no suena, si lo mato si, qué hago para que no me excluya el uno al otro?


Back to Top
 
Julian
Post: Jun 11th 2008 at 10:27 PM

Bueno mira, tuxguitar de por si no es un sintetizador de sonidos, sino que se conecta a uno.

El que entra en conflicto con pulse audio es el sintetizador.
pero la pregunta es, al final que sintetizador (MIDI Port) seleccionaste ?

si estas usando "Java Sound Synthesizer" seguramente el problema sea el mismo que explique mas arriba.
Ese problema se da en determinadas tarjetas de sonido.. si apagas el server de pulse audio (o lo que fuere que entra en conflicto) te volvera a pasar cuando abras otra aplicacion..
Por otro lado, no me respondiste esto que pregunte antes: probaste con alsa-oss ?

Ahora, si el que tenes seleccionado es timidity, ya es un tema mas complejo para poder ayudarte ya que yo no soy desarrollador de timidty y no tengo idea de como funciona este internamente.


Back to Top
 
Emmanuel
Post: Jul 15th 2008 at 11:47 PM

Los amo!! pude solucionarlo. No sabría explicarles exactamente como, pero les comento que instalé timidity, tuxguitar-alsa, alsa-oss y después seguí las instrucciones de julian:

cita:
Julian
Post: Jun 2nd 2008 at 6:58 PM
probaste usar alsa-oss ?

sino lo mejor seria que instales timidity:
sudo apt-get install timidity freepats

despues anda al menu de tuxguitar "Tools -> Settings" y "Sound" donde esta el combo MIDI Port selecciona el puerto 128:0 de timidity.




Muchas gracias...


Back to Top
 
luis jaime
Post: Dec 8th 2008 at 12:27 AM

Después de un largo receso por causas laborales estoy nuevamente aquí.

Me alegro por Emmanuel. Pero yo sigo con mi problema. El tuxguitar no suena y no se qué hacer :(


Back to Top
 
Julian
Post: Dec 8th 2008 at 11:54 AM

Tantos posts en este hilo medio como que me marean..

En sintesis, que puerto tenes seleccionado en tuxguitar ?
que version exacta de ubuntu tenes ?


Back to Top
 
luis jaime
Post: Dec 11th 2008 at 4:01 AM

:(, te voy a conseguir una pastilla pa'l mareo ;-)

ubuntu 8.04

TiMidity port 0 [128:0] + tuxguitar sequencer

Doy
aplaymidi --port 128:0 ~/Lobos, Heitor Villa - Estudo n°1.mid
no suena, el totem me lo reproducía con anterioridad ahora nop


Back to Top
 
Julian
Post: Dec 11th 2008 at 9:31 AM

Creo que estas teniendo un problema conocido con ubuntu hardy y pulseaudio
Si "aplaymidi --port 128:0 file" no suena, entonces el problema esta mas alla de tuxguitar..

testea mejor iniciar timidity desde una consola:
timidity -iA -Os

te va a listar nuevos puertos ( seguramente 129:* )
y sin cerrar timidity,
en otra terminal intenta de nuevo:
aplaymidi --port 129:0 archivo....

si eso funciona el tema es definitivamente pulseaudio..
no encontre solucion a ese problema.. lo que hicieron muchos fue configurar Alsa como sistema de sonido por defecto en lugar de pulseaudio (lo cual no es una real solucion.. sino que es ocultar el problema )

En ubuntu intrepid el problema parece estar solucionado.

>> te voy a conseguir una pastilla pa'l mareo
Jeje... es que generalmente veo los posts cuando me despierto... y no entiendo nada a esa hora :) despues tengo que trabajar...


Back to Top
 
luis jaime
Post: Jan 8th 2009 at 1:36 AM

POR FIN!!!!!!!!!!!!

Actualicé a intrepid y no funcionó :(, pero acudí al foro de ubuntu colombia y me remitieron a:

http://ubuntuforums.org/showthread.php?t=789578

hice los pasos y voilá funcionó.

Gracias Julián por tu tiempo.

Estoy como niño estrenando juguete :)


Back to Top
 
leoarismac
Post: Jul 6th 2009 at 3:51 AM

ami no me sonaba el tux guitar pero por ahi vi que con synaptic buscas tuxguitar y le instalas todos los plugins y me suena ahora funciona perfecto creo que tuxguitar-jsa sirve

sistema/administración/gestor de paquetes synaptic


Back to Top