Tux Guitar

Suggestions

Subject Software mixer to improve sound compativility



Author Message
Ishmael
Post: Mar 25th 2008 at 8:17 PM

Hi there,
Is it possible to use software mixer with GNU/linux?

I think that would improve the compativility.
Up until now, I need to close xmms and mplayer before
openning TuxGuitar, and close TuxGuitar before opening
xmms, otherwise I get no sound.

At first I couldn't play with xmms and mplayer at the
same time, but after I set the software mixer in both
I have no problem.

By the way, tanks fot such a nice program.


Back to Top
 
Julian
Post: Mar 25th 2008 at 8:38 PM

Hi, i don't know what you mean with "software mixer",
but however, you'll solve your problem by using the alsa output.
See at Tools -> Settings : "Sound -> MIDI Port".
i'm sure you have "Java Sound Syntheziser" selected,
that synth use the OSS output, what have conflicts with other sound apps.
if you install any software synth like "timidity" and then select it on tuxguitar you'll don't have this problem.


Back to Top
 
Ishmael
Post: Mar 25th 2008 at 9:23 PM

I used to use timidity with TuxGuitar .9, but is a little
hard to compile it with the right options, and the package
for centos doesn't have the -iAqqq option (I don't have
timidity right now).

Also I like more the current sound output since timidity
is a little slow (or so I think).

I don't know how the software mixer works either but in
mplayer->preferences->audio, in the check box below there
is software mixer (it seems that it only works for alsa
and not for oss)

in xmms is in options->preferences->configure output plugin->
(alsa)->use software volume control

winecfg->audio->(direct sound) driver emulation


Back to Top
 
Julian
Post: Mar 25th 2008 at 9:35 PM

Ok, i don't know about centos.
another option is "fluidsynth", but you need search for soundfonts on the web ( i suggest you "Unison" ).

about mplayer, xmms and wine.. they are not the problem.
is Java Sound Api who use OSS as output, and OSS is known becase that problem.
There is a wrapper called "alsa-oss" to solve that problem:
~$ aoss tuxguitar

But that don't work for all users ( i don't know why ), so you can test that.


Back to Top